Jump to content

[Guide] macOS Sierra 10.12.x on ASRock H170M-ITX/ac

* * * * * 3 votes asrock h170m clover skylake sierra

  • Please log in to reply
327 replies to this topic

#321
fixpol

fixpol

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:POLAND

What you mean  condensed solution? It is relative simple.

1.Upgrade to 10.12.5. Probably  you will lost your desktop.

2.Use  fake graphic id in  clover options i.e. 12345678 or  whatever. You will be back in your desktop with  slow graphic 8mb VRAM. 

3. Download newest AppleALC.kext and replace in  clover/kexts/other.

4. Add in config.plist  in  kext to patch section 

<dict>                 

    <key>Comment</key>
    <string>10.11-SKL-1912000-4_displays</string>
    <key>Find</key>
    <data>
    AQMDAw==
    </data>
    <key>Name</key>
    <string>AppleIntelSKLGraphicsFramebuffer</string>
    <key>Replace</key>
    <data>
    AQMEAw==
    </data>
</dict>

 

5.Check if  inject intel is true  and looks like this

 

<key>Graphics</key> 

<dict>
        <key>Inject</key>
        <dict>
            <key>ATI</key>
            <false/>
            <key>Intel</key>
            <true/>
            <key>NVidia</key>
            <false/>
        </dict>
        <key>ig-platform-id</key>
        <string>0x19120000</string>
</dict>

 

6.Dowload latest Lilu. kext and Intelgraphicsfixup.kext on desktop . Use  Kext Beast to install this two together in S/L/E.

7. Reboot normally 

Thats all.



#322
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 46 posts
  • Gender:Male
  • Location:the Netherlands

What you mean condensed solution? It is relative simple.
[...].

This is exactly what I needed, thank you very much.
I gonna try this as soon as possible.

#323
luckybear333

luckybear333

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Great post. Try the guide on ASRock H110-ITX, worked. Thanks a lot.



#324
Denicio

Denicio

    InsanelyMac Sage

  • Donators
  • 446 posts
  • Gender:Male
  • Location:Greece

Great post. Try the guide on ASRock H110-ITX, worked. Thanks a lot.

Thanks for letting us know, enjoy your hack :)



#325
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 46 posts
  • Gender:Male
  • Location:the Netherlands

What you mean  condensed solution? It is relative simple.

[...]

 

- first installed Clover_v2.4k_r4114
- reboot
- made Time Machine-backup !
- installed 10.12.5
- reboot with fake ig-platform-id
- placed AppleALC.kext (v1.1.2) in /EFI/CLOVER/kexts/Other
- placed Lilu.kext (v1.1.4) and Intelgraphicsfixup.kext (v1.1.5) in /EFI/CLOVER/kexts/Other
- added earlier mentioned text in config.plist in 'kext to patch' section to replace 'AQMDAw==' with 'AQMEAw=='
- reboot normally with ig-platform-id 1912000

- succes!

 

So I only changed the installation path of Lilu.kext and Intelgraphicsfixup.kext to /EFI/CLOVER/kexts/Other

 

Thank you very much for your help!



#326
Denicio

Denicio

    InsanelyMac Sage

  • Donators
  • 446 posts
  • Gender:Male
  • Location:Greece

- first installed Clover_v2.4k_r4114
- reboot
- made Time Machine-backup !
- installed 10.12.5
- reboot with fake ig-platform-id
- placed AppleALC.kext (v1.1.2) in /EFI/CLOVER/kexts/Other
- placed Lilu.kext (v1.1.4) and Intelgraphicsfixup.kext (v1.1.5) in /EFI/CLOVER/kexts/Other
- added earlier mentioned text in config.plist in 'kext to patch' section to replace 'AQMDAw==' with 'AQMEAw=='
- reboot normally with ig-platform-id 1912000

- succes!

 

So I only changed the installation path of Lilu.kext and Intelgraphicsfixup.kext to /EFI/CLOVER/kexts/Other

 

Thank you very much for your help!

 

Doesn't everyone mention that you can't run lilu.kext from CLOVER's location? I thought you need to explicitly put it on S/L/E.



#327
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 46 posts
  • Gender:Male
  • Location:the Netherlands

Doesn't everyone mention that you can't run lilu.kext from CLOVER's location? I thought you need to explicitly put it on S/L/E.

 

I installed Lilu.kext and Intelgraphicsfixup.kext, still in 10.12.4, in several locations and it crashed always (expected...).

I could stop the crashing by adding parameter -igfxoff and -liluoff.

That also worked when the kexts were in the /EFI/CLOVER/kexts/10.12 location so I think the kexts were handled correctly, because the extra disable-parameter was interpreted.

Then I moved them to /EFI/CLOVER/kexts/Other and it stil works.

 

I have a feeling that it is better to handle non-Apple kexts not direclty in the local harddisk?

 

Update: with Kext Wizard.app I can see on the last tab that they are both loaded.



#328
fixpol

fixpol

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:POLAND

Just installed High Sierra  Beta 2 on external  drive, and sound , wifi, works fine but cannot pass HD530 graphics as 10.12.5  fix no longer works.

Attached Files







Also tagged with one or more of these keywords: asrock, h170m, clover, skylake, sierra


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy