Jump to content

El Capitan - Sierra - High Sierra - Sony Vaio E Series (2012) - SVE1712W1EB - AMD Radeon HD 7650M

* * * * - 1 votes Sony El Capitan Ati Dsdt Brightness fix Gradient fix Ivy bridge Battery Fan RPM Sierra

  • Please log in to reply
46 replies to this topic

#21
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

Hey did u install clover 4035 or any 4K !

m getting black screen after i upgraded to 4K clover.

 

RM Sir, told there is a new way of patching ATI connector in 4K

 

slice sir can u guide us !



#22
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

My  AMD Radeon HD 7650M is not working in 10.12.5(clover 4077), it was previously working gr8 in 10.11.6(clover 3974)

how can i get it work again ! :( 



#23
Onestyle

Onestyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male

Hey did u install clover 4035 or any 4K !
m getting black screen after i upgraded to 4K clover.

RM Sir, told there is a new way of patching ATI connector in 4K

slice sir can u guide us !

Haven't yet went on high Sierra so no reason for me to update to latest clover,but I'll look into it today and see what's up. First off, what's not working,the screen or there is no qe/ci(no acceleration)??. If screen is the issue then it's edid injection,if it's qe/ci then it's kexts patching aka framebuffer.

Might be this is the reason,just a wild guess after looking into clover changes:
<key>Graphics</key>
<dict>
<key>EDID</key>
<dict>
<key>Custom</key>
<data> bla bla bla edid </data>
<key>Inject</key>
<true/>
<key>VendorID</key> // this is the new thing for edid
<string>0x1006</string>
<key>ProductID</key> this is the new thing for edid
<string>0x9221</string>
</dict>



Rev 3737
We can fake our EDID to be like Apple's one.
Also changes in config.plist (old config also supported)
Rev 4058
Updated EDID injection by Sherlocks.
There are no more old keys "CustomEDID" and "InjectEDID".

Edited by Onestyle, 08 June 2017 - 08:21 AM.


#24
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

ROM is main issue, whenever i inject ROM panic comes. But all setting was same in 10.11.6 n worked gr8.

 

Attached Files



#25
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

Hey bro thanks alot it worked  :)

But it is showing AMD Radeon HD 6xxx 1024MB  :(

 

Still lot to do :(


Wish AMD Community had all in one solution for AMD cards !

1.Dump Radeon Bios

2.Use AMDFrameBufferUtility to patch

3.Clover Injections

etc



#26
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

Ny update on 10.13 !



#27
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

@Nonta97, as u requested :)


Clover configuration-Graphics : 

set Dual Link : 0 , FB Name : Pondweed , Vram : 1,024 , Video Ports : 3 , Check Load Vbios ,Inject Edid , Inject ATI .
3. Clover configuration- Kernel and Kext Patches : 
Name : AMD6000Controller

use AMDFramebufferUtilty to get best result.

 

 

And @Onestyle y is ur Fake ID : ATI : 0x67411002 instead of 0x68411002

Attached Files



#28
Nonta72

Nonta72

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

@Nonta97, as u requested :)


Clover configuration-Graphics : 

set Dual Link : 0 , FB Name : Pondweed , Vram : 1,024 , Video Ports : 3 , Check Load Vbios ,Inject Edid , Inject ATI .
3. Clover configuration- Kernel and Kext Patches : 
Name : AMD6000Controller

use AMDFramebufferUtilty to get best result.

 

 

And @Onestyle y is ur Fake ID : ATI : 0x67411002 instead of 0x68411002

 

Thanks

Can you upload your entire CLOVER folder (remove themes to reduce the size)?

I have already tried this many times, same results: Black screen.

And it is Nonta72 by the way, hahahahahhhh



#29
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

Make sure u have ur own EDID :)


DualLinke = 1 if ur intel HD 4000 is working, else 0(it make difference, gives black screen)


N also post ur details/procedures, so that one can help u :) 

Attached Files



#30
Nonta72

Nonta72

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Make sure u have ur own EDID :)


DualLinke = 1 if ur intel HD 4000 is working, else 0(it make difference, gives black screen)


N also post ur details/procedures, so that one can help u :)

Thank you!!!

I now have Full QE/CI using your files.

For the details, you can find them on my signature (same config as you, except mine ends with FW instead of NB which is just regional difference I guess).

Now I will fix the remaining bugs and will install 10.12 on another partition. Together we can try to figure out why the graphics won't work on 10.12.



#31
Onestyle

Onestyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male

Thank you!!!
I now have Full QE/CI using your files.
For the details, you can find them on my signature (same config as you, except mine ends with FW instead of NB which is just regional difference I guess).
Now I will fix the remaining bugs and will install 10.12 on another partition. Together we can try to figure out why the graphics won't work on 10.12.


Graphics works on 10.12

#32
Nonta72

Nonta72

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Graphics works on 10.12

 

That's good news!

Have you got the graphics to work on 10.11 without the framebuffer patch?

Because I think I have been doing the whole thing very wrong. I just found out that Cattail and Fanwort (probably Kudzu and Lotus too) work without the patch. I just checked InjectEDID, LoadVBIOS, InjectATI and disabled your AMD6000Controller patch. After reboot, I have now QE/CI. LVDS is what matters to me right now, VGA and HDMI can wait.



#33
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

Thank you!!!

I now have Full QE/CI using your files.

For the details, you can find them on my signature (same config as you, except mine ends with FW instead of NB which is just regional difference I guess).

Now I will fix the remaining bugs and will install 10.12 on another partition. Together we can try to figure out why the graphics won't work on 10.12.

Sharing is Caring :)

 

OnsStyle did a gr8 Job by creating this Thread with a gr8 Details :)



#34
Nonta72

Nonta72

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Sharing is Caring :)

 

OnsStyle did a gr8 Job by creating this Thread with a gr8 Details :)

Yeah, indeed!

I'm still struggling to get brightness slider working. I used the patch provided by the OP, the brightness slider appeared but won't change the brightness (brightness keys won't change it either).

Do you mind sharing your DSDT patches?

If I use your patched DSDT, I get it working fine. But I'd like to know how you did it for future uses.



#35
SiddRamesh

SiddRamesh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Mumbai
  • Interests:Developing

Yeah, indeed!

I'm still struggling to get brightness slider working. I used the patch provided by the OP, the brightness slider appeared but won't change the brightness (brightness keys won't change it either).

Do you mind sharing your DSDT patches?

If I use your patched DSDT, I get it working fine. But I'd like to know how you did it for future uses.

Ive used this DSDT Patches,

1.Audio (layout-id 3)

2.IRQ Fix
3.TNOT Fix
4.Brightness Fix
5.7Series/8Series USB


In MacIasl app, add RehabMan's repo(DSDT Patches).



#36
Onestyle

Onestyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male

Yeah, indeed!

I'm still struggling to get brightness slider working. I used the patch provided by the OP, the brightness slider appeared but won't change the brightness (brightness keys won't change it either).

Do you mind sharing your DSDT patches?

If I use your patched DSDT, I get it working fine. But I'd like to know how you did it for future uses.

 

Brightness slider shows but doesn't do anything,that's strange cause it works for me. Have you did this part in dsdt

 

2a. Find in your dsdt: 
Device (LID0)
{
Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID



2b. replace
Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

with

 Name (_HID, EisaId ("LCD1234")) // _HID: Hardware ID



#37
Nonta72

Nonta72

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Ive used this DSDT Patches,

1.Audio (layout-id 3)

2.IRQ Fix
3.TNOT Fix
4.Brightness Fix
5.7Series/8Series USB


In MacIasl app, add RehabMan's repo(DSDT Patches).

 

Alright, I will apply these patches and see.

 

Brightness slider shows but doesn't do anything,that's strange cause it works for me. Have you did this part in dsdt

 

2a. Find in your dsdt: 
Device (LID0)
{
Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID



2b. replace
Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

with

 Name (_HID, EisaId ("LCD1234")) // _HID: Hardware ID

 

Yeah, I did that part. Apparently, siddRamesh did not do that part. I tried both cases i.e changing the EisaId and not changing it. All ended up with the same results.

I noticed something strange. I checked siddRamesh's patched DSDT and the PNLF device isn't under a scope. It's just on the very end of the DSDT.

But whenever I patch mine, it goes under a new _SB scope. Can that be the problem?

This is the end of his patched DSDT:

    Name (_S5, Package (0x04)  // _S5_: S5 System State
    {
        0x07, 
        Zero, 
        Zero, 
        Zero
    })
    Device (PNLF)
    {
        Name (_ADR, Zero)  // _ADR: Address
        Name (_HID, EisaId ("APP0002"))  // _HID: Hardware ID
        Name (_CID, "backlight")  // _CID: Compatible ID
        Name (_UID, 0x0A)  // _UID: Unique ID
        Name (_STA, 0x0B)  // _STA: Status
    }
}

I also checked RehabMan's patches and the brightness patch that you provided, none of them seem to contain the comments that are actually in his DSDT i.e // _ADR: Address for example.



#38
Onestyle

Onestyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male

Alright, I will apply these patches and see.
 

 
Yeah, I did that part. Apparently, siddRamesh did not do that part. I tried both cases i.e changing the EisaId and not changing it. All ended up with the same results.
I noticed something strange. I checked siddRamesh's patched DSDT and the PNLF device isn't under a scope. It's just on the very end of the DSDT.
But whenever I patch mine, it goes under a new _SB scope. Can that be the problem?
This is the end of his patched DSDT:

Name (_S5, Package (0x04)  // _S5_: S5 System State
    {
        0x07, 
        Zero, 
        Zero, 
        Zero
    })
    Device (PNLF)
    {
        Name (_ADR, Zero)  // _ADR: Address
        Name (_HID, EisaId ("APP0002"))  // _HID: Hardware ID
        Name (_CID, "backlight")  // _CID: Compatible ID
        Name (_UID, 0x0A)  // _UID: Unique ID
        Name (_STA, 0x0B)  // _STA: Status
    }
}
I also checked RehabMan's patches and the brightness patch that you provided, none of them seem to contain the comments that are actually in his DSDT i.e // _ADR: Address for example.

Quick question,is the brightness changing in system preferences?? If it is,update to the latest voodoo PS2

#39
Nonta72

Nonta72

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Quick question,is the brightness changing in system preferences?? If it is,update to the latest voodoo PS2

 

I have the latest PS2 driver. And no, brightness doesn't change in system preferences or with the Fn keys (Fn+F5 and Fn+F6)



#40
Onestyle

Onestyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male

I have the latest PS2 driver. And no, brightness doesn't change in system preferences or with the Fn keys (Fn+F5 and Fn+F6)



Okay,PNLF issue then,put your whole clover folder here,without themes,and I'll check it out later on when I have time.





Also tagged with one or more of these keywords: Sony, El Capitan, Ati, Dsdt, Brightness fix, Gradient fix, Ivy bridge, Battery, Fan RPM, Sierra


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy