Jump to content

Power management may be incomplete or unsupported


  • Please log in to reply
3 replies to this topic

#1
christian1992usb

christian1992usb

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi everyone, finally I managed to have a successful installation of Niresh's Yosemite Zone 10.10.1 on my AMD configuration with this specs :

Mobo: Asus M5A97 EVO r2.0

CPU: AMD FX6300

GPU: Sapphire Radeon r9 270x vapor x

HDD: Western Digital Caviar Blue 1tb

Ram: 8gb 1600mhz corsair vengeance

I boot with /amd npci=0x2000 -v and the installation has completed successfully but when the PC restarts and when I boot with npci=0x3000, computer shows me a grey screen with an infinite spinning beachball cursor. I can only enter Yosemite in safe mode whit boot flag "-x". I tried lots of boot flags include "GraphicsEnabler=No" and the result is always the same grey screen. I've set the uefi bios disabling Vtd, turning on AHCI and so on without result. When I boot in Verbose mode with bootflag "-v" the black screen with white signs shows me after PCI configuration :

"Warning: IOPlatformPluginUntil : GetCPUIDInfo: this is an unknown CPU model 0x3a
--Power management may be incomplete or unsupported"



Please help me

#2
Hervé

Hervé

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,955 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

You've got an AMD CPU, that's not used by Apple nor natively supported by OS X, hence no CPU power management. That's perfectly normal. Only Intel CPU can enjoy proper native CPU power management. This being said, your issue has nothing to do with CPU power management.

 

If you booted your installer successfully with option npci=0x2000, I'm failing to understand why you switched to npci=0x3000 afterwards. Just make sure you've installed a FakeSMC kext to your installation, that's absolutely mandatory.



#3
JahStories

JahStories

    Elijah

  • Donators
  • 2,787 posts
  • Gender:Male
  • Location:Tyson III

@herve

About the rules, we do not support any commercial project or distro, but Niresh is not commercial and it can discussed freely on IM.

Of course, we strongly suggest using official installers to be aware on what are we running and installing



#4
Shaneee

Shaneee

    InsanelyMac Deity

  • Local Moderators
  • 2,243 posts
  • Gender:Male
  • Location:Fife, Scotland

As Herve mentioned it's normal on AMD systems. You can use VoodooPState to get better power management. Install the kext to either Extra/Extensions or System/Library/Extensions and the app to the Applications folder and set the app to run on startup.

 

Attached File  PState.zip   499.37KB   16 downloads

 

If npci=0x2000 worked then use that but I also recomend you update the kernel as the one bundled is not up to date. Use this kernel instead, http://nova-x.co.uk/...10.10.5_rc1.zip

 

Place it in the root of your HDD and instead of /amd use /kernel







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy