Jump to content

Kext para Dell Inspiron 5420


Best Answer matmagico1, 10 November 2015 - 03:20 PM

Boa tarde,

 

         Atualizando o tópico, meu hackintosh está com 99% ok  :thumbsup_anim:  :hysterical:

 

      

  •         Video: OK, funcionando a HD4000 com HDMI e som. (* Pena não funcionar a GT 630M  :().
  •         Audio: OK, funcionando com VoodooHDA.
  •         Bateria: OK, funcionando aplicado o patch prontos do repositório do rehabman, (sugestão do mendietinha) + ACPIBatteryManager.kext.
  •         Teclado e mouse: Ok, funcionando com VoodooPS2Controller.kext
  •         Ethernet: OK, funcionando com a ALXEthernet.kext
  •         Wifi: OK, troquei o cartão wifi por um compatível com MAC (DELL 1515).
  • ​        Sleep e Hibernação: Ok, funcionando com patch XHCI, EHCI1 e EHCI2 + Unlocked-Ver.1.0.11-PXHCD.kext (Usado o tutorial do Allan).
  •         SSD: Ok, funcionando trim. 
  •         Cartão de Memória: Não funciona, acho que é incompatível  :unsure:
  •         USB 3.0: Ok, funcionando. 

         

         Quero agradecer novamente a ajuda do Allan e do mendietinha, continuem assim que o mundo hackintosh não terá limites....

Go to the full post


  • Please log in to reply
15 replies to this topic

#1
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

Boa tarde,

 

         Galera faz tempo que não apareço por aqui... venho procurar ajuda de vcs, instalei no meu notebook o El captain 10.11.1 e as minhas kexts do mavericks não estão funcionando nele, a não ser a kext de lan... resumindo estou sem som, sem video, sem wireless e sem gerenciamento do processador. Rodei o system info e diferente do mavericks todos os componente do meu notebook estão verde incluindo a minha nvidia GT 630M, está certo isso ? Vou anexar a imagem do system info. Para fazer a DSDT o método é o mesmo do mavericks ou mudou tambem?

 

          Desde já agradeço a ajuda.

 

         

 

 

       

Attached Files



#2
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,461 posts
  • Gender:Male

Bem quando sai algum OS novo, eu costumo usar sempre as novas do OS. Pode fazer aplicando os patchs denovo, ou caso tenha baixado de um desenvolvedor especifico, provavelmente ele deve ter lançado na pag de downloads.

 

E como assim estão "verdes"?



#3
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
Fala Allan quanto tempo heim.
Então o system info marca que todos os componentes do meu note são compatíveis... no Mavericks a placa de rede wireless e a Nvidia não eram compatíveis.

#4
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,461 posts
  • Gender:Male

Entendi.

O que dá pra você fazer é o seguinte, atualiza o que funciona.

Raramente um hardware fica compatível simplesmente por causa de uma nova versão do OS X, as vezes nunca.

 

Depois de fazer funcionar aquilo que já usa, procure informações sobre seu WiFi e Nvidia com o novo OS X, mas é 100% de chances que nada mudou...



#5
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

Allan boa noite.

 

    Consegui instalar quase todas as kext, video, audio e até o gerenciamento do processador, as temperaturas dos núcleos não passam de 60º  :thumbsup_anim:, porem ainda existe dois problemas e uma duvida. 

     1º problema: ao conectar o note na TV através da porta HDMI, aparece na TV o nome DVI e por isso estou sem som, você saberia qual o método para mudar isso?eu usei o hackintosh taiwan tools.

      2ºproblema: o mac não está reconhecendo a minha bateria, pesquisei na internet vários métodos mais nenhum funcionou, DSDT, ACPIBattery manager, voodoobattery, você saberia como resolver esse problema?

      3º duvida: essa instalação eu fiz num hd de 500GB de teste que tenho em casa, será que posso fazer o mesmo processo no meu SSD 120GB, será que muda muita coisa? 

      Lembrando que o mac os x que instalei é o el captain 10.11.1

      Segue a minha DSDT.aml e o config.plist, mas SSDT.aml eu não criei pois estou deixando o clover gerenciar.

Attached Files



#6
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,461 posts
  • Gender:Male

1 - Como habilitou a saida HDMI? E lembrando que para controlar o Som nesses casos é o Televisor e não o Mac.

2 - Isso é complicado, geralmente usando ACPIBattery + DSDT era para aparecer a porcentagem, limpou os caches e reparou o sistema?

3 - Não tem problema algum, o método é o mesmo tanto em HDDs quanto em SSDs.



#7
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
Eu usei o programa hackintosh Vietnam tools para patchear a kext AppleintelcapriFB.kext, ao conectar a minha TV ela não entra como HDMI e sim como DVI o som não sai nem aumentando o volume da TV. Questão da bateria, sim limpei os caches e reparei o sistema, porem nunca tinha feito o esquema B1B2 na dsdt então não sei se esta certo.

#8
mendietinha

mendietinha

    mendi

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,184 posts
  • Gender:Male
  • Interests:full hackintosh.

ssdt gere com script do piker usando workaround -w 3. bateria use maciasl e veja os patches prontos do repositório do rehabman, certamente um dos dell de lá servem pro teu. 

 

hdmi pro som veja o tópico do allan sobre, e não use essas ferramentas, tente subir com inject intel e 0x01660003. caso a tela fique com artefatos, precisará injetar propriedades do fb4 no 3, e ai para usar o hdmi precisarás trocar de dsdt e config.plist e dar reboot a cada vez.

 

se subir sem problemas com 0x01660003, só precisas do patch que o allan mostra no tutorial daqui de como ativar o som no hdmi com hd4k.



#9
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
Ok vou faze isso, já gerei o ssdt.aml quando tinh Mavericks instalado mas como faço para usar esse workaround -w? Nunca usei esse maciasl sempre editei meu dsdt com o dsdt editor, no Mavericks a bateria funcionava com a voodoobattery e a AICPUmonitor. Eu já uso as flags inject Intel e a ig-platform-id igual a 0x01660003, mas na TV aparece como DVI e não HDMI, DVI não tem som mesmo.

#10
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

Bom dia.

   Atualizando o tópico, meu hackintosh está com 95% ok, tenho video, tenho audio, Trim ativado com o meu SSD, todos as 4 USB funcionando, quero agradecer a ajuda do Allan e do mendietinha. Gostaria de tirar duas duvida:

1. Ao reiniciar ou desligar o meu notebook ele apaga a tela, porém somente depois de 1min que ele desliga completamente, isso é normal no el capitan, pois no mavericks ele desligava rápido e nem era SSD ainda.  

 2. Não estou conseguindo ter sleep, ja fiz quase todos os tutoriais do Allan e da internet, qual será o problema, pois no mavericks funcionava bem.

 

Obrigado novamente pela atenção.



#11
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,461 posts
  • Gender:Male

Eu notei uma lerdeza nesse El Capitan pra desligar tambem. Mas senti uma pequena diferença quando atualizei pra versão 10.11.1

 

Sobre o Sleep isso nem sempre é garantido, como você tem uma placa off-board, se a mesma não é desativada corretamente, pode acarretar nesses problemas.



#12
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
O problema de desligar/reiniciar que estava demorando era por conta da minha wirelesss mini usb dw131, foi só instalar a minha Dell 1515 onbord que resolveu o problema. Faltando agora o sleep, mas tudo ok quase nem uso o sleep. Para mim está 100% agora. Allan ouvi fala sobre o metal para hd4000 ele já vem no el captain ou tem que abaixar e instalar?

#13
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,461 posts
  • Gender:Male

Com relação ao Sleep, geralmente dispositivos Bluetooth/Wireless USB causam problemas.

Veja um guia que expliquei como ativar o Sleep ou Hibernação.

 

O Metal é uma tecnologia que permite aos dispositivos rentabilizar o desempenho gráfico sem que seja necessário um update de componentes físicos, podendo aumentar

até 40% a renderização grafica.

 

E ele já vem incluido no OS X, não tem como remover/adicionar.



#14
matmagico1

matmagico1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

Best Answer

Boa tarde,

 

         Atualizando o tópico, meu hackintosh está com 99% ok  :thumbsup_anim:  :hysterical:

 

      

  •         Video: OK, funcionando a HD4000 com HDMI e som. (* Pena não funcionar a GT 630M  :().
  •         Audio: OK, funcionando com VoodooHDA.
  •         Bateria: OK, funcionando aplicado o patch prontos do repositório do rehabman, (sugestão do mendietinha) + ACPIBatteryManager.kext.
  •         Teclado e mouse: Ok, funcionando com VoodooPS2Controller.kext
  •         Ethernet: OK, funcionando com a ALXEthernet.kext
  •         Wifi: OK, troquei o cartão wifi por um compatível com MAC (DELL 1515).
  • ​        Sleep e Hibernação: Ok, funcionando com patch XHCI, EHCI1 e EHCI2 + Unlocked-Ver.1.0.11-PXHCD.kext (Usado o tutorial do Allan).
  •         SSD: Ok, funcionando trim. 
  •         Cartão de Memória: Não funciona, acho que é incompatível  :unsure:
  •         USB 3.0: Ok, funcionando. 

         

         Quero agradecer novamente a ajuda do Allan e do mendietinha, continuem assim que o mundo hackintosh não terá limites....



#15
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,461 posts
  • Gender:Male

Valeu por ter reportado o sucesso.

 

;)



#16
xAndre

xAndre

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male

Boa tarde,

 

         Atualizando o tópico, meu hackintosh está com 99% ok  :thumbsup_anim:  :hysterical:

 

      

  •         Video: OK, funcionando a HD4000 com HDMI e som. (* Pena não funcionar a GT 630M  :().
  •         Audio: OK, funcionando com VoodooHDA.
  •         Bateria: OK, funcionando aplicado o patch prontos do repositório do rehabman, (sugestão do mendietinha) + ACPIBatteryManager.kext.
  •         Teclado e mouse: Ok, funcionando com VoodooPS2Controller.kext
  •         Ethernet: OK, funcionando com a ALXEthernet.kext
  •         Wifi: OK, troquei o cartão wifi por um compatível com MAC (DELL 1515).
  • ​        Sleep e Hibernação: Ok, funcionando com patch XHCI, EHCI1 e EHCI2 + Unlocked-Ver.1.0.11-PXHCD.kext (Usado o tutorial do Allan).
  •         SSD: Ok, funcionando trim. 
  •         Cartão de Memória: Não funciona, acho que é incompatível  :unsure:
  •         USB 3.0: Ok, funcionando. 

         

         Quero agradecer novamente a ajuda do Allan e do mendietinha, continuem assim que o mundo hackintosh não terá limites....

Você tem o Hackintosh funcional ainda? Tenho o mesmo notebook, você poderia postar os arquivos de configuração? Obrigado.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy