Jump to content

Nvidia Web Driver updates for El Capitan (UPDATE 05/16/2017)

nvidia web driver updates el capitan 10.11

  • Please log in to reply
691 replies to this topic

#41
Havenger

Havenger

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male

I'm using a GTX 980 and with latest NVIDIA WebDriver 346.03.01b07 my TFT switches after successful Init of GPU ( NVDAStartup:Web ) to Energy-saving Mode. With Yosemite I can boot withou Problems - same with "nv_disable=1". Is there any hope to get the GTX working ?

 

Hope NVIDIA will fix this until to the Release …



#42
KWS

KWS

    InsanelyMac Protégé

  • Donators
  • 90 posts

DP 8 works with 346.03.01b07



#43
arsradu

arsradu

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,261 posts
  • Gender:Male

DP 8 works with 346.03.01b07

wanted to share or asking?

#44
levifig

levifig

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male

Anybody tested 346.03.01b07 with PB6? 

 

Pretty thanks. :)



#45
arsradu

arsradu

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,261 posts
  • Gender:Male

Anybody tested 346.03.01b07 with PB6?

Pretty thanks. :)

Yeah. Works no problem.

#46
KWS

KWS

    InsanelyMac Protégé

  • Donators
  • 90 posts

wanted to share or asking?

Share, in this case ... :-)



#47
rhcp011235

rhcp011235

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
  • Gender:Male
  • Location:Charlotte,NC

Sorry to re-post but it seems my previous post has been ignored or no one knows?

 

I am running the 

Chipset Model: NVIDIA GeForce GTX 970

  Type: GPU

  Bus: PCIe

  Slot: PCI Slot 0

  PCIe Lane Width: x16

  VRAM (Total): 4095 MB

  Vendor: NVIDIA (0x10de)

  Device ID: 0x13c2

  Revision ID: 0x00a1

  ROM Revision: VBIOS 84.04.2f.00.72

 
Gigabyte GeForce GTX 970 Mini ITX Overclocked 4GB GDDR5 PCiE Video Card GV-N970IXOC-4GD

 

It works for the most part on B07 (But will instant reboot if I try to use native OS X drivers)

 

I am noticing some Graphical glitches every now and again. I am using DUAL 34" LG ultra wide PLS displays via Display port

 

Anyone have any ideas how to better this? or any info?

 

Thanks



#48
arsradu

arsradu

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,261 posts
  • Gender:Male

Sorry to re-post but it seems my previous post has been ignored or no one knows?

 

I am running the 

Chipset Model: NVIDIA GeForce GTX 970

  Type: GPU

  Bus: PCIe

  Slot: PCI Slot 0

  PCIe Lane Width: x16

  VRAM (Total): 4095 MB

  Vendor: NVIDIA (0x10de)

  Device ID: 0x13c2

  Revision ID: 0x00a1

  ROM Revision: VBIOS 84.04.2f.00.72

 
Gigabyte GeForce GTX 970 Mini ITX Overclocked 4GB GDDR5 PCiE Video Card GV-N970IXOC-4GD

 

It works for the most part on B07 (But will instant reboot if I try to use native OS X drivers)

 

I am noticing some Graphical glitches every now and again. I am using DUAL 34" LG ultra wide PLS displays via Display port

 

Anyone have any ideas how to better this? or any info?

 

Thanks

Not really, man.

 

And, although sometimes posts can get lost due to large number of people posting, sometimes patience is the key. :)

 

Now, I wish I had at least one of your displays... :))) I'm dying to get my hands on a PLS display from Samsung. ONE. I can't even dream of two. :)

 

Anyway, sometimes, you can try fixing this by clearing kernel cache with this command (and reboot after):

sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/Startup/*
reboot now

I'm usually doing it in Single-user verbose mode. For that, you would need to do one extra step to get the system in read-write mode:

/sbin/mount -uw /
rm -r -v /System/Library/Caches/com.apple.kext.caches/Startup/*
reboot now

Sometimes it helps with the reboots. And, at least for the purpose of this test, try to disable SIP (in case you haven't already). See if that makes any difference.

 

Also, if you're on DP7, try to upgrade to DP8, see if that helps.



#49
levifig

levifig

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male

Not really, man.

 

And, although sometimes posts can get lost due to large number of people posting, sometimes patience is the key. :)

 

Now, I wish I had at least one of your displays... :))) I'm dying to get my hands on a PLS display from Samsung. ONE. I can't even dream of two. :)

 

Anyway, sometimes, you can try fixing this by clearing kernel cache with this command (and reboot after):

sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/Startup/*
reboot now

I'm usually doing it in Single-user verbose mode. For that, you would need to do one extra step to get the system in read-write mode:

/sbin/mount -uw /
rm -r -v /System/Library/Caches/com.apple.kext.caches/Startup/*
reboot now

Sometimes it helps with the reboots. And, at least for the purpose of this test, try to disable SIP (in case you haven't already). See if that makes any difference.

 

Also, if you're on DP7, try to upgrade to DP8, see if that helps.

 

More importantly, this is hijacking the thread, which is bad. If you want help with your setup (which a perfectly legit thing), please create a thread for that in the appropriate forum section. This thread is for updates regarding Nvidia's Web Driver in El Capitan, which is why you're not seeing any help coming regarding your question. This is just basic forum etiquette. 

 

Considering the above, I'd point out that there's no such thing as "native drivers" for the GTX 970. Instant reboots could be caused by a myriad of issues and without your specific boot log, it'll be hard to help… which shouldn't happen in this thread anyway. Your setup seems to be working anyway, so I'm not sure what the issue is. When you do create the proper post, make sure to include pictures (ideally photos, not screenshots) of said glitches. Your setup is quite atypical (dual 34'' via DP) so there are tons of things that can affect your experience. With such a setup, sometimes your best bet is a proper Mac because with a hackintosh, you're always gambling (and most of us are fine with it)… :)

 

Have a good day.



#50
rhcp011235

rhcp011235

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
  • Gender:Male
  • Location:Charlotte,NC

Not really, man.

 

And, although sometimes posts can get lost due to large number of people posting, sometimes patience is the key. :)

 

Now, I wish I had at least one of your displays... :))) I'm dying to get my hands on a PLS display from Samsung. ONE. I can't even dream of two. :)

 

Anyway, sometimes, you can try fixing this by clearing kernel cache with this command (and reboot after):

sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/Startup/*
reboot now

I'm usually doing it in Single-user verbose mode. For that, you would need to do one extra step to get the system in read-write mode:

/sbin/mount -uw /
rm -r -v /System/Library/Caches/com.apple.kext.caches/Startup/*
reboot now

Sometimes it helps with the reboots. And, at least for the purpose of this test, try to disable SIP (in case you haven't already). See if that makes any difference.

 

Also, if you're on DP7, try to upgrade to DP8, see if that helps.

 

Thanks, Yea, dual of these guys may be over-kill TBH. but, its quite nice :)

 

Here is a picture of what is looks like: http://rhcp011235.ro...ge/2c3m003M2W2p

 

It seems to be less flickery if i reboot a few times, I guess maybe i am catching something at the right time? I honestly do not know. 

 

I am hoping we should see GM of both 10.11 and IOS 9 by the end of the day and maybe some updated NVIDIA drivers.



#51
jsl

jsl

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 803 posts
  • Gender:Male

Thanks, Yea, dual of these guys may be over-kill TBH. but, its quite nice :)

 

Here is a picture of what is looks like: http://rhcp011235.ro...ge/2c3m003M2W2p

 

It seems to be less flickery if i reboot a few times, I guess maybe i am catching something at the right time? I honestly do not know. 

 

I am hoping we should see GM of both 10.11 and IOS 9 by the end of the day and maybe some updated NVIDIA drivers.

For 10.11GM we need a newer version of web Nvidia driver, otherwise it will interfere mouse control and Intel HD 4600 display function.

In 10.11DP7 I can enable both Intel HD4600 & Nvidia GTX980 at the same time with stable mouse control in both monitors.

But in 10.11GM they can not be enabled at the same time (either Intel HD4600 or Nvidia GTX 980 alone).

Mouse control is also poor too.

Hope the newer version coming soon !



#52
wastez

wastez

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 236 posts
  • Gender:Male

This drivers also doesn´t support metal....

 

Does anybody has a idea if nvidia will implement it?



#53
Gurqn

Gurqn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Istanbul

This drivers also doesn´t support metal....

 

Does anybody has a idea if nvidia will implement it?

 

They are definitely going to implement

https://www.linkedin...ob_details_text



#54
xelanaiznac

xelanaiznac

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 235 posts
  • Gender:Male

hi. any news about gm driver?



#55
cecekpawon

cecekpawon

    InsanelyMac Legend

  • Developers
  • 735 posts
  • Gender:Male

hi. any news about gm driver?

 

nope, keep an eye on here / here / here (final only)



#56
rhcp011235

rhcp011235

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
  • Gender:Male
  • Location:Charlotte,NC

nope, keep an eye on here / here / here (final only)

 

Wow, I must admit, I was thinking they would drop new drivers when the GM dropped. So, the current drivers don't work on the GM release?

I have yet to upgrade my hack. Without them, my GTX980 wont work afaik 



#57
cecekpawon

cecekpawon

    InsanelyMac Legend

  • Developers
  • 735 posts
  • Gender:Male

@rhcp011235, for your safety, better to wait until 30th Sept ETA



#58
rhcp011235

rhcp011235

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
  • Gender:Male
  • Location:Charlotte,NC

@rhcp011235, for your safety, better to wait until 30th Sept ETA

 

Oh yes for sure. 

 

I am still trying to decide if i am going to keep this 980 or just use my 660 (which is native supported) and just run my second screen at 50HZ vs 60HZ.

 

I don't know if its worth all this trouble. Just for a second display port.



#59
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,415 posts
  • Gender:Male

hi. any news about gm driver?

 

the last 346.03.01b07 webdriver is the same for DB7/PB5/DB8/PB6/GM

 

it also works fine with the first 10.11.1 build 15B17c beta... just have to edit the NVDAStartupWeb.kext Info.plist file NVDARequiredOS section 15A to 15B



#60
rhcp011235

rhcp011235

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
  • Gender:Male
  • Location:Charlotte,NC

the last 346.03.01b07 webdriver is the same for DB7/PB5/DB8/PB6/GM

 

it also works fine with the first 10.11.1 build 15B17c beta... just have to edit the NVDAStartupWeb.kext Info.plist file NVDARequiredOS section 15A to 15B

 

are you saying you got these drivers to work with the GM release? I have heard they do not work







Also tagged with one or more of these keywords: nvidia web driver, updates, el capitan, 10.11


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy