Jump to content

[Guide] Install Windows 8 UEFI on Legacy BIOS with Clover (and Dual boot with Yosemite)

UEFI Legacy bios bios Clover Dual-boot OSX Yosemite Windows GPT GUID

  • Please log in to reply
98 replies to this topic

#81
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

tried everything,install UEFI Windows on my legacy bios computer fail.Boot usb EFI partition fail,seems like boot file doesn't have usb driver.

Really ? I tested it on many machines I have, including an old Dell Latitude E6400 and a desktop with 1st gen Core 2 Duo CPU on a G31 mobo, it works like a charm



#82
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

Really ? I tested it on many machines I have, including an old Dell Latitude E6400 and a desktop with 1st gen Core 2 Duo CPU on a G31 mobo, it works like a charm

maybe my boot order has problem,when boot dvd efi sector and format partition,then install,it said cannot find install file.



#83
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

maybe my boot order has problem,when boot dvd efi sector and format partition,then install,it said cannot find install file.

Boot order ? You have 2 or more HDD/SSD ?



#84
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

Boot order ? You have 2 or more HDD/SSD ?

I have 1 SSD and 1HDD,I tried this tutorials with windows 7 sp1 and windows 8,when I select cdboot.efi,I cannot select bootx64.efi,when screen show press any key to install,I press,and then it return to clover,I cannot reach to install window,please help.



#85
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,992 posts
  • Gender:Male
  • Location:France

I have 1 SSD and 1HDD,I tried this tutorials with windows 7 sp1 and windows 8,when I select cdboot.efi,I cannot select bootx64.efi,when screen show press any key to install,I press,and then it return to clover,I cannot reach to install window,please help.

 

Why would you boot with cdboot.efi ? Are you using a DVD to install Windows UEFI via Clover ? If so, you just have to select "Boot xxx from Optical xxx" using bootmgrfw.efi and you'll be fine ! Don't forget to put GrubUDF-64.efi and/or GrubISO9660-64.efi (can't remember which one is correct but I guess it's the first one :P) in your Drivers64 folder.

 

If you're using a USB stick, make sure to format it with MBR partition scheme then follow fusion71au's guide to make your Windows install disk UEFI ready. It works for Win7/8/10 like a charm.

 

BTW, I strongly advise you to unplug any other drive apart the one for Windows.



#86
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

@redcoatd,

 

If you don't see "Boot UEFI external"/bootx64.efi, most likely it is hidden (the latest Clover revisions >r2999 automatically hide bootx64.efi from the GUI, unless you press <F3> at the Main Menu to unhide).  Did you read point no3 in the troubleshooting section?

 

Try this workaround

 

1.  Rename cdboot.efi in WIN81/efi/microsoft/boot folder to cdboot.BAK

2.  Copy bootmgfw.efi into WIN81/efi/microsoft/boot

 

post-846696-0-42354800-1418288879_thumb.

 

3. Reboot the computer with the Installer USB and select "Boot Microsoft EFI boot menu from WIN81", then press <spacebar>

 

post-846696-0-52813400-1418288999_thumb.

 

4.  Select "Run bootmgfw.efi" and then press <spacebar> ---> should now boot into the UEFI Windows Installer!

 

post-846696-0-34464000-1418289116_thumb.

follow your steps,bootmgfw.efi say my pc need to repair.I can't reach install window



#87
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,992 posts
  • Gender:Male
  • Location:France

Yeah, I know ;).

That's why I said make sure to format the USB stick with MBR partition scheme and follow this post instead of the one you quote. GUID is the point here and I spent a lot of time before I realize it just don't work using this partition scheme.

 

MBR partition scheme should solve that. Furthermore, I also figured out that making dual or more OS install disk isn't working as soon as you have anything else than Windows installer on a FAT32 partition.

 

I tried with OS X + Windows, Windows + Linux and also Win7 + Win8 and each time it ended up with the Windows installer not seeing my drive and asking to find/install a driver. I'm sure I missed something but I don't know where :unsure:.

 

So, for my part, I stick with only Clover + Windows installer on a single USB pen using MBR partition scheme and it works fine like this.



#88
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

Why would you boot with cdboot.efi ? Are you using a DVD to install Windows UEFI via Clover ? If so, you just have to select "Boot xxx from Optical xxx" using bootmgrfw.efi and you'll be fine ! Don't forget to put GrubUDF-64.efi and/or GrubISO9660-64.efi (can't remember which one is correct but I guess it's the first one :P) in your Drivers64 folder.

 

If you're using a USB stick, make sure to format it with MBR partition scheme then follow fusion71au's guide to make your Windows install disk UEFI ready. It works for Win7/8/10 like a charm.

 

BTW, I strongly advise to unplug any other drive apart the one for Windows.

follow your step,GPT SSD Clover install windows 7 sp1 and windows 8 dvd to GPT SSD Partition,I always get errors like "We couldn't create a new partition or locate an existing one..." like this post



#89
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,992 posts
  • Gender:Male
  • Location:France

So you can reach the Windows installer on the USB pen with no errors anymore like "you need to repair and blablabla" ? I guess this is a step forward ;).

 

Did you unplug the other HDD ? I mean, physically !

 

This error comes from the Windows installer which doesn't like not being the only one on the PC <_<.

 

Could you run a diskutil list so we can see how your HDD/SSD are organized ?



#90
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

So you can reach the Windows installer on the USB pen with no errors anymore like "you need to repair and blablabla" ? I guess this is a step forward ;).

 

Did you unplug the other HDD ? I mean, physically !

 

This error comes from the Windows installer which doesn't like not being the only one on the PC <_<.

 

Could you run a diskutil list so we can see how your HDD/SSD are organized ?

No,USB pen can't reach the Windows installer,DVD can reach the Windows installer.

OK,I will unplug my only HDD.

Here is 

Creating Installation Media:
 
Erase the USB drive, using Disk Utility. Make 1 partitions for OS X (call it Mavericks-Installer.Select OS X Partition as Mac OS Extended Journaled,Make sure you are giving 7GB (or more) for each OS X installation partitions. Select ‘GPT (GUID Partition Table)’ under Options.
 
Install Clover_v2.3k_r3253 into the EFI partition of this USB by targeting the OSX partition and customize by selecting Install Clover in the ESP, Bootloader > Install boot0ss in MBR, CloverEFI > CloverEFI 64-bits SATA and Drivers64UEFI > EmuVariableUefi-64. Perform installation:
 
Once clover is installed EFI partition will be mounted automatically. Open it and now you need put few more files. You will need config.plist, DSDT.aml which are specific to your system.

- Put config.plist in EFI/CLOVER directory
- Put DSDT.aml in EFI/CLOVER/ACPI/patched
- Put HFSPlus.efi in EFI/CLOVER/drivers64 & EFI/CLOVER/drivers64UEFI
- Delete VBoxHfs-64.efi in EFI/CLOVER/drivers64 & EFI/CLOVER/drivers64UEFI
- Put FakeSMC.kext and other kexts required in EFI/CLOVER/kexts/10.9
 
Now we need to copy Mavericks installation file to USB drive. Make sure /Volumes/HDD/Applications/Install OS X Mavericks.app exists and run following in terminal:
 
sudo /Volumes/HDD/Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Mavericks-Installer --applicationpath /Volumes/HDD/Applications/Install\ OS\ X\ Mavericks.app
 
Your USB installation drive is ready.
 

Jianwei:~ jianweiliu$ diskutil list

/dev/disk0

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *128.0 GB   disk0

   1:                        EFI EFI                     209.7 MB   disk0s1

   2:                  Apple_HFS SSD                     127.2 GB   disk0s2

   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s4

/dev/disk1

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *1.0 TB     disk1

   1:                        EFI EFI                     209.7 MB   disk1s1

   2:                  Apple_HFS HDD                     999.9 GB   disk1s2

 

polly,you are god,unplug HDD and use clover to install windows 8.1 now I can use Windows 8.1 to type this word.



#91
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,992 posts
  • Gender:Male
  • Location:France

Windows is definitely EVIL <_< !

 

Why the hell Microsoft won't allow its installation whenever any other drive is attached ? That's so stupid :rolleyes: !



#92
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

I don't use Grub or anything. I used the built-in EFI Shell in Clover, make it load Windows Installer's bootx64.efi



#93
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

Windows is definitely EVIL <_< !

 

Why the hell Microsoft won't allow its installation whenever any other drive is attached ? That's so stupid :rolleyes: !

Maybe my Western Digital Caviar Black 1TB is broken,I experience crash during use it.crash because over clock CPU,reset cmos to fix.So I want converter it to USB portable hard drive,I get a computer from a beijing people in october 2009.then I replace signature thing.Too bad.

Western Digital Caviar Black 1TB is OK,I converter it to portable,plug in,still can't install Windows 8.1.HDD must be unplug to use on Windows 8.1 EFI Installer.



#94
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

I don't use Grub or anything. I used the built-in EFI Shell in Clover, make it load Windows Installer's bootx64.efi

Yes grub is not useful in clover.follow your steps,it works,though IDE DVD a bit slower.



#95
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Yes grub is not useful in clover.follow your steps,it works,though IDE DVD a bit slower.

So it works right ?



#96
cuthead

cuthead

    InsanelyMac Legend

  • Donators
  • 646 posts
  • Gender:Male
  • Location:Port Edward
  • Interests:Whistle

So it works right ?

yes



#97
cicetto

cicetto

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts

 

........

BTW, I strongly advise you to unplug any other drive apart the one for Windows.

 

This helped me.



#98
crazyj

crazyj

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

I'm struggling right out of the gate with this.

 

I've created a usb clover test stick with that other guy's installer, which seems to at least get me to the clover boot menu, but going by this guide, it just hangs for a while at the first page of my booting screen, then eventually just boots my old snow-leopard install on my hd.

 

I've tried mbr-fat16 and guid-mac HFS journalled with no change in outcomes.

 

Its a bit old, but others have had success.  Not sure why I'm having issues:

 

P55-UD4P

Gigabyte ATI 4670

16gb ram

SSD is PCI-E installed Plextor 256GB M6e (the only thing I can think is a bit odd.

 

I may not have a fully functioning config.plist, since snow leopard install uses that boot.plist stuff.

 

Any suggestions?  I'm ultimately trying to get this fully functioning as a fully GPT triple boot of El-Capitan, Windows-7 (running as UEFI), and Mint 18, but this first step has me stumped...



#99
kosakgroove

kosakgroove

    Unix Shepherd

  • Members
  • PipPipPipPipPipPipPip
  • 709 posts
  • Gender:Male
  • Location:ALGARVE
  • Interests:The unexpected is the real
I just wanted to say that this worked like a charm for my Legacy Hacks. I downloaded the official Windows 10 iso and made a GUID USB and installed Windows with it in dual boot to my three hacks. All thanks to the trick of copying bootmgfw.efi from install.wim
Thanks for the guide !





Also tagged with one or more of these keywords: UEFI, Legacy bios, bios, Clover, Dual-boot, OSX, Yosemite, Windows, GPT, GUID


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy