Jump to content

Workstation 11/12, Player 7/12, Fusion 7/8 and ESXi 6 Mac OS X Unlocker 2

vmware unlocker

  • Please log in to reply
566 replies to this topic

#561
newsguytor

newsguytor

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Has anyone been able to use their real macOS Dual Boot Partition as the disk in VMWare, so they can access their macOS Hackintosh installation from Windows?

 

(like how I can use virtualize my real Windows installation on MacOS)



#562
bailsafe

bailsafe

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

Hi all, having a bit of trouble. On Windows 10 -- installed VMware Workstation Player to the default location, ran the win-install file as administrator, but getting some errors and not seeing macOS in the OS list. Gist is below. Thanks in advance!

 

https://gist.github....4cda9c4391934b1

 

Edit: Also when starting the machine, it acts like no OS is installed - it said IDE device could not be started, loads to Intel PXE boot, then fails.



#563
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,292 posts
  • Gender:Male
  • Location:Manchester UK

Hi all, having a bit of trouble. On Windows 10 -- installed VMware Workstation Player to the default location, ran the win-install file as administrator, but getting some errors and not seeing macOS in the OS list. Gist is below. Thanks in advance!

 

https://gist.github....4cda9c4391934b1

 

Edit: Also when starting the machine, it acts like no OS is installed - it said IDE device could not be started, loads to Intel PXE boot, then fails.

 

This is an issue in the pyinstaller system used to package up the Python code. I am not sure what is causing this issue so can I suggest some different tests?

 

1. Disable any AV you have running as that can stop some of the VMware processes from being stopped. For example McAfee HIPS interferes with the unlocker. After patching it can be restarted.

2. Apparently pyinstaller may not like unusual characters in paths so the next step would be to try it from a path without "(" or ")" characters:

C:\Users\xxxx\Downloads\VMWare Player Patch Τool macOS Sierra\unlocker208

3. Also pyinstaller has had problems with the code page in the terminal. Can you run the CHCP command in a command prompt and let me know the value please?

 

Thanks



#564
bailsafe

bailsafe

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

This is an issue in the pyinstaller system used to package up the Python code. I am not sure what is causing this issue so can I suggest some different tests?

 

1. Disable any AV you have running as that can stop some of the VMware processes from being stopped. For example McAfee HIPS interferes with the unlocker. After patching it can be restarted.

2. Apparently pyinstaller may not like unusual characters in paths so the next step would be to try it from a path without "(" or ")" characters:

C:\Users\xxxx\Downloads\VMWare Player Patch Τool macOS Sierra\unlocker208

3. Also pyinstaller has had problems with the code page in the terminal. Can you run the CHCP command in a command prompt and let me know the value please?

 

Thanks

 

  1. No antivirus on my system aside from Windows Defender, so that should be clear.
  2. I took the parentheses out of the folder name but it didn't seem to help. Current path is C:\Users\baile\Downloads\VMWare Player Patch Τool macOS Sierra\unlocker208
  3. System active code page: 437

Here's the latest snippet

Thanks for the help in advance!

 

Edit: Got it! pyinstaller must not like long file names. I changed the folder name from "VMWare Player Patch Τool macOS Sierra" to "patch" and it worked flawlessly.



#565
werro

werro

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Traceback (most recent call last):
  File "<string>", line 18, in <module>
  File "D:\PyInstaller-3.0\PyInstaller\loader\pyimod03_importers.py", line 634, in install
  File "D:\PyInstaller-3.0\PyInstaller\loader\pyimod03_importers.py", line 222, in __init__
ImportError: Can't load frozen modules.

In both calls to the python scripts in win-install I get this, which results in the scrips exiting with -1 and the install failing. I've tried installing Python 3.0 and 2.7, removing and reinstalling VMWare, and running the .py files instead of the .exe files. Nothing has worked so far. Any ideas?



#566
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,292 posts
  • Gender:Male
  • Location:Manchester UK

 

Traceback (most recent call last):
  File "<string>", line 18, in <module>
  File "D:\PyInstaller-3.0\PyInstaller\loader\pyimod03_importers.py", line 634, in install
  File "D:\PyInstaller-3.0\PyInstaller\loader\pyimod03_importers.py", line 222, in __init__
ImportError: Can't load frozen modules.

In both calls to the python scripts in win-install I get this, which results in the scrips exiting with -1 and the install failing. I've tried installing Python 3.0 and 2.7, removing and reinstalling VMWare, and running the .py files instead of the .exe files. Nothing has worked so far. Any ideas?

 

 

 

There are issues when there are characters in the path such as Chinese, Japanese etc. What is the folder name you are using? This is a known issue with Python and PyInstaller.



#567
werro

werro

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

There are issues when there are characters in the path such as Chinese, Japanese etc. What is the folder name you are using? This is a known issue with Python and PyInstaller.

I changed the folder name to test to see if that fixed anything and it worked perfectly. There weren't any foreign characters in the path, but they weren't all alphanumeric.  Thank you.

 

Edit: Now I see that the issue directly before me was the same thing.  I skimmed the first few pages of the thread and searched "Can't load frozen modules" and then didn't see those posts. Sorry to make you solve the same issue twice in a row.







Also tagged with one or more of these keywords: vmware unlocker


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy