Jump to content

Nvidia Web Driver updates for Yosemite [UPDATE: 09/02/2016]


  • Please log in to reply
653 replies to this topic

#1
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,166 posts
  • Gender:Male

*
POPULAR

hi

 

ok guys,

 

you can use this thread to link / talk about of the futur Nvidia Web Driver updates for Yosemite

 

 

10.10.5

 

Nvidia Web Driver - 346.02.03f09 --> build 14F1912 (thanks to BreBoNew!

 

Nvidia Web Driver - 346.02.03f08 --> build 14F1909 (thanks to WeBeRiO

 

Nvidia Web Driver - 346.02.03f07 --> build 14F1808 (thanks to WeBeRiO)  

 

Nvidia Web Driver - 346.02.03f06 --> build 14F1713 (thanks to Riley Freeman)

 

Nvidia Web Driver - 346.02.03f05 --> build 14F1605 (thanks to WeBeRiO)  

 

Nvidia Web Driver - 346.02.03f04 --> build 14F1509 (thanks to marcozardi)

 

Nvidia Web Driver - 346.02.03f03 --> for build 14F1505 (thanks to slim.jim

 

Nvidia Web Driver - 346.02.03f02 --> 10.10.5 (build 14F1021) second public release (thanks to Riley Freeman

 

Nvidia Web Driver - 346.02.03f01 --> 10.10.5 (build 14F27) first public release (see here)

 

Nvidia Web Driver - 346.02.03b01 --> 10.10.5 first beta release (thanks to MTWomg)  

 

 

 

10.10.4

 

Nvidia Web Driver - 346.02.02f03 --> 10.10.4 third public release (thanks to Vampirexx)  

 

Nvidia Web Driver - 346.02.02f02 --> 10.10.4 second public release (thanks to Vampirexx)  

 

Nvidia Web Driver - 346.01.03f01  --> 10.10.4 first public release (thanks to Vampirexx)  

 

Nvidia Web Driver - 346.01.03b01 --> 10.10.4 build 14E26a (thanks to netkas and MTWomg)  

 

 

 

10.10.3

 

Nvidia Web Driver - 346.01.02f04 --> 10.10.3 fourth public release (thanks to SummerRain

 

Nvidia Web Driver - 346.01.02f03 --> 10.10.3 third public relase (thanks to marcozardi

 

Nvidia Web Driver - 346.01.02f02 --> 10.10.3 second public release (thanks to lukazm

 

Nvidia Web Driver - 346.01.02f01 --> 10.10.3 first public release (thanks to lukazm

 

Nvidia Web Driver - 346.01.02b01 --> 10.10.3 build 14D130a (thanks to horizoli

 

Nvidia Web Driver - 343.02.03b04 --> 10.10.3 build 14D105g (thanks to zhuangzi23

 

 

 

10.10.2

 

Nvidia Web Driver - 346.01.01f01 --> 10.10.2 fifth public release (thanks to duggum)

 

Nvidia Web Driver - 343.02.02f04 --> 10.10.2 (build 14C1514) fourth public release (thanks to Vampirexx

 

Nvidia Web Driver - 343.02.02f03 --> 10.10.2 (build 14C1510) third public release (thanks to lukazm)

 

Nvidia Web Driver - 343.02.02f02 --> 10.10.2 second public release (thanks to Mela quadrata)

 

Nvidia Web Driver - 343.02.02f01 --> 10.10.2 build 14C109 (thanks to archfan)

 

Nvidia Web Driver -343.02.02b04  --> 10.10.2 build 14C94b (thanks to ddani)

 

Nvidia Web Driver - 343.01.03b01 --> 10.10.2 build 14C68k (thanks to netkas)

 

 

 

10.10.1

 

Nvidia Web Driver - 343.02.01f01 --> 10.10.1 third public release (thanks to rednous)

 

Nvidia Web Driver - 343.01.02f03 --> 10.10.1 second public release (thanks to jamilitia)

 

Nvidia Web Driver - 343.01.02f01 --> 10.10.1 public release (thanks to luele)

 

Nvidia Web Driver - 343.01.02b02 --> 10.10.1 build 14B23 (thanks to Rominator) --> works fine with the public release (build 14B25)

 

Nvidia Web Driver - 343.01.02b01 --> 10.10.1 build 14B17 (thanks to cmf)

 

 

 

10.10.0

 

Nvidia Web Driver - 343.01.01f03

 

Nvidia Web Driver - 343.01.01f02 (with OpenCL fix?) --> (thanks to Joao Paulo Mello)

 

Nvidia Web Driver - 343.01.01f01 (maxwell support) --> 10.10.0 (14A389)      (thanks to Moviemakergr)

 

 

 

GM & PB

 

Nvidia Web Driver - 343.01.01b04 --> GM Candidate 3.0 (14A388a) 

 

Nvidia Web Driver - 343.01.01b03 --> Public Beta 5 (14A386b)

 

Nvidia Web Driver - 343.01.01b02 --> GM Candidate 2.0 (14A386a)

 

 

 

Credits go to Rominator & Netkas 


Edited by fantomas1, 03 September 2016 - 08:30 PM.
update 09/02/2016 - added Nvidia Web Driver - 346.02.03f09 for 10.10.5 (build 14F1912)


#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,166 posts
  • Gender:Male

ok,

 

I'm on Yosemite Public Beta 5 and web driver just works fine with my GTX 570 + Clover r2890

 

Attached File  1.png   106.51KB   86 downloads Attached File  2.png   87.12KB   59 downloads



#3
hiphopboy

hiphopboy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 163 posts

Support for what Graphic ?



#4
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 3,014 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Has someone in idea what the exclude-oats.txt (within the OpenGL driver , resources) has for an meaning?

Does it config some workaround? (Lots of text about Channel_exception bugs = hangs /stalls , often happened with Nvidia gpus)

# Exclude list for OATS tests for Branch GB10.
# When editing, look for all occurences of your bug number, there could be more than one.

# Lines that beging with #= limits the exclusion to the named GPU devices or GPU families.
# The scope ends at the next blank line.
# By default the tests will be excluded for all devices, same effect as using the tag #= ALL
# The tag #= NONE can be used to omit the exclusion for all devices.

# For Future expansion:
# Lines that begin with #? contain information about the nature of the failure.
# Keywords include: Hang Crash Failure Waiver Success GLErrors Intermittent Channel_exception

# Tests included in Apple's test list but not actually included in the OATS drop.
# Many of these are app tests anyway, which we may not want to run in automation.
#? Mandatory
#= ALL
3rdPartyApps/COD4/launch.py
3rdPartyApps/Cascaded_Shadow_Map/CSM_NV_Test
3rdPartyApps/Cascaded_Shadow_Map/CSM_NV_Test.app/Contents/MacOS/CSM_NV_Test
3rdPartyApps/Cinebench10/cinebench10.py
3rdPartyApps/Cinebench11/cinebench11.py
3rdPartyApps/Cinebench9/cinebench9.py
3rdPartyApps/Doom3/Doom3
3rdPartyApps/EnemyTerritory/ETQWTester.py
3rdPartyApps/Portal/PortalTester.py
3rdPartyApps/Star2/Star2Tester.py
GLKMath/GLKMath/basic/basic
GLKTextureLoader/GLKTextureLoader/GLKTextureLoaderTest -t 2D -a NO -e bmp
GLKTextureLoader/GLKTextureLoader/GLKTextureLoaderTest -t 2D -a NO -e jpg
GLKTextureLoader/GLKTextureLoader/GLKTextureLoaderTest -t 2D -a NO -e png

# Bug: 1032914 Buffers/null_surface causes channel errors and system hang.
# Bug: 1031314 Mac: D2: Some OATS tests cause channel exceptions
#? Hang Channel
#= ALL
Buffers/null_surface

# Bug 1158140 Bug 1059290, Bug 1043550 - Channel exception and machine hang on J31 / TOT.
# Bug 1158140 Test Malicious/infiniteloop Causing Some OATS Systems to Hang
# Bug 1059290 Malicious/infiniteloop times out
# Bug 1043550 -Closed- gk1xx: NVDA(OpenGL): Channel exception! running "Malicious/infiniteloop"
# GB10 GB7 GB7-1 GB8 GB9-2 GB9-2-CLASSIC TOT TOT-CAB TOT-CLASSIC
# Malicious/lotstriangles is Intermittent Success/Failure on GB10.
#? Hang Failure Channel
#= gk10x
Malicious/infiniteloop
Malicious/lotstriangles

# Bug 1160083 Channel exceptions in GB9-2, w. J31
# Bug 1160083 Channel exceptions in dev_a, w. K40
# GB7 GB7-1 GB8 GB9-2 GB9-2-CLASSIC TOT TOT-CAB TOT-CLASSIC gpu_drv_dev_a gpu_drv_dev_a_mcp8x gpu_drv_dev_a_tot_rm gpu_drv_stage_mac gpu_drv_stage_mac_mcp8x tot-nv-eng totclassic
# Not GB10 GB9 GB9-5, they are OK, tot-nv-eng with gk10x and totclassic with mcp8x have intermittent Channel exception.
#? Failure Channel Intermittent Success
#= g8x g9x gf10x gk10x gt20x mcp8x
#GLSL/GLSLGoldenImage/leizex

# Bug 1328725 [fasttrack regression] [OATS] [TOT] - OATS GL3Core/ubo/uboTypeCombination - new errors and then it hangs.
# GB10 TOT gpu_drv_dev_a tot-nv-eng totclassic
#? Hang
#= ALL
GL3Core/ubo/uboTypeCombination

# Bug 1412346 Channel exception and graphics hang
# GB10 GB7 GB7-1 GB8 GB9-2 GB9-2-CLASSIC TOT TOT-CAB TOT-CLASSIC gpu_drv_dev_a totclassic tot-nv-eng totclassic
#? Failure Crash glError
#= gk10x mcp8x
GL3Core/ubo/uboIndirect

# Bug 1482711 [fasttrack regression] [OATS] [TOT] - GL3Core/context/memoryleak_core - Hang
# It fails on gk107 but works on gk104.
# GB10 TOT gpu_drv_dev_a tot-nv-eng
#? Hang
#= gk107
GL3Core/context/memoryleak_core

# Bug 1482741 [fasttrack regression] [OATS] [TOT] - GL3Core/ubo/uboStruct - Many errors and then Hang
# GB10 TOT gpu_drv_dev_a tot-nv-eng totclassic
# Introspect says it hangs but it did complete eventually when run manually. Lots of printouts.
#? Hang 
#= ALL
GL3Core/ubo/uboStruct

# Bug 1482786 [fasttrack regression] [OATS] [TOT] - WebGL/WebGLTester.app/Contents/MacOS/WebGLTester --testListFile ../../../base_conform.txt - Hang
# GB10 GB9-5 TOT gpu_drv_dev_a tot-nv-eng totclassic
#? Hang Failure Intermittent
#= ALL
WebGL/WebGLTester.app/Contents/MacOS/WebGLTester --testListFile ../../../base_conform.txt

# Bug 1485216 [OATS] [GB10] - Hooked/OpenGL4Tests/hooked_test -extension gpu_shader_fp64 - Hang
# GB10 TOT gpu_drv_dev_a tot-nv-eng
# GB10 always hangs, Intermittent Hang/Failure on the others.
#? Hang
#= gk10x 
Hooked/OpenGL4Tests/hooked_test -extension gpu_shader_fp64



#5
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,444 posts
  • Gender:Male
  • Location:The Streets

The Preview OpenCL GPU usage bug is still here with the PB5 drivers. Opening an image in Preview runs the GPU at high speed until Preview is closed.



#6
pdawg17

pdawg17

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Does Nvidia Beta 5 drivers work with beta 6?



#7
T a D

T a D

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Does Nvidia Beta 5 drivers work with beta 6?

Not sure I didn't try them.

 

I altered the GM 3 installer so it would install, but it still says incompatible with this version of OS X in System Preferences.

 

There's probably a couple of other places in the install that specify the build the drivers will work with.



#8
pdawg17

pdawg17

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Not sure I didn't try them.

 

I altered the GM 3 installer so it would install, but it still says incompatible with this version of OS X in System Preferences.

 

There's probably a couple of other places in the install that specify the build the drivers will work with.

 

Yeah I tried editing the "NVDARequiredOS" line in the NVDAStartup.kext but I still can't install due to the OS version not being compatible. 

 

I'm really trying to figure out a way to get drivers installed for PB6 because I just got my GTX 970 and my wife will only use OS X and won't touch Windows! 



#9
dinker99

dinker99

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

 

 

I'm really trying to figure out a way to get drivers installed for PB6 because I just got my GTX 970 and my wife will only use OS X and won't touch Windows! 

 

Get new wife, man.



#10
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,166 posts
  • Gender:Male

Yeah I tried editing the "NVDARequiredOS" line in the NVDAStartup.kext but I still can't install due to the OS version not being compatible. 

 

 

first, use pacifist to extract the kexts then edit the NVDARequiredOS line in the NVDAStartup.kext

 

after that, use kext wizard or what you want to install the kexts in S/L/E

 

repair the permissions and rebuild the cache

 

boot with -v kext-dev-mode=1 nvda_drv=1

 

Attached File  Capture d’écran 2014-10-15 Ã 15.15.56.png   117.47KB   135 downloads



#11
pdawg17

pdawg17

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

first, use pacifist to extract the kexts then edit the NVDARequiredOS line in the NVDAStartup.kext

 

after that, use kext wizard or what you want to install the kexts in S/L/E

 

repair the permissions and rebuild the cache

 

boot with -v kext-dev-mode=1 nvda_drv=1

 

attachicon.gifnull

 

EDIT: Thanks! I got it!

 

 

I had done a reinstall then updated straight to pb6 so I currently have no other nvidia drivers installed.

 

So per your instructions after editing the NVDAstartup.kext I would use kext wizard to install ALL kexts in the pb5 driver package to S/L/E? What about the other files in the pb5 pkg? 

 

Thanks.



#12
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,166 posts
  • Gender:Male

yes,

 

you can install all of them (kexts + nvprefpane)

 

you have only to edit NVDAStartup.kext, nothing else

 

;)



#13
T a D

T a D

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Got the Nvidia driver installed and it is now working, but still shows up as "NVIDIA Chip Model" in About this Mac/System Information.

 

I used 

pkgutil --expand

to extract the installation package.

 

Edit the file "Distribution" and change the build from 14A388a to 14A388b 

Edit the Info.plist file in the NVDAStartup.kext and change the build in there too.

 

Then use

pkgutil --flatten

To put it all back into a .pkg so you can install it  



#14
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,166 posts
  • Gender:Male

Edit the file "Distribution" and change the build from 14A388a to 14A388b

 

or just delete these two lines

 

if (!validateHardware()) return false; 
if (!validateSoftware()) return false;

 

it will delete hardware and software check function

 

;)



#15
Moviemakergr

Moviemakergr

    InsanelyMac Sage

  • Donators
  • 366 posts
  • Gender:Male

Thanks

Done WIth EVGA SC GTX 970 and nVidia beta web drivers. <(some bugs)

 

Attached File  post-783357-0-39081400-1413524526.jpg   105.96KB   107 downloads

 



#16
Hackmodford

Hackmodford

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
  • Location:'Merica's Mitt

It seems like the nvidia drivers no longer fix the OpenCL bug in Yosemite :(



#17
Moviemakergr

Moviemakergr

    InsanelyMac Sage

  • Donators
  • 366 posts
  • Gender:Male

Thanks

Done WIth EVGA SC GTX 970 and nVidia beta web drivers. <(some bugs)

 

attachicon.gifpost-783357-0-39081400-1413524526.jpg

And official Web drivers for maxwell > http://us.download.n...43.01.01f01.pkg



#18
Hackmodford

Hackmodford

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 283 posts
  • Gender:Male
  • Location:'Merica's Mitt

I updated the driver via the NVIDIA pref pane. However I have the openCL bug again. Open preview and the clockspeed gets stuck :(



#19
UltraLaser

UltraLaser

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 295 posts
Is supported the gtx 750ti?

#20
The Edge3000

The Edge3000

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Location:McKinney, TX

Working fine for me here. In fact, I found the PM bug was fixed even without the web drivers in default Yosemite. GTX 780.

Attached Files







2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy