Jump to content

Vaio users black screen after boot

DSDT EDID Drive Nvidia Vaio Black Screen

  • Please log in to reply
211 replies to this topic

#201
mrmacdi2

mrmacdi2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Hello!

 

Can't get internal LCD to work on my Vaio-SZ770. There is no EDI* in DSDT or SSDT etc.

Have tried EDID injection via Clover - no luck.

 

Will attach ioreg, DSDT, clover boot log later today.



#202
Funky frank

Funky frank

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 451 posts
Have a look into my vaio f11 dsdt (see signature), how I inject the nvidia device and adapt it for your device (changed device Id etc). Do it exactly the way I did.

Those vaios need some special nodes in that nvidia part to have a working internal scree , and the clover devs did not realize until now.

#203
mrmacdi2

mrmacdi2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Have a look into my vaio f11 dsdt (see signature), how I inject the nvidia device and adapt it for your device (changed device Id etc). Do it exactly the way I did.

Those vaios need some special nodes in that nvidia part to have a working internal scree , and the clover devs did not realize until now.

Unfortunately, in my DSDT there is no EDI data and in your DSDT there is EDI*, so I have no clue where to include edi patch in my case :/

My internal LCD EDID:

00 FF FF FF FF FF FF 00 3A C4 00 01 00 00 00 00 2D 0C 01 03 80 20 14 00 EA A8 E0 99 57 4B 92 25 1C 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 94 1B 00 AD 50 20 0A 30 40 40 42 00 42 C9 10 00 0A 30 40 40 42 00 42 C9 10 00 64 69 61 20 44 65 66 61 75 6C 00 00 00 FC 00 74 20 46 6C 61 74 20 50 61 6E 65 6C 00 00 00 00 FD 00 00 3D 1D 31 08 00 00 20 20 20 20 20 00 00 C8 

Original DSDT and patched by Clover:

 

Attached Files



#204
Funky frank

Funky frank

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 451 posts

Read here: http://www.insanelym...40#entry2152883



#205
mrmacdi2

mrmacdi2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

So, the actual problem is not with the EDID in my case, as I've managed to wake-up internal display with "Inject Nvidia ON" in Clover and then after macOS boot going to System Preferences -> Displays - > Detect Displays. Then the internal LCD wakes up and works great, the second way to wake-up the internal LCD is to put the laptop to Sleep and then wake it up - internal display start to work. As soon as it's on then I can do sleep etc with no problems - it works till reboot.

Have no clue why it happens: tried fixing NGFX in DSDT to GFX0, IGPU - the same: internal LCD works on macOS boot (apple logo and the boot progress 50%) then it switches to my external LCD and to make it work again - Detect Displays or Sleep.

 

One suspect is the mac model - Clover suggested MacBookPro5,1 in my case (MBP5,1 has the internal GPU and discrete GPU) - probably can cause the issue with internal LCD - will change it to MacBookPro4,1 (with the same GPU and CPU as my laptop).



#206
Funky frank

Funky frank

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 451 posts

AFAIK "GFX0" usually is AMD, "IGPU" is intel, "NGFX" or similar is nvidia. I guess no need to change that.

 

So do you have an intel GPU + nvidia?  I remember there was a problem with that and lot of people then only used the intel gpu... I don't know then :)



#207
mrmacdi2

mrmacdi2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

AFAIK "GFX0" usually is AMD, "IGPU" is intel, "NGFX" or similar is nvidia. I guess no need to change that.

 

So do you have an intel GPU + nvidia?  I remember there was a problem with that and lot of people then only used the intel gpu... I don't know then :)

Yes, Intel GPU + Nvidia, but Intel GPU is old and is not supported after 10.8, so I use Nvidia GPU only.



#208
KJAlnajjar

KJAlnajjar

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Anyone can help me guys to get my internal screen works!! I try to get it work for days :/ 

 

sony vaio vpcf126fm 

Intel Core i7 740QM / 1.73 GHz

NVIDIA GeForce GT 330M - 1 GB VRAM

 

Attached Files



#209
jl4c

jl4c

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 412 posts
  • Gender:Male
  • Location:Chile

Anyone can help me guys to get my internal screen works!! I try to get it work for days :/ 

  1. Corrupted ioreg, please use IORegistryExplorer Version 2.1
  2. Extract the EDID from windows/linux and attach it here.


#210
KJAlnajjar

KJAlnajjar

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

 

  1. Corrupted ioreg, please use IORegistryExplorer Version 2.1
  2. Extract the EDID from windows/linux and attach it here.

 

 

Actually I don't have a duel boot on my device but I have a virtual Windows if this work :/ 

Attached Files



#211
jl4c

jl4c

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 412 posts
  • Gender:Male
  • Location:Chile

You can use Linux LiveUSB to extract the EDID.



#212
KJAlnajjar

KJAlnajjar

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

You can use Linux LiveUSB to extract the EDID.

 

I installed fedora LiveUSB and tried to get the EDID and that's what I got using the terminal..

 

 

[liveuser@localhost ~]$ xrandr --verbose
Screen 0: minimum 320 x 200, current 2624 x 900, maximum 8192 x 8192
XWAYLAND0 connected 1600x900+0+0 (0x24) normal (normal left inverted right x axis y axis) 360mm x 200mm
    Identifier: 0x21
    Timestamp:  41668
    Subpixel:   unknown
    Gamma:      1.0:1.0:1.0
    Brightness: 0.0
    Clones:    
    CRTC:       0
    CRTCs:      0
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter:
  1600x900 (0x24) 118.000MHz -HSync +VSync *current +preferred
        h: width  1600 start 1696 end 1856 total 2112 skew    0 clock  55.87KHz
        v: height  900 start  903 end  908 total  934           clock  59.82Hz
XWAYLAND1 connected 1024x768+1600+0 (0x25) normal (normal left inverted right x axis y axis) 0mm x 0mm
    Identifier: 0x23
    Timestamp:  41668
    Subpixel:   unknown
    Gamma:      1.0:1.0:1.0
    Brightness: 0.0
    Clones:    
    CRTC:       1
    CRTCs:      1
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter:
  1024x768 (0x25) 63.500MHz -HSync +VSync *current +preferred
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock  47.82KHz
        v: height  768 start  771 end  775 total  798           clock  59.92Hz
 







Also tagged with one or more of these keywords: DSDT, EDID, Drive, Nvidia, Vaio, Black Screen

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy