Jump to content

100% stable hack froze and suddenly started boot looping


  • Please log in to reply
2 replies to this topic

#1
jamiethemorris

jamiethemorris

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 600 posts
  • Gender:Male
  • Location:San Rafael, CA

Hi, so my hack has been running fine up to this point... I switched to MacPro5,1 definition to get AGPM working. I made sure to use the Clover patch to prevent AppleTyMCEDriver from causing a kernel panic. I created an injector kext to add my graphics card to AGPM and put in in /EFI/kexts/10.9, and reinstalled the original AGPM because I had been messing with it. As soon as kext utility gets done, the system freezes and then starts boot looping. So I boot from my other Clover drive which still has the MacPro3,1 smbios. The system boots sucessfully, but after a couple minutes it locks up. What is going on? Corrupted kernel cache maybe? I would think if the kernel cache was corrupted it would have the same exact behavior for both configs. I booted it into Linux and it hasn't frozen so I think that rules out a sudden hardware issue. Any suggestions?

 

EDIT: This is my GA-Z68-UD3 build in my signature.



#2
jamiethemorris

jamiethemorris

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 600 posts
  • Gender:Male
  • Location:San Rafael, CA

Nevermind, after booting with MacPro3,1 a second time it stopped freezing. After deleting my injector kext MacPro5,1 boots again... It turns out I simply can't add my graphics card to AGPM (discovered it doesn't work on my XPS720 either)without it freezing. No idea why. I haven't tried it with iMac12,2 but I don't really want to use that SMBios.



#3
jamiethemorris

jamiethemorris

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 600 posts
  • Gender:Male
  • Location:San Rafael, CA

Update: I changed the control-id to 18 instead of 17 and now it's booting with the kext. I don't understand what the control id does though so I can't tell if it's working properly.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy