Jump to content

Badly need bootloader help - Can't boot from HD!


  • Please log in to reply
1 reply to this topic

#1
PB_863

PB_863

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male

I've got both Mountain Lion and Snow Leopard installed on my hard drive, but I can't boot from the hard drive no matter what I try!

 

To install Mountain Lion, I used the MyHack 3.3 Guide, which used to be located at myhack.sojugarden.com but is now available only from the WayBack machine at the following url: Archived MyHack 3.3 Guide. This worked perfectly, including being able to boot from the hard drive (although it only supported a MyHack, text-only boot screen).

 

But since the MyHack OSX Installer creation tool doesn't work for a Snow Leopard install, I used the "regae" boot CD and installer guide, located on this very site at: [GUIDE] Lion Retail & Snow Leopard 10.6.8 on ASUS P8P67 Deluxe B3. Although that assumed a different and older motherboard than mine (an ASUS P5WDG2 WS Pro), the Snow Leopard install worked fine, except that it would not boot from the hard drive.  (By the way, I did not upgrade from 10.6.3 to 10.6.8 as the guide calls for because after trying to upgrade to 10.6.8 the system would not boot at all).

 

I was advised to install Chameleon on both the Snow Leopard and Mountain Lion partitions, so that I could once again boot from the hard drive, but no matter which version I install, I simply cannot boot from the hard drive.  Instead, I always see the messages:

 

 

boot0:GPT
boot0:GPT
boot0:GPT
boot0:error

 

Now, please don't ask or tell me to forget about using Snow Leopard, because I absolutely need it because it is the last version that includes Rosetta (the PPC emulator), which I definitely need.

 

In the past, I've also tried to install Clover, but afterwards I could never get Clover to boot from the hard drive either.

 

By the way, my Hackintosh system requires a legacy BIOS and does not support UEFI.

 

Please help me solve this problem :unsure:



#2
jamiethemorris

jamiethemorris

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 781 posts
  • Gender:Male
  • Location:San Rafael, CA

Aah yes, the infamous boot0 error... This is because you are using an "advanced format" hard drive (meaning it uses 4kb sectors, most modern hard drives are this type). Chameleon has trouble dealing with these and for some reason that still hasn't been fixed after like 3 years... Fortunately this can be solved pretty easily.

 

This should solve your problem: http://www.insanelym...-after-install/

 

Happy hacking.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy