Jump to content

I got the ATI Radeon HD 6370M working with the right resolution but can't get the QE working!

ATI HD 6370M working on 10.9

Best Answer Hobbes65, 12 July 2014 - 09:45 PM

Finally, I managed to get my ATI Radeon HD 6370 1GB working using these updated kexts for OS X10.9  Mavericks , installed it like any other kext and boot using GraphicsEnabler=Yes .
 
 
1 . Figure out your graphics device ID, you can find it in:
 
about this mac —-> more info —-> system report
 
click on graphics/displays from left sidebar
 
2: delete all ATI and AMD related Kexts and injectors, then install the attached ones using the kext wizard:
 
AMD5000Controller.kext
AMD6000Controller.kext
AMDFramebuffer.kext
AMDRadeonAccelerator.kext
ATY_Init.kext
AMDRadeonVADriver.bundle
AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
AMDSupport.kext
 
3 :Add your Device ID to ATi5000controller.kext and ATiReadeonx3000.kext.
 
GO to System/Library/Extensions
then find one of the above Kexts and show package contents —-> Contents
 
add your device id to info.plist under IOPCIMatch
 
4- set your display to the right resolution by getting your monitor’s Edid, and inserting it into the file “DisplayProductID-717”, which can be found in: System—->Library—->Displays—-> Overrides -—> DisplayVendorID-756e6b6e
 
GraphicsEnabler = Yes
 
Repair permission using kext utility 
reboot
that’s it, Enjoy :)

Here are the rest of the files...

 

Go to the full post


  • Please log in to reply
6 replies to this topic

#1
Hobbes65

Hobbes65

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts

Hi there...

I have ASUS K52JT with the specs.:

Processor: Intel i7

Ram: 6GB

Wifi: Atheros

and I managed to install the Mavericks 10.9, then I managed to install my vga card kext, then I activated my LCD right resolution using the right edid...

But now I am lost.. trying time after time to activate the ATI Radeon HD 6370M QE... but seems it will never happen :(  ...

you'll find the kexts which I used and my "DisplayProductID-717" file attached.., along with two desktop snaps.  

 

Any ideas please  

Attached Files



#2
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,809 posts
  • Gender:Male
  • Location:Brazil

try this: http://www.hackintos...es-6370m-512mb/

 

put your signature, but with more details. Intel i7...???



#3
Hobbes65

Hobbes65

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts

InsanelyMaestro....

 

Thank you for responding.. I'm going to try it, and I'll be back to you... 



#4
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,809 posts
  • Gender:Male
  • Location:Brazil

Ok.



#5
CobraKhan007

CobraKhan007

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Maybe a weird question, but what makes you think you got no QE/CI?

on mine lappy it also didnt show under graphics section, but its working.

Have you enabled the translucent menu bar in "Desktop & Screensaver" section?

If no set it and check again. The translucent menubar is a dead give away if QE/CI is working or not.

 

Hope this helps. 



#6
Hobbes65

Hobbes65

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 3 posts

Best Answer

Attached File  AMD5000Controller.kext.zip   772.62KB   7 downloadsAttached File  AMD6000Controller.kext.zip   780.92KB   4 downloadsFinally, I managed to get my ATI Radeon HD 6370 1GB working using these updated kexts for OS X10.9  Mavericks , installed it like any other kext and boot using GraphicsEnabler=Yes .
 
 
1 . Figure out your graphics device ID, you can find it in:
 
about this mac —-> more info —-> system report
 
click on graphics/displays from left sidebar
 
2: delete all ATI and AMD related Kexts and injectors, then install the attached ones using the kext wizard:
 
AMD5000Controller.kext
AMD6000Controller.kext
AMDFramebuffer.kext
AMDRadeonAccelerator.kext
ATY_Init.kext
AMDRadeonVADriver.bundle
AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
AMDSupport.kext
 
3 :Add your Device ID to ATi5000controller.kext and ATiReadeonx3000.kext.
 
GO to System/Library/Extensions
then find one of the above Kexts and show package contents —-> Contents
 
add your device id to info.plist under IOPCIMatch
 
4- set your display to the right resolution by getting your monitor’s Edid, and inserting it into the file “DisplayProductID-717”, which can be found in: System—->Library—->Displays—-> Overrides -—> DisplayVendorID-756e6b6e
 
GraphicsEnabler = Yes
 
Repair permission using kext utility 
reboot
that’s it, Enjoy :)

Here are the rest of the files...

 

Attached Files



#7
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,809 posts
  • Gender:Male
  • Location:Brazil

Congratulations for you hard work!!  ;)


going to get better if you give the credits of those who helped you. or which method you use to succeed.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy