Jump to content

Samba share not recognized.

Samba Lion Finder Not found

  • Please log in to reply
10 replies to this topic

#1
Kikill3r

Kikill3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Vienna, Austria

Hey guys,

 

I have a Fujitsu T4200 laptop running iATKOS 10.7.5. Everything works except WiFi.

 

I have bought a Raspberry Pi and installed Samba on it in order to share my 1TB hard drive over the network and access it over Ethernet. Now the problem is that the share isn't recognized in the Finder. It just doesn't pop up in the "Shares" section of the Finder's sidebar. I also tried to connect to it by pressing "Command+K" to bring up the "Connect to Server" menu, I enter smb://10.0.0.2/ (with 10.0.0.2 being the IP address of the RasPi). Then I press "Connect" and it will try to connect forever.

 

WIndows recognizes the share just fine and I have read/write access and everything.

 

What's the problem here?

 

Thank you.

 

Btw I also can't connect to the RasPi over SSH in Terminal. I've dowloaded a SSH but it's not working, too. Could the two problems be connected?

 

Thanks in advance!



#2
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hello!

 

I have nothing done with samba for years. But I had with it built a network with Amiga OS 3.0, with Shapeshifter Emulation on Amiga OS enabled Mac OS System 8, connected with a pc running Windows NT 4.0.

 

Full read an write access enabled on all systems. The Samba configuration has been a bit tricky, because of implementing the different pw methods to an one, that has been allowed and could be used on all systems. You should read the samba documentation or google for an example config that is matching your system with the smb-server on the Raspberry..

 

Have fun.



#3
Kikill3r

Kikill3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Vienna, Austria
Thanks for your quick reply!

Do you mean I should Google for a smb.conf file compatible with OS X?


Best regards!

Kikll3r

#4
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hello!

 

Yes! But the config should also be compatibel with win. And I think you don´t need to define guest accounts. The admin or admin and onr user account should be enough. Try to set the same admin account name and user account name with password on all our systems. This should make it also a bit easier.

 

As in your case you have full access from win on the server, Try to create the the same account, which is working on win, on OSX in the same group with same account name and password and login on osx with this account. If I remember it right, I had done it in this way.

 

This should work without defining other accounts on the config of your smb server on the Raspberry, if your ethernet on OSX is working on the hardware side. (working internet access)

 

Have fun.

 

PS: You could also try prof, if your ethernet is working on OSX by sending a ping command to the ip adress of the smb-server. Type in terminal: ping 192.168.x.x. Replace x with your given digits for the smb-server.



#5
Kikill3r

Kikill3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Vienna, Austria
Hello!

I do have a working ethernet but I can't login to the server in OS X since it doesn't recognize the server and it is not showing up in finder or anything.

About the ping command, I'll try it later on, I have got some stuff to do. I'll report wether the ping succeeds or not.

Thank you!

#6
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hello!

 

I have looked a bit around and found this guide, which could perhaps help you: http://perevillega.c...nas-with-samba/

 

Have fun.



#7
Kikill3r

Kikill3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Vienna, Austria

Hello!

 

I've tried to ping the RasPi from my Hackintosh, that's the result:

PING 10.0.0.3 (10.0.0.3): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
Request timeout for icmp_seq 7
Request timeout for icmp_seq 8
Request timeout for icmp_seq 9
Request timeout for icmp_seq 10
Request timeout for icmp_seq 11
Request timeout for icmp_seq 12
Request timeout for icmp_seq 13
Request timeout for icmp_seq 14
Request timeout for icmp_seq 15
Request timeout for icmp_seq 16
Request timeout for icmp_seq 17
Request timeout for icmp_seq 18
Request timeout for icmp_seq 19
 
 
So it looks like it can't be reached. No firewall on either RasPi or Hackintosh.
Pinging it in Windows gives me a normal response.
 
When running "ssh -vvv root@10.0.0.3" that's the result:
 
ssh -vvv root@10.0.0.3
OpenSSH_5.6p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 10.0.0.3 [10.0.0.3] port 22.

 

and then it stays there forever.

 

I can't make head nor tail of it.

 

 

Edit: Aaaah maybe we get nearer to the solution. I found out that I can't ping the Raspberry Pi in Windows too, as long as I am connected to the network by Ethernet. When I disconnect the Ethernet cable, I can ping and SSH into it great. But in OS X I only have Ethernet. No WiFi.


Edited by Kikill3r, 10 July 2014 - 06:00 PM.


#8
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hello!

 

Have you set your Raspberry to a static IP?

 

Look in the ethernet config of your Raspberry. Is there something wrong with it? You can also try to set it´s IP adress to static with the pingable IP from Wifi.

 

Have fun.



#9
Kikill3r

Kikill3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Vienna, Austria
Hey!

I think there's everytging OK with the raspberry's Ethernet config. It's static, yes. I think it's more about the router or so because I can't ping it only if my computer is connected to the network by ethernet. I USB-Tethered my phone, which was connected to it by wifi, to my hackintosh and it recognized the samba share and I could ping it normally woth response.... Strange...

#10
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hello!

 

My own network is set to DHCP with the IP adresspool starting at 192.168.1.2 and ending at 192.168.1.254, the router IP adress is reserved at 192.168.1.1, all with subnetmask 255.255.255.0

 

I by myself have connteced my home nas, running on samba with a browserbased managing interface, with ethernet over the with wifi combined router and also some other devices. I can access all my devices among each other on ethernet and wifi  combined and have with them full access to the nas and also to the internet.

 

I suggest, that you should save the current settings of your router and then rest them to the standard values, starting from scratch with changes, doing neccessary changings one after the other, to control if they are working.

 

Have fun.

 

PS: Don´t forget to save your then hopefully working settings.



#11
Kikill3r

Kikill3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Vienna, Austria
Hello,

thank you for your efforts I appreciate it really much. I have bought a MacBook Pro now and it has working wifi so it doesn't matter anymore.

Thanks again!





Also tagged with one or more of these keywords: Samba, Lion, Finder, Not found


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy