Jump to content

OS X Yosemite 10.10 DP3


  • Please log in to reply
31 replies to this topic

#1
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,025 posts
  • Gender:Male

OS X Yosemite 10.10 DP3

 

 

2494061010DP3.png

 

 

 

 

Tout juste apparue sur AppStore !!!



#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,025 posts
  • Gender:Male

tout baigne sur ma vielle config (e8400 + p5kpl-am + hd4830 ou hd6770) + clover

 

enfin, il a fallu booter en single user + kext-dev-mode=1, charger FakeSMC.kext manuellement et une fois sur le bureau, reconstruire le kernelcache via Terminal

 

sudo kextcache -prelinked-kernel

 

au boot, ça refonctionne   ;)

 

thème "sombre", à moitié fonctionnel dans la dp2, fonctionne pleinement avec cette dp3

 

pour l'utiliser, allez dans Préférences Système -> Général -> Thème (choisissez "sombre")

 

;)



#3
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 823 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

Ha ben flute; j'ai effectué la mise à jour DP3 sur le Latitude D630 nVidia, mais ça ne reboote plus: difficultés à charger les kexts nVidia puis ça s'arrête d'un coup avec le panneau sens interdit et le message "waiting for root device":

GeForceSensors: still waiting for accelerator to start...

GeForceSensors: still waiting for accelerator to start...

GeForceSensors: still waiting for accelerator to start...

GeForceSensors (pci1): chipset: G86 (NV86) bios 60.80.68.00

GeForceSensors (pci1): started

Still waiting for root device

 

Je boote avec une clé USB Clover (r2695) avec ma DSDT dans EFI/CLOVER/ACPI/patched et mes kexts dans EFI/CLOVER/kexts/10.10.

Attached File  D630n_config.plist.zip   1.74KB   5 downloads

 

Je vais ptet tenter une version plus récente de Clover...

 

Quelle version de FakeSMC as-tu utilisé ce coup-ci Fantomas1?



#4
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,025 posts
  • Gender:Male
Quelle version de FakeSMC as-tu utilisé ce coup-ci Fantomas1?

 

il est vrai que j'accorde pas bcp d'attention sur les versions de FakeSMC, si ce n'est pour HWSensors (et encore). Sur ma vielle config, toutes les versions passent bien, donc je n'ai jamais eu de réel problèmes avec. Là actuellement, je suis à la 6.4.1220

 

 

Attached File  FakeSMC.kext_6.4.1220.zip   157.89KB   28 downloads

 

 

mais n'empêche, il y a pas mal de trucs que je n'ai pas compris avec cette DP3

 

j'ai un peu suivi le fil de discussion sur la partie anglaise concernant le nouveau mode de démarrage, à savoir le logo blanc + le fond noir, comme pour les vrais Macs, apparement  certains seraient arrivés mais nul ne dit comment, à se poser des questions.   -_-

 

bref, ce mode semble être désactivé au moment de l'installation, lors de la vérification si on a le smbios compatible (/var/log/install.log)

localhost OSInstaller[401]: Removing background color for incompatible machine Mac-F2268CC8

mais d'après modbin, il suffit simplement d'avoir le bon smbios et on retrouve ce mode

 

pour rappel, afin de vérifier si vous possédez le bon smbios, allez voir dans

/Volumes/votre_clé_usb/System/Library/PrivateFrameworks/OSInstaller.framework/Versions/A/Resources/BlackBackgroundCompatibleMachines.plist

 

il est donc primordial d'avoir le smbios compatible, faute de quoi, on n'aura pas ce mode (pour peu que cela dérange, voir pas du tout) et ajouter notre smbios ne marchera pas !!! 

 

ce que je trouve bien avec ma config, c'est que dès qu'il s'agisse d'un proc 2 cores, je peux utiliser ce smbios   :P

 

pour me faire mieux comprendre, pour ce test j'ai utilisé le smbios de MacBookAir6,2, qui est doté d'un i5-4250U ou d'un i7-465U, tous deux des proc 2 cores (4 threads), donc passe très bien avec mon e8400 (2cores, 2 threads)   :P

 

et en plus, il est dans la liste des machines compatibles avec ce mode

<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<array>
<string>Mac-C3EC7CD22292981F</string>
<string>Mac-AFD8A9D944EA4843</string>
<string>Mac-35C1E88140C3E6CF</string>
<string>Mac-7DF21CB3ED6977E5</string>  MacBookAir6,2
<string>Mac-031B6874CF7F642A</string>
<string>Mac-77EB7D7DAF985301</string>
<string>Mac-27ADBB7B4CEE8E61</string>
<string>Mac-189A3D4F975D5FFC</string>
<string>Mac-3CBD00234E554E41</string>
<string>Mac-2BD1B31983FE1663</string>
<string>Mac-F60DEB81FF30ACF6</string>
</array>
</plist>

et effectivement cela marche, quand je boot sur ma clé usb, j'ai bien ce mode, pas instantanément, mais au premier quart de la barre de défilement blanche, avec le logo blanc et le fond noir et jusqu'à l'arrivé à la fenêtre de la première étape de l'installation.

 

mais ce que je trouve surprenant, c'est que cela ne marche que si je boot avec ma clé usb et en plus de cela, je ne peux que booter avec ma clé usb, puisque j'arrive à la même erreur que toi,  Still Waiting for root device     :lol:

 

une autre chose étrange, vous vous souvenez de tout le calvaire qu'il a fallu pour, rien que de lancer l'installe, avec abdou, youyou et les indiens kext-dev-mode=1 et tout le tralala ?  Bein là, rien !!!   :blink:

 

ça s'est juste lancé normalement   :drool:

 

bref, je vais encore investiguer un peu, d'autant plus que je n'ai pas encore essayé avec chameleon, chose qui devrait marcher avec le patch de Pike

 

piufff, tout ce que j'ai écrit là, je suis KO    :P



#5
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 823 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

Je tente la ré-installation avec DP1 et vla que j'arrive plus à lancer l'installateur sans que ça plante! Pourtant, j'avais pas modifié grand chose à la config.plist de ma clé de démarrage Clover. J'aurais du prendre des notes!  :wallbash:



#6
polyzargone

polyzargone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 530 posts
  • Gender:Male
  • Location:France

Alors pour ma part :

 

Update OK et reboote sur clé USB (clover 2747). Premier boot en -s avec comme pour Fantomas1 chargement manuel de FakeSMC (version 4.0 - je sais plus d'où il sort celui-là :D  ) puis exit et reboot de Clover avant d'arriver sur le bureau (il me fait ça une fois sur deux, c'est d'ailleurs très pénible).

Après plusieurs tentatives et quelques KP, je boot enfin sur la DP3 et l'install s'se termine sans problèmes.

 

Pour les histoires de SMBios, j'ai pas encore testé (franchement, je peux me passer du legacy logo pour le moment et, je pense que de toute manière, ce sera réglé di'ci la GM) mais je confirme que la version actuelle de Chameleon ne fonctionne pas (sans doute une histoire de mach_kernel obsolète).

 

Bref, pour le moment, je vais regarder rapidement les changements amenés avec cette DP3 (toujours cette hideuse icône du Finder, grrrrrrrr :rolleyes: ) en attendant que les bootloaders soient à jour.

Attached Files

  • Attached File  DP3.png   84.46KB   4 downloads


#7
polyzargone

polyzargone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 530 posts
  • Gender:Male
  • Location:France

Chameleon fonctionne parfaitement avec le nouveau mach_kernel pour la DP3 :

 

http://www.niresh.co...oper-preview-3/



#8
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 823 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

Bon, j'ai quand même bien fini par gagner!

 

Ca (re)tourne sur le Latitude D630n (toujours aussi moche):

Attached File  D630n_10.10-DP3.jpg   41.17KB   4 downloads

 

Au tour du Vostro200...



#9
polyzargone

polyzargone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 530 posts
  • Gender:Male
  • Location:France

Tiens, c'est bizarre, on a pas le même "About this Mac" (OS X Yosemite pour moi et OS X pour toi) ni le même n° de Build (14A283o pour moi et 14A238x pour toi) !?!

 

:surprised:



#10
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 823 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

On dirait que l'update n'a pas été prise en compte!  :wallbash: Ca ma re-télécharge la même chose. Je dois toujours être sous DP1...



#11
polyzargone

polyzargone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 530 posts
  • Gender:Male
  • Location:France

T'as fait une combo update directe de DP1 à DP3 ?



#12
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 823 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

Je fais la mise à jour via menu pomme, mais vas comprendre:

Attached File  10.10_updates.jpg   135.62KB   5 downloads



#13
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,025 posts
  • Gender:Male

T'as fait une combo update directe de DP1 à DP3 ?

 

il n'y a pas de combo update pour les DP


Je fais la mise à jour via menu pomme, mais vas comprendre:

attachicon.gif10.10_updates.jpg

 

quand tu installes la DP1, AppStore te proposera uniquement la DP2

 

une fois celle-ci installée, il doit te proposer la DP3

 

seulement le problème chez moi, c'est qu'il ne me propose PLUS la DP3   :drool:  :drool:  :drool:  :drool:  :drool:  :drool:  :drool:  :drool:



#14
polyzargone

polyzargone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 530 posts
  • Gender:Male
  • Location:France

Donc mieux va pas se planter à la DP10 sinon faut tout réinstaller (il faut tout racheter comme dirais la marionnette de Steve Jobs des Guignols ;-) ?!?



#15
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,025 posts
  • Gender:Male

Je fais la mise à jour via menu pomme, mais vas comprendre:

attachicon.gif10.10_updates.jpg

 

:lol:

 

je viens d'avoir la même chose

 

:hysterical:

 

 

bon, je vais me lancer dans mon installe avec chameleon pour voir ce que ça donne    :yes:



#16
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,955 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

:)

 

3 jours d'absence et la DP3 sort !! je manque toujours les bonnes nouvelles !!   :hysterical:

 

demain je mets le turbo pour tester cette nouvelle MAJ   :P



#17
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,025 posts
  • Gender:Male

oui, donc l'installation avec chameleon était possible même si je ne l'avais pas entamée, vu que j'en avais déjà une et que je ne pouvais boot dessus qu'avec ma clé usb avec clover

 

donc j'en ai profité pour tester chameleon et ça fonctionne plutôt bien, mais il me semble pas encore au point. Pour pouvoir booter, je suis obligé d'utiliser l'option "Sans kernel cache" via GUI de chameleon, l'option "UseKernelCache=No" dans org.chameleon.Boot.plist ne fonctionne pas pour moi   :(   Mais la chose drôle, c'est que mes kexts sont tout de même chargés et je peux avoir QE/CI sur ma HD4830 avec ses kexts patchés   :blink:

 

Et on est pas obligé d'indiquer où se trouve "kernel", chameleon le trouve tout seul.. ah, bon chien, chien ça   :P

 

J'ai mis aussi l'option "Legacy logo" et je peux donc retrouver l'ancien logo gris + la barre de défilement grise

 

@ Hervé

 

pour ta mise à jour, oui il semblerait que cela est arrivé à d'autres aussi... à priori l'install de la mise à jour ne s'est pas faite dans les règles de l'art... une réinstallation de celle-ci règle le problème

 

Attached File  Capture d’écran 2014-07-09 11.19.20.png   164.55KB   2 downloads Attached File  Capture d’écran 2014-07-09 12.31.06.png   142.88KB   2 downloads

 



#18
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,955 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

:)

 

pour ma part , je charge , encore 45 mn , vu mon débit à 250 ko/s , j'ai le temps de me promener :D , chamaleon ne fonctionne pas pour moi , je reste sur Clover , pas si mal mais bon , j'ai une préférence pour chameleon , il reconnais mieux mon CPU , vu comme Xeon et non i7 .



#19
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,955 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

MAJ sans histoire :) je n'ai rien changé .

 

 

 

 



#20
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 823 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

Bon, j'ai fini par "clouer le salopard" comme disent les Brits. Non mais... Suis passé par une mise à jour Combo.

 

Attached File  D630n_10.10DP3.jpg   103.83KB   2 downloads







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy