Jump to content

Ayuda con bootloader y tarjeta gráfica


  • Please log in to reply
14 replies to this topic

#1
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hola a todos, necesito ayuda con OS X Mavericks, ya que es mi primera vez en Hackintosh y me han surgido diversos problemas tras la instalación. 

 

He sido capaz al menos de instalarlo y de que sea funcional y aquí estoy escribiendo desde Hackintosh, pero tengo un problema.

Tras instalar Chameleon para poder bootear desde el disco duro, quito el boot USB, reinicio e intento arrancar desde el HDD, pero me sale el error de boot0:GPT boot0: test boot0:error y no hay manera. 

Si no está enchufado el boot USB que si no me equivoco lleva Chimera, no puedo bootear OS X.

Y para colmo, otro problema que tengo es que no me deja usar el HDMI de mi tarjeta gráfica (Nvidia GT 630).

Me reconoce la tarjeta gráfica en Acerca de este Mac porque la tengo enchufada por VGA a la pantalla, pero a la hora de usar el HDMI, es que se queda la pantalla totalmente en negro desde que inicio el ordenador, no se ve nada. He intentado instalar el kext de mi tarjeta gráfica con Kext Utility y aparentemente se instala correctamente, pero vamos, lo mismo, es enchufar HDMI y que no se vea nada...

Por cierto, por si es útil, tengo que arrancar con la bootflag GraphicsEnabler=Yes

 

¿Algún entendido del tema puede ayudar? 

 

Aquí las características de mi PC: 

Procesador: Intel Core i3 2,79 GHz

Memoria: 4 GB 1600 MHz DDR3

HDD: TOSHIBA DT01ACA050

 

Muchas gracias y un saludo!  :wink_anim:



#2
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

Seja bem-vindo.

 

Sobre erro de 4k: http://www.insanelym...tosh/?p=2028496

 

Qual i3 usa? Sandy, Ivy ou Haswell?

 

Não damos suporte para Chimera, ou qualquer ferramenta do TonyMac.

 

Para ter video HDMI, requer em alguns casos, edição de DSDT ou framebuffer.



#3
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hola y gracias por tu respuesta! 

Me ha sorprendido que me respondieras en portugués, pero nos podemos entender  :yes:

 

Mi i3 es de tercera generación, así que supongo que es Ivy Bridge.

 

He conseguido instalar Chameleon al disco duro pero cuando selecciono el HDD para bootear pasan unos segundos y se reinicia el pc, así que de momento sigo usando el boot USB, pero por lo menos ya puedo acceder a Chameleon!

No sé a qué se debe que se reinicie sólo y no sé como solucionarlo...

 

Y si necesito editar el DSDT para hacer que funcione el HDMI, cómo podría hacerlo? 

 

Muchas gracias por tu ayuda :)



#4
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

Verifica se o arquivo "boot" está na raiz do HDD, e se a pasta Extra foi criada.



#5
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Sí, ambas cosas están en la raíz.

¿Puede ser que me falte algún .kext?



#6
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

de boot com -v, e poste uma foto aqui.



#7
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hecho... Empieza así:

 

Attached File  la foto 1.JPG   111.84KB   1 downloads

 

Luego sigue así, pero antes de terminar el análisis de errores se reinicia

 

Attached File  la foto 2.JPG   137.44KB   1 downloads



#8
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

de boot com -v -f



#9
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Sin resultado, se reinicia solo  :(



#10
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

tente esse: 

-f -v GraphicsEnabler=Yes IntelCapriFB=3


#11
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Sigue reiniciándose.
Por lo menos he solucionado el problema del HDMI instalando NVEnabler.kext y ya funciona.
Quizás debería probar otro bootloader?

#12
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

Pode ser uma incompatibilidade com o Chameleon e Chimera. As vezes os arquivos não foram instalado corretamente.

 

Qual versão do Chameleon está usando?



#13
MarioSocrazy

MarioSocrazy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Estoy usando la versión más reciente (2.1 r-2069)

Debería probar Clover?



#14
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,543 posts
  • Gender:Male
  • Location:Brazil

A versão mais recente é essa: Chameleon 2.2 svn r2391



#15
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,410 posts
  • Gender:Male
  • Location:Tru, Venezuela

Hola. Ese reinicio instantaneo es NORMAL desde hace un tiempo para acá en configuraciones sandy e Ivy bridge, ocasionado por el registro de operaciones MSR 0xE2. Entonces debes arreglar varias cosas para saltarlo. Léete este tópico para ver si entiendes lo que debes hacer: http://www.insanelym...-reinicia-loop/

 

Hay que tener la dsdt corregida con los parches para sandy bridge. También tener los estados del procesador (CPU) funcionando (C-States y P-States) desde las tablas SSDT a partir de Lion 10.7.4 que fue el hallazgo de RevoGirl, pero en estos momentos pudieras arrancar instalando el NULLCPUPowerManagement.kext. Luego necesitas adicionalmente parchear el AICPM.kext. Es probable que puedas arrancar con "DropSSDT=Yes" para descartar las tablas SSDT con errores.

 

También te pudieran servir:

GenerateCStates=Yes

GeneratePStates=Yes

 

La(s) tabla(s) SSDT se corrige de la siguiente manera: http://www.insanelym...-108/?p=1815873

 

Algo en Español que te pudiera interesar sobre el tema: http://www.nosolohd....t=3166&page=150

 

Y aqui: http://www.insanelym...step/?p=1818943

 

POR CIERTO, dicho problema NO tiene relación con el bootloader o la gráfica, por lo tanto es OFF-TOPIC. Así que, por favor abre otro tópico.

 

Ah, por favor les pido que mantegamos esto en Español. No sé, por ejemplo utilizar traductores, etc. Gracias y Saludos.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy