Jump to content

ALC898 Issue on Mavericks


  • Please log in to reply
1 reply to this topic

#1
cacoe

cacoe

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hi all.

 

I'm posting this from my successful install of Mavericks on my AMD build. Quite surprised it was so easy, and everything works perfectly apart from one thing. I do have one problem though. Sound!

 

Specs:

Mobo: SABERTOOTH 990FX R2.0

Proc: AMD 8350fx BE

RAM: 8gb 1600mhz

GPU: AMD R9 270x (very surprised that this worked out of the box with full support!)

 

 

So, the issue is sound. My motherboard has the Realtek ALC898.

 

I actually used a 'distro' to install. Steps I had to take:

- remove certain kexts from the installer usb stick I had to avoid a bluetooth error

- delete the intel power management kext to stop freezing

 

 

My install included VoodooHDA but there was intense noise coming out of my speakers with this, so I removed it (am I right in thinking it doesn't support optical out either?)

 

I then went on to install the kext from the Mavericks version of ##### <<< An app that is quite beastly, the kexts are in place but still no sound at all.

 

So I deleted them and went searching for the correct standalone kexts. HDAenabler and the modified appleHDA.kext, 99% sure I had the right ones but still no luck.

 

The volume icon is greyed out and I have no hardware showing under sound in system preferences.

 

Perhaps the hardware ID is wrong inside the kext for my mobo?

 

Does anyone have any suggestions?



#2
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,823 posts
  • Gender:Male
  • Location:Brazil

For AMD systems the best alternative is to use VoodooHDA.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy