Jump to content

DV6-6xxx DV7-6xxx OS X Yosemite 10.10 GM


  • Please log in to reply
148 replies to this topic

#1
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy
 
(DV7-6180sl) DV6-6xxx DV7-6xxx OS X Yosemite 10.10 GM
 
EDIT POST 10 Settembre 2014
 
• Per tutte le successive DP è necessario solo ricaricare AppleHDA.kext patchato.
 
• Alla fine del post ho messo il DSDT patchato per ACPIBatteryManager.kext del DV6.
 
EDIT POST 10 Agosto 2014
 

Ciao a tutti,

 

finalmente sono soddisfatto del risultato ottenuto... :D    

Penso che ora posso sostituire il caro vecchio Mountain Lion...  :yes:

Con ML era stato raggiunto un risultato incredibile: funzionale, affidabile e veloce. Non ricordo sinceramente quando ho avuto l'ultimo kernel panic, forse un anno fa!!! (Grazie a Micky, senza di lui questo non sarebbe accaduto....  :wink_anim:  )

 

Invece Mavericks non mi aveva convinto... 

 

Vi posso assicurare che Yosemite è migliore a sai!!!   :yes:

 

Negli ultimi mesi ho usato sia Clover che Chameleon/Enoch, ho sostituito più volte il bootloader nel tentativo di risolvere alcuni inconvenienti, specie gli artefatti:

che con Chameleon non si presentavano... Con Clover si. Ho chiesto un po’ in giro e per risolvere il problema è bastato selezionare “slide=0” nel boot.

 

Nell'uso e nella configurazione di Yosemite, penso che a oggi, per svariati motivi Clover sia superiore, questo bootloader si adatta meglio all'hardware, i vantaggi sono diversi:

abbiamo un hack più reale al Mac, molte patch a portata di clic, lapic kernel patch, gestione della CPU, NVRAM configurata ad hoc per il funzionamento di iCloud e iMessage, ecc...

 

Vi metto a disposizione tutti i file da me usati negli ultimi giorni… fatene buon uso!  :D

 

 
Yosemile.png

 

 

 

 

 

 

Guida di riferimento di carbo178 (Thanks): http://www.insanelym...0-yosemite-dp1/

 

Installazione eseguita con:

 

• Clover 2747 (con patch kernel lapic funzionante e caricamento dei kext nella cartella 10.10): http://www.hackintos...125-clover-v2k/

 

Legacy mode:

 

Legacy Mode.png
 
UEFI Mode:
 
UEFI mode.png

 

 

 

• fakeSMC + AppleIntelCpuPowerManagement + keyboard e ps2 kext + WifiInjector (Atheros 9250).

 

• config.plist personalizzato, che vi allego (ricordatevi di cambiare il numero di serie con Clover configuration e abilitare inject EDID con vostro relativo codice IODisplayEDID):      http://www.mediafire...onfig.plist.zip

 

• Intel HD 3000 funzionante nativamente.

 

• Radeon 6770m non funzionante. Disattivata scheda video con bios mod insydeH2O F1.A (L'ho ritenuto necessario per aumentare la durata della batteria e diminuire il surriscaldamento del notebook).

 

• Sostituita scheda WiFi con Atheros 9285 installato bios mod senza whitelist: insydeH2O F1.A - Funzionante.
 

• Audio funzionante con AppleHDA + HDAEnabler

  Credits for Kabyl for all HDAEnabler's. http://www.insanelym...-dp2/?p=2037350

 

• Trackpad - Keyboard funzionante con ApplePS2Controller.kext and AppleACPIPS2Nub.kext

 

• USB 2.0 e webcam funzionante nativamente. 

 

• USB 3.0 funzionante con GenericUSBXHCI.kext v. 1.2.8.d7

 

• DSDT DV7-6xxx patchato per la gestione della batteria

 

 Batteria funzionante con ACPIBatteryManager.kext

  link post dove ne parlo            #33             Credits for RehabMan 

 

• Kext di base necessari per installazione e funzionamento 

 

 

Attached File  EDID Installer.pkg.zip   4.28KB   273 downloads

 
 
Attached File  FanControl1.2.dmg   2.5MB   371 downloads
 
 
 
 

 

 

Attached Files



#2
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

Per i più esperti di me con Clover se potete dare un'occhiata, correggere o dare dei consigli (che sono sempre ben accettati) sulla configurazione del file config.plist che ho messo nel primo post in alto!

Ciao. Grazie



#3
friscos

friscos

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 540 posts
  • Gender:Male
  • Location:Roma
Ciao Conti
Scusa, siccome non riesco a fare il boot e le sto provando tutte, mi puoi dire quel "NUOVO AppleIntelCPUPowerManagement.kext" se lo metti nella cartella 10.10 in EFI o in system..
 
Poi non mi è chiara un'altra cosa dagli screen, se fai un'installazione uefi la spunta nella ESP la devi mettere altrimenti clover si installa nella root (ho già provato) come fosse un'installazione legacy.


#4
alboz83

alboz83

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts

Ciao a tutti, dopo un pò di tempo ho deciso di rifarmi l'hackintosh e provare il nuovo Yosemile. Aiuto ho seguito la guida di carbo e sono riuscito ad installarlo e farlo partire ma è di una lentezza pazzesca. Così ho seguito questa guida (io ho un dv6-3xxx, ma molti driver e periferiche sono le stesse) e qualcosa è migliorata a parte le lentezza. Molto probabilmente è colpa della scheda video, perchè io ho una Intel 1st generazione, e devo fare vari tentativi per farla funzionare (e probabilmente reinstallare tutto da zero varie volte). Comunque una cosa non mi è chiara, io non ho UEFI quindi dovrei installare Clover in modalità legacy, ma perchè nella immagine dici di installare Driver64UEFI? Premetto che di Clover non ci capisco nulla, è la prima volta che provo ad usarlo perchè sino ad ora usavo Chameleon. Thaaanks



#5
carbo178

carbo178

    Insanely Salam da l'aj

  • Local Moderators
  • 10,231 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
In effetti se non si installa in Uefi bisogna selezionare i driver64 normali.
Per la scheda video penso che il problema della lentezza sia da imputare al fatto che non è supportata dal sistema e non so se con qualche accorgimento la si possa far riconoscere

#6
alboz83

alboz83

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts

In effetti se non si installa in Uefi bisogna selezionare i driver64 normali.
Per la scheda video penso che il problema della lentezza sia da imputare al fatto che non è supportata dal sistema e non so se con qualche accorgimento la si possa far riconoscere

Infatti se uno ha il Bios credo debba lasciar stare qualsiasi cosa che riguarda Uefi e Efi.
Io sino a Mavericks sono sempre riuscito a far andare al scheda video, c'è un thread apposito in cui un'utente ha postato i kext funzionanti però per il suo sistema. Siccome ci sono tre diversi metodi per patchare AppleIntelHDGraphicsFB.kext tramite un tool, bisogna andare a tentativi, solo che ho provato il primo e adesso non si avvia più nulla, penso di dover reinstallare nuovamente tutto. Poi però devo anche capire se c'è qualcosa da settare su Clover, è un pò complicato come bootloader, devo imparare a conoscerlo. 
Infine per quanto riguarda i driver64 o non sò anche i driver32, cosa consigliate di selezionare? 



#7
carbo178

carbo178

    Insanely Salam da l'aj

  • Local Moderators
  • 10,231 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Seleziona solo i driver64



#8
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

 

Ciao Conti
Scusa, siccome non riesco a fare il boot e le sto provando tutte, mi puoi dire quel "NUOVO AppleIntelCPUPowerManagement.kext" se lo metti nella cartella 10.10 in EFI o in system..
 
Poi non mi è chiara un'altra cosa dagli screen, se fai un'installazione uefi la spunta nella ESP la devi mettere altrimenti clover si installa nella root (ho già provato) come fosse un'installazione legacy.

 

 

Si confermo quello che hai detto: la stinta anche su ESP... è che mi è rimasto selezionato ma non l'ho stentato per errore... lo correggo!!

 

Si AppleCPUPower.... lo devi mettere nei kext nella cartella EFI/Clover/kexts/10.10

Attached Files



#9
alboz83

alboz83

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
Dopo tantissime prove sono riuscito ad installare Yosemite sul mio HP, però ho usato chameleon. Ora ho tre grossi problemi
1) posso avviare solo con cpus=1 perché il lapic kernel patcher, tool che usavo per far andare il mach_kernel, non cambia nulla.
2) non funziona il WiFi, ma quando provai Clover invece andava
3) non funzionano le 2 USB di sinistra, le altre 2 di destra invece si.
Qualcuno può darmi una mano?
Grazie mille

#10
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

Dopo tantissime prove sono riuscito ad installare Yosemite sul mio HP, però ho usato chameleon. Ora ho tre grossi problemi
1) posso avviare solo con cpus=1 perché il lapic kernel patcher, tool che usavo per far andare il mach_kernel, non cambia nulla.
2) non funziona il WiFi, ma quando provai Clover invece andava
3) non funzionano le 2 USB di sinistra, le altre 2 di destra invece si.
Qualcuno può darmi una mano?
Grazie mille

 

Si in effetti finche non viene rilasciato il kernel lapic patch non puoi utilizzare tutti i core... per ora solo con chameleon...

che wifi hai?



#11
alboz83

alboz83

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts

Si in effetti finche non viene rilasciato il kernel lapic patch non puoi utilizzare tutti i core... per ora solo con chameleon...

che wifi hai?

Alla fine ho provato a sostituire Chameleon con Clover scaricato da qui, ed ora il Wifi mi funziona (ho Atheros AR9285). Funziona anche senza avviare con cpus=1 selezionando Kernel Lapic nelle impostazioni di Clover, e funzionano pure le USB. Per ora l'unica cosa che non funziona è l'audio nonostante abbia sostituito AppleHDA, dovrei patchare HPET ma non riesco ad estratte il dsdt in nessun modo, proverò da windows



#12
soloh_shadi

soloh_shadi

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
  • Gender:Male
  • Location:Rome - Italy

 

...........WifiInjector (Atheros 9250).

 

 

Ciao, vorrei chiederti se potessi allegare l'injector della 9285.

 

Sono su 10.10 dp2 (notebook in firma) e l'unica cosa che non riesco ad attivare è la mia scheda ar9285.

 

Grazie 1000



#13
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

Ciao, vorrei chiederti se potessi allegare l'injector della 9285.

 

Sono su 10.10 dp2 (notebook in firma) e l'unica cosa che non riesco ad attivare è la mia scheda ar9285.

 

Grazie 1000

 

Ciao, eccolo qua! scusa il ritardo....

Attached Files



#14
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

Ciao a tutti,

sono riuscito a patchare l'audio usando come riferimento: http://www.insanelym...-yosemite-dp2/ . Credits for Kabyl for all HDAEnabler's.

 

Comunque per semplificarvi la vita vi posso dire che il DSDT di Micky (un pilastro) non è da editare.

 

Vi allego i kext da caricare sempre in S/L/E

testato e funzionante con Clover e Chameleon/Enoch (necessario inserimento del boot flag: kext-dev-mode=1).

Attached Files



#15
te4o

te4o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:milano
Ma tu hai eseguito la guida di carbo178 usando la DP2?
E che kext hai messo nella cartella 10.10?

..perché io non riesco a far partire l installazione

#16
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

Ma tu hai eseguito la guida di carbo178 usando la DP2?
E che kext hai messo nella cartella 10.10?

..perché io non riesco a far partire l installazione


Hai bisogno di inserire soltanto i kext fondamentali, minimi per far partire l'installazione:
fakeSMC, nullCpuPowerManagement o AppleIntelCpuPowerManagement e keyboard e ps2 kext

Dove ti si blocca l'installazione?

#17
te4o

te4o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:milano

io ho messo AppleIntelCpuPowerManagement, fakeSMC, AppleHDA e quelli per mouse e tastiera

uso la DP2

comunque non mi parte proprio. quando faccio il boot dell installazione va subito in panico



#18
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

io ho messo AppleIntelCpuPowerManagement, fakeSMC, AppleHDA e quelli per mouse e tastiera
uso la DP2
comunque non mi parte proprio. quando faccio il boot dell installazione va subito in panico


Metti quello Nuovo di IntelCPUPower...
ApplaHDA per fare l'installazione non ti serve.
E poi se usi Chameleon come bootloader devi fare il boot con cpus=1
Avvia in verbose mode e fai una foto dell'errore che vediamo di cosa si tratta

#19
te4o

te4o

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:milano

Metti quello Nuovo di IntelCPUPower...
ApplaHDA per fare l'installazione non ti serve.
E poi se usi Chameleon come bootloader devi fare il boot con cpus=1
Avvia in verbose mode e fai una foto dell'errore che vediamo di cosa si tratta

Uso giá quello nuovo postato da te.
Non uso Chameleon ma Clover, l'ultima versione disponibile
Qua ho bootato solo con -v

Ti ringrazio per il tuo tempo

Attached Files



#20
simconti

simconti

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male
  • Location:Italy

Uso giá quello nuovo postato da te.
Non uso Chameleon ma Clover, l'ultima versione disponibile
Qua ho bootato solo con -v

Ti ringrazio per il tuo tempo

Sembra un problema di cache... errore generato dal ACPIPlatform

Prova a mettere questo config.plist

Visto che usi la DP2 aggiorna anche Clover: http://www.hackintos...125-clover-v2k/

Ciao

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy