Jump to content

Intel HD 4600 QE/CI Yosemite


  • Please log in to reply
483 replies to this topic

#481
rimkashox

rimkashox

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Ok perfect, so if I understand you correctly, because I have more then 8 GB of RAM (I have 16), the system allocates 1536 MB of VRAM instead of 1024. For the ig-platform-id, I inject it in DSDT.. Here's my code, I stayed with GFX0, if I renaming it to IGPU in any way possible, but I get a kernel panic every time : / ... I have power management, thanks to your post, and it seems to work well, even for GFX0 so I guess it's good for now.. 

                Device (GFX0)
                {
                    Name (_ADR, 0x00020000)  // _ADR: Address
                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                    {
                        If (LEqual (Arg2, Zero))
                        {
                            Return (Buffer (One)
                            {
                                 0x03
                            })
                        }

                        Return (Package (0x04)
                        {
                            "AAPL,ig-platform-id", 
                            Buffer (0x04)
                            {
                                 0x03, 0x00, 0x22, 0x0D
                            }, 

                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }
                        })
                    }
                }


#482
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,743 posts
  • Gender:Male

 

 I have power management, thanks to your post, and it seems to work well, even for GFX0 so I guess it's good for now.. 

IOReg shows no GPU power management.  For native GPU PM, use IGPU or edit AppleGraphicsPowerManagement.kext.  For IGPU dsdt edits, see Post #/HD4600/9 Series in Yosemite AppleHDA HDMI Audio

 

IOReg also shows no Haswell CPU PM.



#483
rimkashox

rimkashox

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

IOReg shows no GPU power management.  For native GPU PM, use IGPU or edit AppleGraphicsPowerManagement.kext.  For IGPU dsdt edits, see Post #/HD4600/9 Series in Yosemite AppleHDA HDMI Audio

 

IOReg also shows no Haswell CPU PM.

 

 

Hey man, I installed pm after making the first post.. here's my present ioreg with pm on both... I'll try again to rename GFX0 to IGPU.. Thanks !

Attached Files



#484
applehacks

applehacks

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Interests:Hackintosh, sci-fy

I am new to clover and have been mildly successful i think.

 

Z97X UD5H, i7 4790K **Stock speed** 32GB 1600 DDR3 No DSDT or SSDT ALC1150 edits work great!!

 

When I try to inject the values to get QE/CI enabled it fixes the second stage boot garble and snow but I end up with 5MB graphics memory and no acceleration. 

 

<key>Graphics</key>

<dict>
<key>DualLink</key>
<integer>1</integer>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
</dict>
<key>InjectEDID</key>
<true/>
<key>NVCAP</key>
<string>0000000000000000000000000000000000000000</string>
<key>NvidiaSingle</key>
<false/>
<key>VRAM</key>
<integer>0</integer>
<key>VideoPorts</key>
<integer>0</integer>
<key>display-cfg</key>
<string>0000000000000000</string>
<key>ig-platform-id</key>
<string>0x0300220D</string>
</dict>
 
Not sure how to do this?
My FakeID is 0x0412 (Desktop HD4600)
 
No idea what to do and easily confused by all the info out there. Any pointers in the right direction would be appreciated.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy