Jump to content

Intel HD Graphics 4600 Can't change brightness.


Best Answer RehabMan, 11 June 2014 - 11:34 PM

THEN WHY YOU NO SEND ME THE FILES XD isn't it faster ?


You need to learn. If I do your work for you, you learn nothing and are still a dependent.
This is not the last time you'll need to patch your DSDT...

Here, do this:
- download your *own* files in post #75.
- the ZIP, Files.zip, will download to your 'Downloads' folder
- decompress Files.zip by double clicking in Finder
- open Terminal
- type:
cd ~/Files
iasl -da *.aml
open ssdt4.dsl ssdt5.dsl
- MaciASL is now open with both ssdt4.dsl and ssdt5.dsl.
- Activate each Window, in turn, and click Compile.

Report the result here. Go to the full post


  • Please log in to reply
155 replies to this topic

#141
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,461 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

Currently yes, I thought the usb2 arg has fixed the problem because I was used my laptop for 3 hours without a sudden restart yesterday :(


I don't know which USB WiFi device you're using. I've had ok results with my Edimax EW-7811UN with the latest drivers from edimax/realtek site. But early on I had stability issues, but I think that was when it was attaching to AppleUSBXHCI.kext instead of GenericUSBXHCI.kext.

At any rate, USB WiFi is not as reliable as native PCIe WiFi. If you have the opportunity to replace your incompatible PCIe WiFi with a compatible card, doing so is a "no brainer."

#142
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

I don't know which USB WiFi device you're using. I've had ok results with my Edimax EW-7811UN with the latest drivers from edimax/realtek site. But early on I had stability issues, but I think that was when it was attaching to AppleUSBXHCI.kext instead of GenericUSBXHCI.kext.At any rate, USB WiFi is not as reliable as native PCIe WiFi. If you have the opportunity to replace your incompatible PCIe WiFi with a compatible card, doing so is a "no brainer."

TP-Link TL-WN723N V3
How can I guarantee that the usb wifi is what doing this sudden reboots ?

#143
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,461 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

TP-Link TL-WN723N V3
How can I guarantee that the usb wifi is what doing this sudden reboots ?


There is no way to determine what is causing sudden reboots. Process of eliminating suspected causes...

Is that realtek based? Which drivers are you using?

#144
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

There is no way to determine what is causing sudden reboots. Process of eliminating suspected causes...

Is that realtek based? Which drivers are you using?

Yes it is....
However I don't need it anymore iOS 7.1.1 is jailbroken now and I can tether internet from my iPhone so I don't need a new wifi :D



#145
yushi90

yushi90

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male

Hi,

 

i have a weird issue. I can change brightness through brightness slider app from the app store, but it only changes from 50% down to 0.

 

It won't go over 50%.

 

I used the acpibrightness.kext or so from rehabman.



#146
lufeig

lufeig

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Sao Paulo, Brazil
  • Interests:Inline skating, Software, Android

dear Raff7M, i dont't know if this can help, but before replacing my stock intel wifi card for a compatible pcie wifi+bluetooth combo, i used the same TP-Link TL-WN723N V3 as you.

 

i was using drivers from hackintoshosx.com site, and in my personal experience, i used it with no reboots in two rigs: a samsung np530c ultrabook, and the hp envy 17t-j100 in my signature.



#147
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

There is no way to determine what is causing sudden reboots. Process of eliminating suspected causes...

Is that realtek based? Which drivers are you using?

Hello rehabman again!,

first of all sorry that i didn't answer the second part of your question i was in a harry and didn't noticed it.... i used this driver from here: http://www.hackintos...5n-v2-usb-wifi/     // because the original didn't work

I wanna ask you about replacing the wifi card on my lenovo...
I saw many reports about lenovo boards doesn't support any wifi card do you know anything about this...?
because i wanna do what you said, its better.. (replacing the wifi)



#148
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,461 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

Hello rehabman again!,
first of all sorry that i didn't answer the second part of your question i was in a harry and didn't noticed it.... i used this driver from here: http://www.hackintos...5n-v2-usb-wifi/     // because the original didn't work

I wanna ask you about replacing the wifi card on my lenovo...
I saw many reports about lenovo boards doesn't support any wifi card do you know anything about this...?
because i wanna do what you said, its better.. (replacing the wifi)


Off-topic, but I'll let the mods move it if they want to...

If it is Realtek-based USB WiFi, get drivers from Realtek site.

Lenovo laptops often have a BIOS whitelist that limits your choices. You may be able to flash a patched BIOS...

#149
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

Off-topic, but I'll let the mods move it if they want to...

If it is Realtek-based USB WiFi, get drivers from Realtek site.

Lenovo laptops often have a BIOS whitelist that limits your choices. You may be able to flash a patched BIOS...

I should have post this thread to notebooks forum from the beginning because it gone off-topic everywhere XD

I used drivers from realtek website first but their application did not open when I plug the usb-wifi  it shows the icon on the dock but wont run.

and does patching the bios may ruin it somehow ? // because you know if bios is gone the whole laptop is going to be trashed :P



#150
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,461 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

I should have post this thread to notebooks forum from the beginning because it gone off-topic everywhere XD

I used drivers from realtek website first but their application did not open when I plug the usb-wifi  it shows the icon on the dock but wont run.

and does patching the bios may ruin it somehow ? // because you know if bios is gone the whole laptop is going to be trashed :P


Make sure the drivers are attaching to AppleUSBEHCI (USB2), not AppleUSBXHCI.kext or GenericUSBXHCI.kext. So...

1) In the case of GenericUSBXHCI.kext use -gux_defer_usb2.
2) In the case of AppleUSBXHCI.kext install GenericUSBXHCI.kext see 1)

#151
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

Make sure the drivers are attaching to AppleUSBEHCI (USB2), not AppleUSBXHCI.kext or GenericUSBXHCI.kext. So...

1) In the case of GenericUSBXHCI.kext use -gux_defer_usb2.
2) In the case of AppleUSBXHCI.kext install GenericUSBXHCI.kext see 1)

Okay!, Thank you sir.



#152
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

.....

Hey RehabMan... I have updated to os x 10.10 and now my qe/ci has gone...

it shows me only Intel HD Graphics 4600 4MB

I tried this thread ##### but it didn't work for me... do you think it's possible to make it work again ?

Note: am using ig-platform-id
and DSDT SSDT patches

#153
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,461 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

Hey RehabMan... I have updated to os x 10.10 and now my qe/ci has gone...

it shows me only Intel HD Graphics 4600 4MB

I tried this thread #### but it didn't work for me... do you think it's possible to make it work again ?

Note: am using ig-platform-id
and DSDT SSDT patches

That fix works. You should read up on the background: https://pikeralpha.w...600-mobile-gt2/

#154
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

That fix works. You should read up on the background: https://pikeralpha.w...600-mobile-gt2/

I had a tiny improvement with animations
i did what he said but nothing seem smooth mouse lags and windows disappear :/
can I ask you to check my config.plist ?
 

Attached Files



#155
Raff7M

Raff7M

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

That fix works. You should read up on the background: https://pikeralpha.w...600-mobile-gt2/

I fixed it with little more effort, but can I ask you for the best AppleHDA patching guide there are too many out there.
Thanks.



#156
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,461 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

I fixed it with little more effort, but can I ask you for the best AppleHDA patching guide there are too many out there.
Thanks.


I've not done a patched HDA from beginning to end. But I would probably start with Mirone's post.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy