Jump to content

(success) GA-H87M-D3H - i5 4570 - HD 4600


  • Please log in to reply
3 replies to this topic

#1
n3r3d3

n3r3d3

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

System Configuration:

  • CPU: Intel Core i5 4570 @3.4 GHz
  • GPU: internal Intel HD4600
  • RAM: 1x4GB 1600Mhz
  • HDD: Kingston 120 GB SSD

Component Status:

  • Graphics including HDMI Tick.png
  • Ethernet Tick.png
  • USB 3.0 Tick.png
  • App Store Tick.png
  • Sleep, Wakeup, Poweroff Tick.png

 

BIOS changes:

  • xHCI mode is auto
  • xHCI and EHCI Hand-off is enabled
  • Vt-D is disenabled

 

Installation Method:

  • USB installer Method; bootflag; -v -x (for only installation and first boot)

Post-Installation:

  • ALC892 (without DSDT), RealtekRTL81xx v0.0.90 ,TRIM enabler, NullCPU
  • no need DSDT (if use dsdt, following this link; http://www.insanelym...dsdt/?p=2020402 )
  • SSDT generation script; ssdtPRGen.sh

 

smbios; imac14,2 (for haswell cpu power managament)

 

boot.plist;

	<key>DropSSDT</key>
	<string>Yes</string>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GUI</key>
	<string>No</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>"1920x1080x32"</string>
	<key>IGPEnabler</key>
	<string>Yes</string>
	<key>IGPlatformID</key>
	<string>0D220003</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>Yes</string>



#2
drule

drule

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

What BIOS version? (I started with F7, but updated to F9 - did not seem to make a difference)

 

I will give your DSDT a try, as I've been having some problems with USB3/Legacy detection (yes, I have same BIOS XHCI/EHCI settings as you) and long sleep.

 

My system:

 

i3-4150
GA-H87M-D3H F9 BIOS
1 x 4GB 1600mhz non-ECC RAM module (reported as installed on slot 4, when actually installed on slot 1)
Gigabyte Nvidea GTX 650 OC
Mavericks 10.94 installed and running, using Chamelon v2.2svn 2377 (darkwake=0 dart=0 generate P/C-states restart-fix) w/SMBios iMac14,2 and the kexts from Rampage's site for this board, plus Nvid DSDT patch file in /Extra.
Removed NullCpuPowerManagement.kext after installation
Had to install VoodooHDA to get it to recognize the ALC892 audio on the MB.
 
Everything seems to be working (no problem with app-store or icloud), but sometimes I get "beach balled" when coming out of sleep after a few times (never on the first time waking up). And my Bluetooth MagicMouse can gets sluggish sometimes.
Also some problems with correct USB port recognition (it thinks legacy USB 2 ports are USB3).
 
If anyone thinks they can help me with my DSDT, I will upload all my IORegistry report and other pertinent files to DropBox and post the link.
 
NOTE: What is best way to extract my DSDT? I don't have Windows or Linux, just Macs.
 
Thanks


#3
drule

drule

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

I seem to have fixed the sluggish Bluetooth SuperMouse by moving the Bluetooth Broadcom dongle to a USB3 port (it was on a USB2 port).



#4
vrishcons

vrishcons

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male

 

System Configuration:

  • CPU: Intel Core i5 4570 @3.4 GHz
  • GPU: internal Intel HD4600
  • RAM: 1x4GB 1600Mhz
  • HDD: Kingston 120 GB SSD

Component Status:

  • Graphics including HDMI Tick.png
  • Ethernet Tick.png
  • USB 3.0 Tick.png
  • App Store Tick.png
  • Sleep, Wakeup, Poweroff Tick.png

 

BIOS changes:

  • xHCI mode is auto
  • xHCI and EHCI Hand-off is enabled
  • Vt-D is disenabled

 

Installation Method:

  • USB installer Method; bootflag; -v -x (for only installation and first boot)

Post-Installation:

  • ALC892 (without DSDT), RealtekRTL81xx v0.0.90 ,TRIM enabler, NullCPU
  • no need DSDT (if use dsdt, following this link; http://www.insanelym...dsdt/?p=2020402 )
  • SSDT generation script; ssdtPRGen.sh

 

smbios; imac14,2 (for haswell cpu power managament)

 

boot.plist;

	<key>DropSSDT</key>
	<string>Yes</string>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GUI</key>
	<string>No</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>"1920x1080x32"</string>
	<key>IGPEnabler</key>
	<string>Yes</string>
	<key>IGPlatformID</key>
	<string>0D220003</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>Yes</string>

What type of connection u have to monitor. HDMI or VGA. Tried all the above with clover and chameleon boot loader. No success 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy