Jump to content

Intel HD 4000 - distorted image through HDMI (Maverics)

intel HD 4000 Inspiron 15R Maverics HDMI

  • Please log in to reply
1 reply to this topic

#1
Rumcajz

Rumcajz

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Good afternoon gentlemen!

 

I've installed Niresh Maverics 10.9 using the dual Clover-USB + MacOS USB installer method.

 

My laptop is a Dell Inspiron 15R 5521 Intel Core i5 with Intel HD 4000 64 MB graphics and 16 GB RAM.

 

I have an issue with HDMI displaying garbage.

 

Step by step what I do is:

 

1) Clover boot screen appears, I select options

https://www.dropbox....a9isrmhck/2.jpg

 

2) Go to the Graphics Injector menu:

https://www.dropbox....1shbz7to0/3.jpg

 

3) Check "Inject EDID" and configure the rest as depicted:

https://www.dropbox....ukd1lrvi5/4.jpg

 

4) Maverics boots and the image is displayed only on the laptop's screen, the external display connected via HDMI remains blank.

I see no kext is loaded for Intel HD 4000 and the amount of RAM reported is only 4 MB (on Windows 7 it shows 64 MB):

https://www.dropbox....qgaeevkah/5.jpg

 

When I repeat this procedure without touching anything in the "Graphics Injector" menu, then what I get is HDMI displaying garbage while the laptop's screen remains blank:

https://www.dropbox....uzeg68xe4/6.jpg

 

Unplugging and plugging HDMI again does not fix the problem.

 

I've already installed Niresh kexts from 10.9_Intel_HD_3000_&_HD_4000_Driver_,zip using Kext WIzard, but this changed nothing.

I think these kexts are not even loaded, screenshot from step 4) shows that.

 

I feel I'm close, but I am slowly getting tired and getting out of ideas on how to proceed, especially that I'm a beginner in the Mac world.

 

Please help a borther out. What do I need to do to make HDMI work?

 

Regards,

Rumcajz



#2
soloh_shadi

soloh_shadi

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
  • Gender:Male
  • Location:Rome - Italy

 

 

 

My laptop is a Dell Inspiron 15R 5521 Intel Core i5 with Intel HD 4000 64 MB 

 

 

You don't have Qe/Ci enabled. Extract your dsdt e attach.








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy