Jump to content

R9 290X Help for mavericks

R9 290X

  • Please log in to reply
199 replies to this topic

#1
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

So Let's try this again without all the useless negative talk from non 290x and 290 owners as of 10.9.3 newest beta's the id for the 290x and 290 are built in to amdradeon7000.kext but it will not load the driver due to missing buffer and if we can figure out this issue we should have fully working 290x and 290 now please don't post useless info like one person was doing in the last thread just post fixes and progress we don't need spammers thanks. 

 

 

 

<key>AMDHawaiiGraphicsAccelerator</key>
<dict>
<key>ATIEnableWideBlitSupport</key>
<true/>
<key>ATIUseTearingWideBlit</key>
<false/>
<key>CFBundleIdentifier</key>
<string>com.apple.AMDRadeonX4000</string>
<key>GpuDebugPolicy</key>
<integer>0</integer>
<key>IOClass</key>
<string>AMDHawaiiGraphicsAccelerator</string>
<key>IODVDBundleName</key>
<string>AMDRadeonVADriver</string>
<key>IOKitDebug</key>
<integer>0</integer>
<key>IOMatchCategory</key>
<string>IOAccelerator</string>
<key>IOPCIMatch</key>
<string>0x67B01002</string>
<key>IOProbeScore</key>
<integer>200</integer>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOSourceVersion</key>
<string>0.0.0.0.0</string>
<key>IOVARendererID</key>
<integer>16908288</integer>
<key>sensor-properties</key>
<array>
<dict>
<key>device_type</key>
<data>
Z3B1LXNlbnNvcg==
</data>
<key>location</key>
<string>GPU</string>
<key>name</key>
<string>gpu-sensor</string>
<key>polling-period</key>
<data>
AAAAAQAAAAA=
</data>
<key>reg</key>
<data>
AAAAAg==
</data>
<key>sample-period</key>
<data>
AAAAAACYmAA=
</data>
<key>sensor-id</key>
<data>
AAAABg==
</data>
<key>version</key>
<data>
AAAAAg==
</data>
<key>zone</key>
<data>
AAAAAg==
</data>
</dict>
</array>
</dict>
it's there ......and more great news the device id is in amd7000controller.kext driver hmm but what i need to know is the framebuffer in the right place and working 
 


#2
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

all things have been tried guess we must wait for the full driver set or till 10.9.4 



#3
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

new beta for 10.9.3 i am updating and trying now



#4
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

new beta for 10.9.3 i am updating and trying now

Any News?



#5
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

Any News?

after trying a dsdt the igpu and fbroate and so many other tricks it's safe to say nothing works but i did get my hd4000 to work and it's weird i can play hd videos and a few games without the driver kext loaded 



#6
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

after trying a dsdt the igpu and fbroate and so many other tricks it's safe to say nothing works but i did get my hd4000 to work and it's weird i can play hd videos and a few games without the driver kext loaded 

Maybe 10.9.4 support the new AMD FirePro™ W9100 with r9 r290x :)
I need EPIC ALPHA version of 10.9.4 included driver!

 

#7
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

 

Maybe 10.9.4 support the new AMD FirePro™ W9100 with r9 r290x :)
I need EPIC ALPHA version of 10.9.4 included driver!

 

 

yes that would be epic and i do see it as a upgrade for the macpro trash can also so i see it coming 


 

Maybe 10.9.4 support the new AMD FirePro™ W9100 with r9 r290x :)
I need EPIC ALPHA version of 10.9.4 included driver!

 

 

my best bet is 10.9.4 or 10.10 it depends if the firepro w9100 launched yet



#8
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

yes that would be epic and i do see it as a upgrade for the macpro trash can also so i see it coming 


my best bet is 10.9.4 or 10.10 it depends if the firepro w9100 launched yet

Haha yeah....

You tried this? http://www.insanelym...m/#entry1975032



#9
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

Haha yeah....

You tried this? http://www.insanelym...m/#entry1975032

nope but if you want to try go head 



#10
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Good news: https://github.com/R...48e60f34d5e030a



#11
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

I am guessing this is good :thumbsup_anim:



#12
ManOnTheMoon

ManOnTheMoon

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi there...

this is my first post, and i know that this is a mac- or hackintosh forum but i have some experience with the windows drivers of the r9 290X that might or might not be helpful at some point....

I have the r9 290   modded to r9 290X by a bios update and I am using the FirePro drivers. This is what i learned in the process... (keep in mind it is about windows, so it might or might not be the same regarding mac)

 

1. the memory size of the card is not important because it is determined by the driver

2. the 67a0 and 67b0 refer to the hawai PRO with Shaders/TMUs/ROPs: 2816/176/64

3. the ecc option of the 67a0 cards is turned off by default so it doesnt conflict with the non ecc ram of the 67b0. (I didnt turn it on with the r9 290X because i really have no idea what would happen)

 

so if there is a driver for the AMD FirePro W9100 (FireGL V)  or a macintosh equivalent that has 67a0 id it should work or at least  my guess would be that it shouldnt be too hard to make it work with the 67b0 cards

 

Again i realy dont know anything about macintosh drivers yet though i am willing to learn...



#13
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Official Firepro W9100 drivers out!
http://support.amd.c...=Windows 7 - 64
OS X support very close for R290/R290X!!!!



#14
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

Official Firepro W9100 drivers out!
http://support.amd.c...=Windows 7 - 64
OS X support very close for R290/R290X!!!!

sooo close so 10.9.3 final the drivers should be in it ya? 


jason go into chat let's talk a bit 



#15
Ir0nSlug

Ir0nSlug

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

I know this is jumping the gun a bit but say these fire pro drivers make the r9 290s work on a hackintosh wouldn't crossfire be possible? doesn't the new mac pro use 2x fire pros? 



#16
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Screen_Shot_2014_05_15_at_17_51_22.png

R9 R290X is working OOB full resolution only need a little mod driver to fully work!

VRAM: 10MB????? What a .....



#17
Ir0nSlug

Ir0nSlug

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Screen_Shot_2014_05_15_at_17_51_22.png

R9 R290X is working OOB full resolution only need a little mod driver to fully work!

VRAM: 10MB????? What a .....

how did you manage that?



#18
JasonHUN

JasonHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

how did you manage that?

I dont know!
I need more VRAM! MAybe a little tweak enables more VRAM! (4096 MB available)

 

Clover has a VRAM option in the Graphics section.

 

<key>Graphics</key>
    <dict>
        <key>VRAM</key>
        <integer>512</integer>
        <key>DualLink</key>
        <string>1</string>

    </dict>

 

I using chimera.



#19
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,772 posts
  • Gender:Male
  • Location:Bcn-Spain

ah!!  and what about this line: Kernel Extensions info: no Kext Loaded :P  this not working O.O.B :(  only full resulution, but no QE/CI  :(



#20
TechGuru

TechGuru

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 148 posts
  • Gender:Male

ah!!  and what about this line: Kernel Extensions info: no Kext Loaded :P  this not working O.O.B :(  only full resulution, but no QE/CI  :(

i agree on that front haha and may i ask https://github.com/R...48e60f34d5e030a <what does all this mean







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy