Jump to content

[Success] OS X Mavericks 10.9.2 on HP Elitebook 8440p with 1st Generation Intel HD Graphics

HP Elitebook 8440p OS X Mavericks 10.9.2 Installation Success Chameleon

  • Please log in to reply
5 replies to this topic

#1
w1r3d

w1r3d

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Following a week of trial and error (a lot of errors), I was finally able to install last night my first Hackintosh!

 

First attempt using Clover boot loader did not work and resulted mostly in kernel panic. Second attempt with Chameleon got me closer, but still I could not figure out what was wrong. The one thing that my gut feeling told me was that I may need to make sure I have maxed out my RAM with identical SO-DIMMs. When I started, the Elitebook had one 4GB and one 2GB SO-DIMM. When I tried swapping, there were further problems which could only be resolved by resetting the BIOS to default. After that, everything went mostly smoothly. 

 

This is my current BIOS configuration:

Attached File  IMG_3498.JPG   106.05KB   105 downloads

 

With the boot flags -x -v -f I was able to finally get the installation completed:

Attached File  IMG_3516.JPG   50.85KB   74 downloads

 

Could create an account and log in:

Attached File  IMG_3543.JPG   100.3KB   42 downloads

 

and these are the screenshots showing the OS X:

Attached File  IMG_3548.JPG   125.95KB   57 downloads

 

and as what the Elitebook is known to the Apple world, as a MacBook Pro 6.2:

Attached File  IMG_3549.JPG   116.54KB   73 downloads

 

I'll post more details in a follow-up.

 

Many special thanks go to all who have helped, but in particular to iFire, artur-pt, PJALM, joe75, Download-Fritz and Joseph. Apologies if I forgot any of the many from this forum who have actively helped me to get this far.

 

Attached is the Manual for the HP8440p with hardware specifications, which is useful to know what kind of kexts to install. Attached File  HP8440p Manual.pdf   2.56MB   276 downloads



#2
w1r3d

w1r3d

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

For anyone interested in the same installation, here is a handy guide to the machine's specifications. I've used the vanilla guide to get me started, and also needed to check the guide for the first generation Intel HD Graphics, supplemented by the download link to the Graphics kexts. The display used is eDP, according to the specifications listed in the Manual (see attachment at previous post), so there is going to be support for Core Image (CI), but not Quartz Extreme (QE).

 

Update 12 April 2014:

Finally I was able to install the right Graphics kext and could boot without the -x flag. 

 

Update 13 April 2014:

However, currently there is a problem with the Screen Saver. When coming back from the screensaver, I get a kernel panic. :-(



#3
w1r3d

w1r3d

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Update May 14, 2014:

 

Swapped the Intel Wifi card out and replaced it with a Broadcom 43224 card bought via HP Spare Parts store. Needed two kexts (toledaAPRT.kext and patched IO80211Family.kext) to get it running and also needed to turn off LAN/WLAN Switching in the BIOS. If you don't do that and plug in an Ethernet cable, then the BIOS will turn off the WiFi card, and when you unplug the Ethernet cable, Mac OS X is not capable of turning it back on.

 

Summary of what works:

See http://wiki.osx86pro...k_8440p_i5-540M



#4
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 459 posts
  • Gender:Male

You should only install toledaAPRT, and use vanilla IO80211Family.kext



#5
FerrariPhil

FerrariPhil

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi Congrats on getting it working on the 8440p.  I think my system is fairly similar and was hoping you could point me to the fixes for the following that do not seem to work.  

 

Sleep - The system immediately hangs, no idea why

Trackpad and Pointer do not work.  I have loaded the latest ApplePCPIPPS2Nub and ApplePS2Controller kexts I could find online but they made no difference

Audio.  I have loaded the latest VoodooHDA I could find online and changed the IOPCIPrimaryMatch to 0x3b568086, but still no success

WiFi.  I am suspecting the standard Intel WiFi is not going to work since you swapped the module out, but interested to hear

 

If possible could you send me all the kexts you have used in Extensions in case the version is important.

 

Cheers



#6
kurt

kurt

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts

Hi w1r3d, 

 

I have the exact same setup as you but I can't for the life of me get the laptop to boot without the safe mode flag. I am trying to install 10.9.5. Have you had luck with 10.9.5 on the Elitebook 8440p?

 

Thanks,







Also tagged with one or more of these keywords: HP, Elitebook, 8440p, OS X, Mavericks, 10.9.2, Installation, Success, Chameleon


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy