Jump to content

USB 3.0 Not working correctly with 10.9 and GA-B75M-D3H

UDB3.0 Mavericks 10.9.2 10.9 GA-B75M-D3H

  • Please log in to reply
No replies to this topic

#1
spang1974

spang1974

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

My USB 3.0 was working properly (since I first built it) with Mountain Lion 10.8.2 (without GenericUSBXHCI) and was reading and writing at speeds greater than I got with USB 2.0, it was not an issue to backup 300-400GB to my external USB 3.0 drive. Unfortunately once I updated to Mavericks 10.9.0 the write speeds dropped to under 20Mb/s. I ended up not noticing this until I updated to 10.9.2 and decided to do a clean complete backup with Time Machine. The drive is still recognised as USB3.0 and says it's capable of "Up to 5 Gb/sec"  instead of the  "Up to 480 Mb/sec" , I realise speeds are never this high. The USB 3.0 drive actually gets better speeds from my USB2.0 ports, yet still not as high as they were with Mountain Lion. I have tried using the different versions of GenericUSBXHCI.kext and without it. I soon as I had a chance I reinstalled 10.8.2 on a test system, and the drive immediately started writing at speeds greater than 80Mb/s. I then upgraded to 10.9.0 on my test system and the drive went back to writing at under 20Mb/s. 

 

So anybody have any advice?

 

I was wondering if anyone else had noticed if their USB 3.0 was actually working properly?

 

Is it just this motherboard?

 

Am I using the wrong kext?

 

Did I need to change any bios settings once I updated to 10.9?

 

Spang1974

Attached Files







Also tagged with one or more of these keywords: UDB3.0, Mavericks, 10.9.2, 10.9, GA-B75M-D3H


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy