Jump to content

Aiuto! AppleLPC blocca lo sleep...


  • Please log in to reply
36 replies to this topic

#1
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Ciao a tutti, vi spiego il problema...

 

La macchina è quella in calce, il Bootloader: Chameleon r2377

kext: fakesmc, applehda, GenericUSBXHCI.kext x USB 3.0, AppleRTC patchato, AppleIntelCPUPowerManagement patchato,

AppleLPC ver. 1.5.1 (test da 10.6.8)

 

Dunque se avvio con DSDT=NULL, il sistema è funzionante al 99% tranne l'audio ovviamente e l'assenza dal caricamento del kext: AppleLPC. Lo sleep si attiva dopo 20 secondi (si comporta così solo in mavericks, no problem) dalla pressione del tasto di accensione o da: Menù Mela > Stop. Wake up veloce senza riavvio. problema con lo spegnimento, vista la non presenza del DSDT.

 

Con DSDT patchato (attaccato al post) con l'essenziale, senza errori, inject per AppleLPC (3a18), quindi caricato,  quando cerco di andare in sleep, dopo i canonici 20 secondi, le usb si addormentano ma il pc rimane acceso, per metterlo in sleep totale devo premere il pulsante di alimentazione del pc. Solo talune volte, riparando i permessi e ricostruendo la cache, lo sleep funziona in maniera regolare.

 

Sembrerebbe quindi un problema legato all'AppleLPC. Non capisco se mi manca un fix nel DSDT...? se esiste una patch per questo kext...?

 

Ma qualcuno sa se è essenziale caricarlo all'avvio, il pc sembra comportarsi regolarmente anche senza, speedstep compreso...

 

Grazie in anticipo per l'aiuto...

Attached Files



#2
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy

Allora per la tua scheda non serve appleIntelCPUPowerManagement patchato.

Stessa cosa per AppleLPC lascia quello di Maverick

Prova questo dsdt

 

Fabio

Attached Files



#3
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Ciao Fabio e innanzitutto grazie per avermi risposto.

Ora reinstallo i due kext orig. di Mav e provo il DSDT che mi hai postato e ti dico...

 

Luca



#4
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Ho reinstallato i due kext orig., e ho riavviato con il dsdt che mi hai postato, Ora AppleLPC non si carica all'avvio, e non mi va in sleep.

Prima senza AppleLPC, mi andava in sleep...

Ma quanto è indispensabile avere LPC caricato in OS???



#5
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy

Da Terminale dai questo comando :

 

kextstat -k | grep LPC

 

 

Fabio



#6
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Si è il comando che uso normalmente, se no uso kextwizard...

comunque il risultato:

Mac-Pro-di-Luca:~ Luca$ kextstat -k | grep LPC

   43    0 0xffffff7f81933000 0x17000    0x17000    org.hwsensors.driver.LPCSensors (1123) <17 11 10 7 5 4 3>

  103    0 0xffffff7f8221a000 0x3000     0x3000     com.apple.driver.AppleLPC (1.7.0) <68 11 5 4 3>


Ora come vedi è caricato, insieme al plugin di fakesmc, perché ho usato il dsdt che avevo postato nel mio primo post.



#7
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
A me sembra che applelpc venga caricato

Fabio

#8
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Si Fabio, come ti ho scritto prima, ho usato il primo dsdt da me postato...



#9
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
Mi sembra strano che non carichi lpc del dsdt che ti ho postato visto che è injectato, deve caricarlo

Fabio

#10
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Mi sembra strano che non carichi lpc del dsdt che ti ho postato visto che è injectato, deve caricarlo

Fabio

Si, ma ho fatto delle prove da un mese a questa parte, oltre a perdere del sonno, ho scoperto che per iniectarlo in maniera corretta deve essere reso compatibile, cioè:

 

tuo inject:

 

Name (_ADR, 0x001F0000)
                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x02)
                        {
                            "device-id", 
                            Buffer (0x04)
                            {
                                0x18, 0x3A, 0x00, 0x00
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
 
inject in compatible mode (mio DSDT):
 
Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x04)
                        {
                            "device-id", 
                            Buffer (0x04)
                            {
                                0x18, 0x3A, 0x00, 0x00
                            }, 
                            "compatible", 
                            Buffer (0x0D)
                            {
                                "pci8086,3a18"
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)


#11
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Dunque, inserendo il _DSM con il device-id sotto SATA e SAT1 e sotto GBE, ora lo sleep funziona correttamente!

 

Ho ancora una piccola attivazione di un paio di secondi del dvd-rom allo sleep (senza DSDT non avevo), se inserissi il _PRW nel SATA e SAT1?



#12
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
In maniera corretta e completo è così :

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x08)
{
"device-id",
Buffer (0x04)
{
0x18, 0x3A, 0x00, 0x00
},
"compatible",
Buffer (0x0D)
{
"pci8086,3a18"
},
"IOName",
Buffer (0x0D)
{
"pci8086,3a18"
},
"name",
Buffer (0x0D)
{
"pci8086,3a18"
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}


Ma in entrambi i due modi lpc viene caricato, penso sia altro che rompe il sonno e di solito sono le usb

Fabio

#13
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia
Tramite dsdt editor ho inserito x le usb la patch ICH9 USB Sleep (fake ich10)...
Ho provato ad eliminare il _PRW ma non ho più il wake da tastiera o mouse. Avevo letto qui da qualche parte che si poteva editare il _PSW, ma non ricordo dove, e non so se è necessario...

#14
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
Non serve inserire la patch ICH9 le usb della tua scheda sono già ICH10

Fabio

#15
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia
Fabio, secondo la tua esperienza, partendo da un'estrazione del DSDT pulito, quali patch mi consiglieresti per la mia MB?

#16
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
Il dsdt che ti ho passato avevo gia' aggiunto le patch neccessarie, potresti solo modificare il Device LPC e provare

Fabio

#17
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia

Ciao Fabio, update...

Sono riuscito, driblando vari impegni importanti, ad aggiungere l'LPC al DSDT che hai compilato e ad aggiornare alla 10.9.2. Dunque lo sleep-autosleep funziona regolarmente dopo 1min. ca dallo spegnimento del monitor. Il risveglio è un po difficoltoso... cioè, 8 volte su 10, il puntatore del mouse diventa la solita ruota arcobaleno e mi tocca riavviare brutalmente dal tasto.

Sulla 10.9.2, ho dovuto cambiare UserKernelcache=Yes in NO e con darkwake=no l'autosleep funziona correttamente.

Ho letto in altri forum che alcuni utenti hanno sperimentato con darkwake=10, 8, 4.

Hai consigli specialmente per il wake?

Se passassi a Clover, pensi che risolverei qualcosa, al contrario di chameleon?

 

Grazie. Luca.



#18
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
Se guardi la mai firma io ho un Asus III Formula sono abbastanza simili come schede utilizzo Chameleon e ho tutto funzionante compreso lo sleep
Puoi provare Clover e vedere come si comporta.

Fabio

#19
lucke

lucke

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Italia
Ok, sbircerò nella tua guida...
Ho fatto delle ulteriori prove... Con usekernelcache=yes e darlwake=no
Lo sleep è perfetto ed anche il risveglio... Però problema stranissimo all'audio, distorto, fuori sincrono.
Al contrario con usekernelcache=no, non funge lo sleep, però l'audio è perfetto...
Non ci capisco più una mazza....
Inizio ad avere dei dubbi sui settaggi del bios, anche se con le release precedenti, non ho mai avuto problemi...

Luca.

#20
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,923 posts
  • Gender:Male
  • Location:Italy
L'audio se non mi sbaglio e' uguale al mio ALC899
Guarda nella mia guida e prova l'audio devi fare la modifica al dsdt cambiando Layout

Fabio





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy