Jump to content

Help me install Realtek ALC898 codec (10.9.2)!

audio sound realtek alc898

Best Answer iFIRE , 17 March 2014 - 06:49 PM

disable onboard , if you have this  2x GeForce GTX 660 ti 3gb SLI , you not need the omboard graphics, and yes, delete all INTEL Gaphics kexts and ATI + AMD Graphics kexts, repairpermissions with Kext Wizard app/reboot,

 

and I not sure if this can boot in sli mode this two cards in MAC  OS X , try disable the sli, to make a test if you can boot

Go to the full post


  • Please log in to reply
8 replies to this topic

#1
JMWRainwater

JMWRainwater

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Columbia, SC

For the life of me, I cannot get my rig to properly produce sound. Everything else works perfectly and smoothly, except for this very important aspect.

Not sure if this matters, but I do have to boot in safe mode every time. 

I have done every guide I can find for installing the ALC898 kext properly, but it just does not seem to work. Does me having to boot in safe mode mess me up? Am I just missing something?

 

(I also cannot get my WiFi card to work, but I understand that's a totally different process and board section, but if anyone has notes on that, I'd appreciate it)

 

 

My rig is as follows:

 

Obsidian 660T Case
ASRock Z77 Xtreme 4
i7 3770k 
32gb RAM (4x 8gb)
2TB HDD, 256gb SSD, 128gb SSD (with Windows 8/1TB, OSX/256SSD)
2x GeForce GTX 660 ti 3gb SLI 

Dedicated Sound card onboard
Blu Ray burner/Reader 12x
Wifi/Bluetooth Card

Extremities:

Monitor: 27" Samsung HDMI 1920X1080 monitor 2hz refresh rate

Keyboard: SteelSeries Merc USB Wired 

Mouse: Razer DeathAdder



#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,033 posts
  • Gender:Male

hi

 

try this: http://www.insanelym...or-alc898-1092/



#3
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,923 posts
  • Gender:Male
  • Location:Italy

Hello

 

Look here : //github.com/toleda/audio_ALC898

 

Fabio



#4
JMWRainwater

JMWRainwater

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Columbia, SC

Hello

 

Look here : //github.com/toleda/audio_ALC898

 

Fabio

 

This is actually the guide I followed that worked the "most" I should say. I still cannot boot without being in safe mode which is what I think is hurting my audio extension/kext. Attached is my very blurry boot -v screen. 

Most notable lines:

...

Kext com.apple.driver.AppleIntelSNBGraphicsFB start failed (0xdc00400a)

Kext com.apple.driver.AppleIntelSNBGraphicsFB failed to load (0xdc008017)

...

ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out

Warning IOPlatformPluginUtil : getSPUIDInfo: this is an unknown CPU model 0x3a

 -- power management may be incomplete or unsupported

Sound assertion in AppleHDACodecGeneric at line 352

Sound assertion in AppleHDACodecGeneric at line 352

Sound assertion in AppleHDACodecGeneric at line 352

Sound assertion in AppleHDACodecGeneric at line 352

Sound assertion in AppleHDACodecGeneric at line 352

Sound assertion in AppleHDACodecGeneric at line 352

Sound assertion in AppleHDAEngine at line 581

...

 

This makes me think that the sound is actually working fine, but its' another problem that is causing me to boot into safe mode, and is triggering an outdated kext for audio.

 

b1QYFv2.jpg



#5
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

this is a problem with  the kexts for IntelHDGraphics, if you not use integrate graphics delete all AppleIntelHD* and this two kexts too, disable in the bios intelGraphics,  repairpermissions with kext wizard reboot



#6
JMWRainwater

JMWRainwater

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Columbia, SC

this is a problem with  the kexts for IntelHDGraphics, if you not use integrate graphics delete all AppleIntelHD* and this two kexts too, disable in the bios intelGraphics,  repairpermissions with kext wizard reboot

 

Thank you for your reply! A few questions, as I am fairly new to all of this:

 

1. How do I know if I am using integrated graphics?

2. By disabling in the BIOS, should I select "onboard" rather than "PCI express?" I can upload a picture of my BIOS if that helps.

3. What if I am using integrated graphics? Should I still delete all the kexts and Kext Wizard, or is there another route?



#7
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

Best Answer

disable onboard , if you have this  2x GeForce GTX 660 ti 3gb SLI , you not need the omboard graphics, and yes, delete all INTEL Gaphics kexts and ATI + AMD Graphics kexts, repairpermissions with Kext Wizard app/reboot,

 

and I not sure if this can boot in sli mode this two cards in MAC  OS X , try disable the sli, to make a test if you can boot



#8
JMWRainwater

JMWRainwater

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Columbia, SC

disable onboard , if you have this  2x GeForce GTX 660 ti 3gb SLI , you not need the omboard graphics, and yes, delete all INTEL Gaphics kexts and ATI + AMD Graphics kexts, repairpermissions with Kext Wizard app/reboot,

 

and I not sure if this can boot in sli mode this two cards in MAC  OS X , try disable the sli, to make a test if you can boot

 

IT WORKED!

Oh my word. Not only did it boot with no boot commands (-x, -f, etc.) but I have sound! You are a king.

Now if I can only get my wireless card to work, I will be unstoppable.

 

Thank you SO much! :D



#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

np, Congratulations!!! :)

 

Happy Hack!!! :D







Also tagged with one or more of these keywords: audio, sound, realtek, alc898


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy