Jump to content

Dell Inspiron 15R - 5537 - woes, issues, what I've done


Best Answer conedmiro, 31 March 2014 - 11:04 PM

AND WE'RE GOLDEN! 

 

Mounted the EFI Partition from within Mac OS X, used Clover Config and edited the config.plist with TextWrangler - got it to boot without caches which allowed me to use my keyboard/track pad and then edited the config so the actual Clover bootloader would load w/o any errors. 

 

I added the SSDTs and the DSDT and I have Brightness fully working, iMessages working, iCloud fully intact, AND WiFi working!

 

FRESH INSTALL LOOKS AMAZING!

 

thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you 

Go to the full post


  • Please log in to reply
77 replies to this topic

#61
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

http://www.osx86.net...gistryexplorer/



#62
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

this is very strange, so I reformatted that partition and installed fresh - 4 times

 

every time I install, the laptop's touchpad/keyboard don't work OotB, but the Atheros 9285 does - I have to boot without injected kexts and then my keyboard/trackpad combo works.... AND 

 

Clover won't boot anymore after I install it on that partition.



#63
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

Is your touchpad Synaptics?



#64
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

yeah



#65
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

Remove two PS2 kexts in /EFI/Clover/kexts/10.9/ and use https://bitbucket.or...ller/downloads/

Don't install FakeSMC.kext in my tool, use /EFI/Clover/kexts/10.9/FakeSMC.kext in CLOVER USB instead.

 

Can you still boot to OS X after install by USB? Compress your EFI folder in EFI partition before restarting.



#66
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

I have no clue why, but when I install clover using your 7000 guide, using the exact setup you describe, it installs clover to the ESP partition

 

can I just copy it over to my MacOSX volume?



#67
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

I have no clue why, but when I install clover using your 7000 guide, using the exact setup you describe, it installs clover to the ESP partition

 

can I just copy it over to my MacOSX volume?

Clover UEFI needs to be installed in ESP, NOT MacOSX partition.

 

Each steps have to be carefully followd, or you won't boot anymore.



#68
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

It is installed there, as per the instructions - It just won't boot anymore when I add the boot file in my BIOS - It only shows the partitions of my Mac volume and my Windows volume

 

I don't know how it was so easy to get it working the last time



#69
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Best Answer

AND WE'RE GOLDEN! 

 

Mounted the EFI Partition from within Mac OS X, used Clover Config and edited the config.plist with TextWrangler - got it to boot without caches which allowed me to use my keyboard/track pad and then edited the config so the actual Clover bootloader would load w/o any errors. 

 

I added the SSDTs and the DSDT and I have Brightness fully working, iMessages working, iCloud fully intact, AND WiFi working!

 

FRESH INSTALL LOOKS AMAZING!

 

thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you thank you 



#70
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

OK one last issue - audio over HDMI - it's using the Intel HD5xxx kext apparently - but do I need to patch the SSDT again for this to work?



#71
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

OK one last issue - audio over HDMI - it's using the Intel HD5xxx kext apparently - but do I need to patch the SSDT again for this to work?

 

DSDT has everything ready for HDMI audio, what you need is kexts patching.

 

My 7000 can't even connect to HDMI TV, it freezes at plugging in.



#72
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Ah damn, yeah I was reading into that HERE, but was at a loss - I saw the series 7, Intel HD4000 section, but al it supplied me with was a custom SSDT that I assume I patched wrong, but I guess I needed to patch AppleHDA as well

 

oh well, another thing for another day. I'd do Audio out via my headphone jack, but I still get some feedback [when headphones/line-out is plugged in only] so I'll fix that when I'm feeling up to it



#73
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

Do a clean install:

 

Dell Inspiron 3x37 5x37 7x37 Mavericks Clover Install



#74
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Perfect, thanks pokengyuen, I have been working on schoolwork and not checking this thread - thanks for the help!



#75
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

I take it you patched everything [ssdt/dsdt] with MaciASL & installed the ACPIBacklight Kext?

 

-and- did iMessage, iCloud, and the AppStore work out of the box, or did you have to do the workaround fixes?



#76
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male

I take it you patched everything [ssdt/dsdt] with MaciASL & installed the ACPIBacklight Kext?

 

-and- did iMessage, iCloud, and the AppStore work out of the box, or did you have to do the workaround fixes?

+1.

 

You have to have patched DSDT.aml, SSDT.aml (from SSDT Generator), SSDT-1.aml (patched from SSDT-7.dsl) + ACPIBacklight to get brightness.



#77
conedmiro

conedmiro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

hey, pokenguyen, any way you can help THIS gentleman out -> none of his input devices [keyboard / track pad] are working on boot and I can't for the life of me help him find a workaround



#78
bachdv

bachdv

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hey Pokenguye, could you help me about patch the audio code. iam so pleasure to take you help. So if that's ok just give ur fone number then i call you back instanly.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy