Jump to content

10.8.5 On haswell and ...

haswell 10.8.5 1150 intel g3220 asus h81m-c

  • Please log in to reply
18 replies to this topic

#1
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

Hi, My Hardware spec is :

Main: Asus H81m-c

Cpu: Intel g3220

VGA: ATI 5450

I know that I can’t install 10.9 with this Cpu, so I tried to install 10.8.5 and built 2 usb stick with 2 ways, manual way and Myhack way. After a few second of booting both of them goes to black screen. I also Patched the vanilla kenel, didn’t change. I also used a lot of flags!

I tested on same pc with different cpu(core i3) and it was ok, and didn’t stuck at black screen. So it is because of my Cpu. 

is there anyway to fix this?

thanks 



#2
Onixs

Onixs

    Since 2007

  • Members
  • PipPipPipPipPipPipPip
  • 736 posts
  • Gender:Male
It s caused by your GPU. Just telling you, no idea about ATI

#3
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

It s caused by your GPU. Just telling you, no idea about ATI

tnx 

you mean gpu of my cpu?!

in bios setting I select PCIE for my graphic card.



#4
iattilagy

iattilagy

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

For me it works on G3220, but I have a different motherboard Asus B85M-G. But I can't get qe/ci working on it (with igp). Try booting with -x or GraphicsEnabler=No.



#5
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

For me it works on G3220, but I have a different motherboard Asus B85M-G. But I can't get qe/ci working on it (with igp). Try booting with -x or GraphicsEnabler=No.

tnx

I tries those flags, but did not work! :(



#6
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,775 posts
  • Gender:Male
  • Location:Bcn-Spain

first, why you try install 10.8.5 and not 10.9.0 ? other problem is your Integrate Graphics HD, disable it in the bios or not boot the system, delete all Graphics Kexts AppleIntelHD from the USBInstaller, and try this boot flag:  how you Patched the kernel ? :rolleyes:

 

-f -v -x GraphicsEnabler=No dart=0 npci=0x2000



#7
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

first, why you try install 10.8.5 and not 10.9.0 ? other problem is your Integrate Graphics HD, disable it in the bios or not boot the system, delete all Graphics Kexts AppleIntelHD from the USBInstaller, and try this boot flag:  how you Patched the kernel ? :rolleyes:

 

-f -v -x GraphicsEnabler=No dart=0 npci=0x2000

Hi, tnx

* because 10.9 doesn't support intel pentium series like g3220, for patching I use a topic in 10.9 section(early reboot maver.... with perl patch and another software named lapic kernel, I gues).

I use your way, but same thing happend .

every body tells about graphic, but I said that I use core i3 cpu on same system with this ati 5450 card, and there was no problem.

I don't know what to do :( 

tnx agian  



#8
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,775 posts
  • Gender:Male
  • Location:Bcn-Spain

try move or delete all the graphics kexts from the USBInstaller and try again, try with flag  cpus=1

 

Attached File  Graphics_Kexts.png   565.87KB   8 downloads



#9
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

try move or delete all the graphics kexts from the USBInstaller and try again, try with flag  cpus=1
 
attachicon.gifGraphics_Kexts.png

tnx again, I've done it, but didn't work

#10
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

I'm totally frustrated! 

any idea?



#11
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,775 posts
  • Gender:Male
  • Location:Bcn-Spain

post a photo where this stop, you  are sure that have changed the kernel ?



#12
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

post a photo where this stop, you  are sure that have changed the kernel ?

I used this topic :

http://www.insanelym...63cl-i7-4700mq/

I see now its perl code is for 10.8.5 but my installer is 10.8 !

which way should I patch the kernel?



#13
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,775 posts
  • Gender:Male
  • Location:Bcn-Spain

:P I see now its perl code is for 10.8.5 

 

but my installer is 10.8 ! :( 

 

what do think that is wrong ? :rolleyes: 



#14
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

ok,  :D

I've searched. I can only find a patcher and sth like this:

http://www.osx86.net...s-1-fix-for-ml/

I'm going to use above kernel!

is it ok? or should I do sth else ?

tnx for your time 



#15
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,775 posts
  • Gender:Male
  • Location:Bcn-Spain

is this your case? :lol:    :no:  MOUNTAIN LION 10.8(12A269) Darwin 12.0.0 HP USERS WITH AN INTEL i3, i5, or i7 sandybridge processors. CPUS=1 FIX FOR HP LAPTOPS eagerness.png  mach_kernel lapic cpus=1 fix for ML - OSx86.net Hackintosh


Make a USBInstaller with app Mountain Lion 10.8.5  :yes:    or forget ML :(



#16
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

is this your case? :lol:    :no:  MOUNTAIN LION 10.8(12A269) Darwin 12.0.0 HP USERS WITH AN INTEL i3, i5, or i7 sandybridge processors. CPUS=1 FIX FOR HP LAPTOPS eagerness.png  mach_kernel lapic cpus=1 fix for ML - OSx86.net Hackintos


is this your case? :lol:    :no:  MOUNTAIN LION 10.8(12A269) Darwin 12.0.0 HP USERS WITH AN INTEL i3, i5, or i7 sandybridge processors. CPUS=1 FIX FOR HP LAPTOPS eagerness.png  mach_kernel lapic cpus=1 fix for ML - OSx86.net Hackintosh


Make a USBInstaller with app Mountain Lion 10.8.5  :yes:    or forget ML :(

tnx :)



#17
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

ok

I installed 10.8.5 and every thing works fine. except one thing!

bootloader

I installed it. 

at first I saw a blue screen of windows which says can not boot to windows....after deleting some files from other hard drive related to boot stuff, it says operation system missing.

I reinstall chameleon..but nothing changes



#18
JavadEd

JavadEd

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

problem fixed!

I don't know why haswell can't boot from gpt hard!

I make mbr hard drive and instal boot loader on it....

it worked

tnx all of you  :)



#19
deus-ex-machina

deus-ex-machina

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Latina

I have this hardware:

CPU  : Intel Pentium G3220;

Scheda madre  : GIGABYTE B85M-D3H

Scheda grafica  : Intel ® HD Graphics (Nella Integrata cpu credo)

RAM  : 12 GB (1 banco da 8 GB + 1 banco da 4);

HD  : win 8.1 ( 2x250 SATA2 ) Ho dovuto HD da 250 con dovuta differendi Installazioni di 2in 8.1 64; 500 GB ( Qui VORREI mettere osx );  Dati ( 1 TB );

 

 

but was not able to install osx. you can help me. This is my post

 

http://www.insanelym...-4#entry2036332







Also tagged with one or more of these keywords: haswell, 10.8.5, 1150, intel g3220, asus h81m-c


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy