Jump to content

[GUIDA] Integrare Ozmosis nel bios UEFI


  • Please log in to reply
135 replies to this topic

#121
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic

@Ultralaser, non e' possibile integrare direttamente nel bios la scheda di rete in quanto non c'e' spazio a disposizione, per integrare la scheda di rete oltre al kext della stessa occorre il flle IONetworkingFamily e questo e' abbastanza corposo per cui passandolo all utility kext2ffs ed usando entrambi i kext compressi, non ci entrano nel bios.

Io pero' yosemite l'ho installato senza essere collegato ad internet, come fai l'installazione? io mi sono fatto una chiavetta bootable con cui installo yosemite ma l'ho fatta avendo a disposizione l'app di yosemite scaricata dall apple store, e ovviamente un osx, non importa se fisico o virtuale, comunque, se usi il mio bios cosi' come e' deve funzionare, e' quello che attualmente uso.

 

@Magnifico, se leggi a pagina 91 del thread in inglese c'e' il link al post su che e' questo http://www.insanelym...osis/?p=2061647 li trovi i link per scvaricare il tutto.

Non ho purtroppo molto tempo ma vedo nei prossimi giorni di prepapare una guida per ozmosis nuovo, anche se non varia moltissimo, insieme a questa inseriro' anche la guida per un tool che si chiama ozmotools che serve a fare il tutto con un comando e su un solo sistema, chiaramente l'editing del DSDT deve essere sempre fatto su OSX.



#122
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

@Aigors : se utilizzo la partizione di recovery allora mi richiede la connessione ad Internet. Alla fine ho tirato fuori la chiavetta "vanilla" che mi ero preparato ed effettivamente sono riuscito ad installarlo nuovamente (poi sono scappato al lavoro); non vedo l'ora di tornare a casa e smanettarci sopra.... il tempo è sempre trooooopo poco :(

 

 

PS : dalla tua guida :

 

"Injector Kext serve per iniettare dei parametri in alcune kext, personalmente non ce l'ho caricato nel mio bios e mi funziona tutto benissimo."

 

non è che per caso manca nel tuo bios e forse per questo motivo le modifiche al defaults.plist non vengono viste? (chiedo ma dubito)



#123
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic
Non credo

#124
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
@aigors,

Sai come si trasforma una stringa in integer per ozsmosis?

<key>IntelGFX</key><string>0x0d228086</string>


#125
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic

@aigors,

Sai come si trasforma una stringa in integer per ozsmosis?
 

<key>IntelGFX</key><string>0x0d228086</string>

Scusa per la tarda risposta, io ho usato plistedit convertendo quel valore in decimale con la calcolatrice, e mettendolo di fianco la chiave in plistedit



#126
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
Figurati, anzi grazie a te e alla tua pazienza.
Per me ozmosis é assolutamente nuovo e fatico a trovare documentazione e così ho fatto di te il mio punto di riferimento :)

Ho provato a fare un bios mod da nuovo scaricando l'ultimo cap ma non riesco a flasharlo ne con l'utility che hai postato ne direttamente dalla mobo.

Cosa sbaglio?
Posso chiederti anche gentilmente la copia della tua efi così da poter confrontare i miei casini ed imparare da tali?

La cosa che non capisco proprio é che per alcune modifiche come il seriale non viene considerato e mi da in default quello che trova in ozmosis bios

#127
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic

La mia te la vorrei dare, ma ho fatto un DSDT a cacchio di cane per cui non mi parte piu' il sistema  :wallbash:

Dunque, per avere un bios che sia possibile flashare con l'utility da windows, devi scaricarti il software Uefitool

https://github.com/L...ases/tag/0.19.2

Installatolo sotto windows, lancialo, dal menu' file carica il bios della tua mobo, selezionalo cliccandoci sopra, poi dal menu' action, sposta il cursore del mouse su capsule file, vedrai due opzioni, extract as is e extract body, scegli extract body, salvati questo file come bios-nocap.rom o quello che vuoi, su questo fai le tue modifiche, poi potrai flasharlo con l'utility sotto windows.

Piccola spiegazione, asus usa un formato detto capsule che aggiunge 2048 byte di header in testa al bios vero e proprio, questo e' detto capsule header e serve come impronta digitale all utility bios per il flash, per cui ogni modifica che fai al bios non rispecchia i dati contenuti nell header, ecco perche' l'utility nel bios non te lo riconosce, ma non viene considerato dall afuwin64 per cui e' possibile flasharlo, a, non so se te l'ho detto, ma il prompt del dos da cui poi lancerai afuwin64 lo devi aprire con i privilegi di administrator.

Spero di non aver scritto fregnacce :D data l'ora tarda e' possibile, se non capisci qualcosa, cosa possibile visto che non sono un "docente", chiedi pure :D 



#128
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

La mia te la vorrei dare, ma ho fatto un DSDT a cacchio di cane per cui non mi parte piu' il sistema  :wallbash:

 

Da windows (con macdrive installato) hai provato a cancellarlo?



#129
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic
No,vedo di provarci

#130
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

E' uscito il bios nuovo per la Asus Z97I-Plus :

 

Z97I-PLUS BIOS 2302
Improve system stability.



#131
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic

doh! devo scaricarlo 



#132
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
@Aigors come si chiama il tuo programmatore di eprom? :(

#133
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic
No!che è successo?
Sofi sp8

#134
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

No!che è successo?
Sofi sp8

 

Boh qualcosa è andato storto : al boot non vede ne le porte usb ne la ram inserita.

Mi va bene che faccio una sostituzione con Amazon ma vorrei pararmi il {censored} per il futuro, prendermi un programmatore e vivere felice.

 

Cosa dovrei sapere per programmare il bios della nostra mobo? hai mica fatto una guida ? :)



#135
Aigors

Aigors

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:Italy
  • Interests:RC Model, pc, networking, mechanic electronic

Azz, mi spiace, puoi pero' provare a fare il bios flashback.

prendi una chiavetta usb, meglio se di piccolo taglio, formattala fat32, copiaci sopra il bios e rinominalo in Z97IPLUS.CAP, collega l'alimentatore alla piastra, non accenderla, metti la chiavetta usb che hai preparato nella porta usb2 in basso, per capirci le porte usb2 sono quelle che sono nere all interno, se guardi la "culatta" che ti danno insieme alla mobo vedrai che tale porta e' marchiata in verde e c'e' scritto bios flashback, una volta inserita la chiavetta, tieni premuto il reset per 5 secondi, se sei fortunato parte la procedura di flashback se la chiavetta ha un led di stato vedrai l'operazione tramite il lampeggio del led, dovrebbe durare circa un paio di minuti.

In bocca al lupo.

La procedura di programmazione del bios non la faccio perche' e' intuitiva e varia da programmatore a programmatore.



#136
UltraLaser

UltraLaser

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

Azz, mi spiace, puoi pero' provare a fare il bios flashback.

prendi una chiavetta usb, meglio se di piccolo taglio, formattala fat32, copiaci sopra il bios e rinominalo in Z97IPLUS.CAP, collega l'alimentatore alla piastra, non accenderla, metti la chiavetta usb che hai preparato nella porta usb2 in basso, per capirci le porte usb2 sono quelle che sono nere all interno, se guardi la "culatta" che ti danno insieme alla mobo vedrai che tale porta e' marchiata in verde e c'e' scritto bios flashback, una volta inserita la chiavetta, tieni premuto il reset per 5 secondi, se sei fortunato parte la procedura di flashback se la chiavetta ha un led di stato vedrai l'operazione tramite il lampeggio del led, dovrebbe durare circa un paio di minuti.

In bocca al lupo.

La procedura di programmazione del bios non la faccio perche' e' intuitiva e varia da programmatore a programmatore.

 

 

AZZ ha funzionato, ci avevo provato 20 volte ma non lo avevo rinominato giusto come hai detto tu!!!!

 

Senti,

 

però tu hai fatto di sicuro qualche modifica al tuo bios, perchè ne ho fatto uno pulito proprio adesso mettendo dentro solo questi files :

 

|188|OzmosisDefaults|99F2839C-57C3-411E-ABC3-ADE5267D960D|00DA7A19|000128|FRFM|
|189|HfsPlus |4CF484CD-135F-4FDC-BAFB-1AA104B48D36|00DA7B41|006174|DRVR|
|190|PartitionDxe |1FA1F39E-FEFF-4AAE-BD7B-38A070A3B609|00DADCB5|002E68|DRVR|
|191|SmcEmulatorKext|DADE1001-1B31-4FE4-8557-26FCEFC78275|00DCF5D8|021710|FRFM|
|192|Ozmosis |AAE65279-0761-41D1-BA13-4A3C1383603F|00DF0CE8|01CDC4|DRVR|
|193|DisablerKext |DADE1002-1B31-4FE4-8557-26FCEFC78275|00E0DAAC|002B6B|FRFM|

 

ma osx non parte : rimane schermata nera con la barra di avanzamento a metà.

Allora mi sono fatto il mio Defaults.plist e messo nella cartella Kext2Ffs\Ffs\Efi\Compress e convertito. Il file poi lo ho rinominato in OzmosisDefaults e sostituito con quello di defaults.

 

Ottengo sempre la schermata nera con la mela bianca e la barra di avanzamento che si blocca a metà.

 

La cosa strana è che io gli ho messo il "-v" nel plist eppure non se lo fila manco per sogno.

 

E' per questo che ti chiedo se hai fatto qualche cosa di strano nel tuo bios perchè a parità di mobo e file la mia non va :(

 

 

Quello che ho fatto è giusto no? creare il Defaults.plist e convertire in OzmosisDefaultsCompress.ffs ed inserirlo come al solito?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy