Jump to content

Supporto QE/CI/OGL X1600/X1800/X1900 [GUIDA]


  • Please log in to reply
31 replies to this topic

#21
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
è vero hai ragione...scusa era uno sfogo ... ho provato manualmente dalla 10.4.7 alla 10.4.4 , ma non ottengo mai niente: o si ferma alla schermata nera con le scritte nere (non entra in graphic mode) o entra in graphic mode ma con un putiferio di artefatti !!!

grazie cmq...lo so che perseverando si ottengono i risultati, ma dopo un po' diventa una frustrazione!!!

ok adesso riprovo...

grazie ancora!!! :D

p.s. ah, io installo sempre l'osx con vmware...poi dopo il riavvio chiudo il prog e riavvio in modo nativo...è giusta questa procedura?

(la mia mobo è una "Sapphire Pure crossfire advantage PC-A9rd480Adv" e la mia scheda grafica e una "Sapphire Radeon x1800 xt 512 mb" e in system Profiler viene riconosciuta con una scheda da 256 mb)

#22
optimistic

optimistic

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
mah,molto strano. ho seguito tutta la procedura sulla 10.4.6, ho tutto supportato ma nn posso cambiare la risoluzione,ferma a 1024x768. Ho una mobility.

Monitor:

Tipo: Controller compatibile con VGA
Bus: PCI
Slot: PCI
VRAM (totale): 256 MB
Fornitore: ATI (0x1002)
ID dispositivo: 0x71c5
ID revisione: 0x0000
Monitor:
Monitor:
Risoluzione: 1024 x 768
Profondità: Colore 32-bit
Core Image: Supportato
Monitor principale: Sì
Mirror: Spento
Online: Sì
Quartz Extreme: Supportato

#23
cremuz

cremuz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
ce l'ho fatta!!! avevo fatto un errore e dovevo lasciare ATYWORMY... beh grazie ancora!!!

firmato: uno stupido

#24
optimistic

optimistic

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts

mah,molto strano. ho seguito tutta la procedura sulla 10.4.6, ho tutto supportato ma nn posso cambiare la risoluzione,ferma a 1024x768. Ho una mobility.

Monitor:

Tipo: Controller compatibile con VGA
Bus: PCI
Slot: PCI
VRAM (totale): 256 MB
Fornitore: ATI (0x1002)
ID dispositivo: 0x71c5
ID revisione: 0x0000
Monitor:
Monitor:
Risoluzione: 1024 x 768
Profondità: Colore 32-bit
Core Image: Supportato
Monitor principale: Sì
Mirror: Spento
Online: Sì
Quartz Extreme: Supportato


nessuno sa darmi una mano?

#25
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Non c'è molto da fare sui notebook con le mobility blocca le risoluzioni. Prova a fare una ricerca.

#26
cogerma

cogerma

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
Buongiorno..

Ho comprato questa mattina la stessa scheda video di sax..(Ati Radeon Sapphire X1600 PRO 512MB PCI-e id: 0x71c2 QE/CI/OGL )nella speranza che potesse andare tutto bene..

ma non è cosi' perche' vedo ancora male i caratteri..sono tutti sgranati..

ho pensato che fosse il mio lcd.. ma non è cosi'..
anche nello screeshoot si vede che va male..

Sax come hai risolto?


Attached File  istante.tiff   901.39KB   67 downloads

#27
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Io ho sempre installato tutto manualmente su una 10.4.5 per poi aggiornare alla 4.7 mai avuti di questi problemi.
Magari stai usando una risoluzione troppo alta...

#28
fabioxx

fabioxx

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
vorrei un consiglio su una scheda ati agp tra la 9800 pro 128mb 256bit che potrei avere usata da un mio amico o una x1600pro 256mb 128bit, entrambe sapphire e agp, visto che non ho pci-ex. la x1600 vi verrebbe a costare circa il doppio della 9800 e mi interessa avere la migliore compatibilità con osx86, mentre sul lato prestazioni non conosco la differenza tra le due schede (tipo giochi su windows).
Se avete consigli, vi ascolto.

#29
sengir

sengir

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
ho un problema con la mia x1600 quando apro il file con nano nn ci sono le stringhe che dite come mai??? e cosa devo fare???

mi appare questo: Posted Image

#30
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
La tua versione sarà uuna 10.4.8 o superiore e nei nuovi driver non ci sono quelle stringhe.
Questa guida va bene 10.4.5-6-7

#31
8solo5

8solo5

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 106 posts
raga ma per leopard c'è qualche speranza??

#32
ironronnie

ironronnie

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Crotone
  • Interests:Sono un laureando di Ingegneria gestionale alla facolta dell'Università della Calabria.<br...

BorisBadenov X1600/X1800/X1900 Full Support Solution

GUIDE VERSION: 0.3

Credit goes out to borisbadenov for getting the official Apple drivers to work with X1600 and X1800 cards.

For the latest info and discussion about this method, refer to the 'boris thread' here

Remember the golden rule: Your Mileage May Vary. User experience has shown:

TRADUZIONE ITALIANA DELLA GUIDA DI munky


Post Originale

- La X1600 e X1800 funzionano perfettamente
- Con la 10.4.4 e 10.4.6 potrete avere artefatti - Provate la 10.4.5 (Es. il DVD Myzar)
- Il supporto DVI varia. Alcune possono usare soltanto il segnale VGA.
- La scheda video perfettamente funzionante sulla10.4.6 è la ASUS X1600XT Silent
- Il supporto per il DualDisplay per ora non funziona ma stiamo lavorando
- Schede video su schede madri con supporto SLI (due schede in parallelo) potrebbero funzionare con questa soluzione.

Nota: avete bisogno di un'installazione 10.4.4, 10.4.5 o 10.4.6 e di una scheda di X1600 o X1800-based. Nelle successive versioni 10.4.7 e 10.4.8 ci sono ancora problemi.
Per ovviare al problema potete installare il driver del tutto automatico che trovate in questo sito
LinkDriver questo driver funziona anche con la X1900

Ps. Il driver funziona in tutte le versioni...anche sulla 10.4.8

Nota: Se avete una Mobility X1600 con id 71c5 anche se installate il driver dovete modificare una stringa che trovate un pò più giù quella di ATY,WORMY con Display

Come applicare la patch:

1) (Se volete!) Rimuovere tutti i kext GeForce e ATIRadeon da /System/Library/Extensions eccetto:

ATIRadeonX1000.kext
ATIRadeonX1000GA.plugin
ATIRadeonX10000GLDriver.bundle
ATIRadeonX1000VADriver.bundle
ATINDRV.kext

2) Aprite il terminale e digitate:

sudo -s (inserite la vostra psw)
nano /System/Library/Extensions/ATINDRV.kext/Contents/Info.plist


Cercate questa stringa:

<string>IONDRVDevice</string>


e modificatela così:
<string>IOPCIDevice</string>

Adesso cercate questa stringa:
<string>ATY,Wormy</string>


e modificatela così:

<string>display</string>

Nota: Se avete una Mobility Radeon X1600 con id 71c5 dovete lasciare ATY,WORMY

Prenete Ctrl + o per salvare Ctrl + x per uscire.

Andate nel menù 'Apple', selezionate 'Informazioni su questo mac' 'Più Informazioni' per aprire System Profiler. Selezionate il tab 'Grafica/Monitor' Guardate il vostro Vendor ID e Product ID e scrivetevelo da qualche parte.
Es.

Tipo:	Controller compatibile con VGA
  Bus:	PCIe
  Slot:	PCI
  VRAM (totale):	256 MB
  Fornitore:	ATI (0x1002) <------Vendor ID
  ID dispositivo:	0x71c2 <-----Product ID
  ID revisione:	0x0000
  Monitor:
Monitor VGA:
  Risoluzione:	1280 x 960 @ 60 Hz
  Profondità:	Colore 32-bit
  Core Image:	Supportato
  Monitor principale:	Sì
  Mirror:	Spento
  Online:	Sì
  Quartz Extreme:	Supportato
  Rotazione:	Supportato

Adesso ritornate al terminale e digitate:
nano /System/Library/Extensions/ATIRadeonX1000.kext/Contents/Info.plist


Cercate la stringa che contiene 'IOPCIMatch'. Nella linea successiva dovete mettere il vostro Vendor e Product ID. Esempio, il vostro vendor ID è 1002, e il vostro device ID è 71c2. dovete combinare la stringa in questo modo 0x71c21002 (dove 0x è il valore base hex quindi lasciatelo così).

<string>0x71c21002</string>


Ctrl + o per salvare ctrl+x per uscire.

Adesso digitate:

nano /System/Library/Extensions/ATIRadeonX1000GA.plugin/Contents/Info.plist


Cercate queste due stringhe e modificate con il vostro vendo e device id:
Nel caso di sopra la stringa era: 0x71c21002
La modificheremo così...
<key>100271c2-0000-0000-0000-000a27898d3e</key>
<string>100271c2-0000-0000-0000-000a27898d3e</string>

Nota fate attenzione perchè è invertita stavolta quindi: 100271c2 e non 71c21002).

Per salvare sempre CTRL+O e per uscire CTRL+X

Adesso digitate:

rm /System/Library/Extensions.mkext
rm /System/Library/Extensions.kextcache
diskutil repairPermissions /


Riavviate e andate nella sezione in System Profller Grafica/Monitor se tutto sarà attivo come in questo esempio avrete abilitato QE CI e OpenGL

Monitor:

  Tipo:	Controller compatibile con VGA
  Bus:	PCIe
  Slot:	PCI
  VRAM (totale):	256 MB
  Fornitore:	ATI (0x1002)
  ID dispositivo:	0x71c2
  ID revisione:	0x0000
  Monitor:
Monitor VGA:
  Risoluzione:	1280 x 960 @ 60 Hz
  Profondità:	Colore 32-bit
  Core Image:	Supportato
  Monitor principale:	Sì
  Mirror:	Spento
  Online:	Sì
  Quartz Extreme:	Supportato
  Rotazione:	Supportato

Note:
Lo StandBy del monitor funziona solo se mettete il vostro monitor con un adattatore DVI/VGA nell'ingresso DVI almeno nel mio caso funziona solo così...
Questa procedura nel mio caso ha funzionato solo in un'istallazione 10.4.5 nelle successive non ho avuto successo a meno di installare il driver automatico.

Buon lavoro.


Credo proprio che grazie a te risolverò il problema...nessuno mi risponde per il momento..Ho installato il leo,con la kalyway,all'avvio dopo la mela in pratica lo schermo è indecifrabile!!milioni di righe sparse a caso per lo schermo..che devo fare? ;)
<string>IONDRVDevice.... non l'ho trovato....come ATY,wormy.....
come posso fare...devo scaricare qualcosa??
Grazie -_-





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy