Jump to content

myHack USB stuck on boot


  • Please log in to reply
14 replies to this topic

#1
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts

I have a Dell Inspiron 660s (I know building a PC is better for Hackintosh) that I want to install OS X 10.9 Mavericks to.  Made a USB with myHack and everything went fine as far as I know. I want to install on an MBR Partition so I made a Partition on my Drive of 100 GB called Macintosh.  That seems to be fine as well.  When I plug the USB in it boots the Apple Logo then it freezes.  I did some research, and found that doing -x or -x GraphicsEnabler=No helps.  But it didn't.   I have attached my System Specs and my Verbose Mode.

Attached Files



#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,975 posts
  • Gender:Male

What is your GPU as that is what it is hung up on. 



#3
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts

My GPU is a Intel HD 2500



#4
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,975 posts
  • Gender:Male

-v -x GraphicsEnabler=No

 

If still not booting remove the Intel GPU drivers from the USB stick Installer in SLE. 



#5
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts

Ok I will try that.


No luck verbose is still stuck at that point.

#6
Laberlohe

Laberlohe

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 218 posts
  • Gender:Male
  • Location:Frankfurt (Home of the Woscht)

Hello!

 

Set your HD2500 to 64MB in bios and try to boot with the flags "-v -f GraphicsEnabler=Yes IntelCapriFB=X dart=0 npci=0x3000" (X is a value between 1 and 11 - try all eleven possibilities until one is working). Note: flags dart and npci will perhabs be redundant, use them just in case of instability of the successfully booted system...

 

Afaik is HD2500 supported by the kexts for HD4000 - both are IvyBridge-family and so there is chance to get it working this way.

 

Good luck!



#7
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts

Ok I will try this



#8
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts
No luck using this method too.

#9
Laberlohe

Laberlohe

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 218 posts
  • Gender:Male
  • Location:Frankfurt (Home of the Woscht)

Sorry to hear that...

 

Last straw:

 

If still not booting remove the Intel GPU drivers from the USB stick Installer in SLE. 



#10
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts
I don't see any specific Intel Drivers. I do see AppleIntelGraphics.kext closest to it should I remove that. If so should I run myfix after that?

#11
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts
Got this after removing the Apple Intel kexts

Attached Files



#12
PimentelX86

PimentelX86

    InsanelyMac Deity

  • Local Moderators
  • 2,445 posts
  • Gender:Male
  • Location:Area 51

Hello

 

HD2500 doens't have support in OSX... You can enable it with this guide: http://www.insanelym...-and-qeci-1083/

But isn't vanilla support,you need edit the HD4000 kext for work as HD2500... And sometimes this work and sometimes not work...

 

If this Dell is notebook, you can try enable your HD2500 using that guide... but it isn't 100%

 

If this Dell is a Desktop, you can buy a dedicated graphic... GT610/620 work OOB in ML(since 10.8.3)and in MV



#13
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,975 posts
  • Gender:Male

Hello

 

HD2500 doens't have support in OSX... You can enable it with this guide: http://www.insanelym...-and-qeci-1083/

But isn't vanilla support,you need edit the HD4000 kext for work as HD2500... And sometimes this work and sometimes not work...

 

If this Dell is notebook, you can try enable your HD2500 using that guide... but it isn't 100%

 

If this Dell is a Desktop, you can buy a dedicated graphic... GT610/620 work OOB in ML(since 10.8.3)and in MV

 

Not true. The device ID is present in the Apple Drivers. And if I recall layout 6 is the default for HD2500. 

 

That said getting it to work out of safe mode has always been a challenge for myself. 



#14
PimentelX86

PimentelX86

    InsanelyMac Deity

  • Local Moderators
  • 2,445 posts
  • Gender:Male
  • Location:Area 51

Hello

 

Good to know about it ...

But anyway, there are always
side-effects those using unsupported hardware

An example: I use the GT610, but in 10.8 it didn't work, so I had to edit the kext adding my Devices IDs ... after that it worked, but i felt it had not well performed, after I updated to 10.8.3 my graphic was well recognized and i noticed a considerable increase in performance and some lags that sometimes i gave gone
...



#15
Goku123

Goku123

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 8 posts
Thanks for all the help. I will look into buying a new graphics card or just install Mavericks in virtual box since all I need is Face time and iMovie





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy