Jump to content

Kernel Panic Maverick 10.9.1 USB

- - - - -

  • Please log in to reply
22 replies to this topic

#1
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto

Boas pessoal tenho o seguinte computador e estou a ter problemas ao instalar a versão 10.9.1

 

A minha máquina é a seguinte:

 

- Caixa: Lancool PC-K62;

- Antec True Power New 750W;

- Motherboard: Asus P5P43TD Pro;

- CPU: Intel Core 2 Quad Q8300;

- CPU Coller: Xigmatek Gaia;

- Placa gráfica: EVGA GTX 760 SC;

- Memória Ram: GSkill 4gb DDR3 PC12800;

- Disco Duro: Samsung 840 Evo 120 Gb e Samsung F3 1Tb 7200rpm 32mb.

 

Sempre que tento instalar o Maverick na máquina tenho sempre kernel panic da seguinte kext: iostoragefamily.kext

 

Algumas vezes deixa até entrar no instalar outra vezes reinicia logo a máquina de seguida. Já tentei instalar com o clover e chamaleon e o problema mantém-se.

 

Se puderem ajudar agradecia.



#2
carbo178

carbo178

    InsanelyMacaholic

  • Local Moderators
  • 4,869 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Seria melhor se eu tirasse uma foto do Kernel Panic

 

Desculpe pelo meu mau Português



#3
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto

O seu Portugues está bom  :thumbsup_anim:

 

Aqui vai a foto do Kernel Panic:

1lzh.jpg



#4
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

 

Agradeço pelo suporte do carbo178.

 

Estava no momento ocupado... vocês sabem, trabalho, estudos, família...

 

Logo quero te falar que teu hardware é bom e esse Intel C2Q é suportado numa boa pelo Mavericks e a gráfica também.

 

A pergunta é: Qual método seguiu para fazer seu penboot(usb bootavél)?

Saiba desde já que não damos suporte para as ferramentas de tonymac, veja na minha assinatura para saber o porque.



#5
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto
Fiz download do sistema operativo 10.9.1 e transferi a imagem .raw para um pendrive através do programa Image Writer.
Faço boot atraves da pendrive com clover/chameleon e tento instalar o maverick.

PS: Não uso nenhuma ferramenta do tonymac

#6
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

Conheço essa imagem é do site olarila, não tem problemas acerca dela, na verdade ela é bastante útil.  :) 

Tenta configure a sua Bios: http://olarila.com/f....php?f=2&t=1804



#7
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto
Sim a imagem é do Olarilla. Infelizmente já configurei a bios e o problema mantem-se. Alias até cheguei a mudar a board para uma 5570 e um hdd mecanico de 1tb e o problema mantem-se :/

#8
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

 

Tenta usar essas kexts:

 

GraphicsEnabler=No UseKernelCache=Yes -v

 

Se não, tenta:

 

GraphicsEnabler=No -f  -v

 

ou um mais completo

 

GraphicsEnabler=No cpus=1 -v

 

No Clover aperta [espaço] e selecione boot withoutcaches

 

Boa sorte!



#9
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto

Finalmente consegui instalar o maverick na máquina. Tive que instalar o maverick com o idioma "English" e correu tudo normal.

 

Agora estou com outro problema no dsdt. Coloquei o dsdt na pasta EFI/CLOVER/ACPI/patched mas ao arrancar dá-me um panic do IOPlatformExpert.

 

Também queria por a Ethernet a funcionar DevId 1026 Atheros AR8121 alguma dica?



#10
All@n

All@n

    InsanelyMac Universum

  • Members
  • PipPipPipPipPipPipPip
  • 885 posts
  • Gender:Male
  • Location:Brazil

Para o Ethernet: http://www.osx86.net...-ar8113-ar8114/

 

Para o KP, adicione isso no Config.plist

<key>Arguments</key>
<string>darkwake=0 dart=0</string>


#11
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

Clover é + complexo, porque não escolher Chameleon? Ele é muito + fácil.

Não sei se essa mobo é UEFI, sendo ou não sendo você pode escolher o modo legacy_boot para usar o Chameleon.

Aqui mesmo tem um guia falando desde a instalação até a configuração do Chameleon: http://www.insanelym...eon-bootloader/



#12
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto
Eu sempre usei o chameleon no entanto toda a gente fala agora do clover. Por isso instalei o clover.

#13
All@n

All@n

    InsanelyMac Universum

  • Members
  • PipPipPipPipPipPipPip
  • 885 posts
  • Gender:Male
  • Location:Brazil

Não se precipite! 

 

Recomendei o que te falei acima, pois pensei que estava usando ele, pois na imagem do Olarila ele já vem como padrão.

 

Mas tente usar o Chameleon como o Pimentel falou, pra iniciantes é melhor, e te poupa dor de cabeça.

 

Coloque isso no boot.plist se ainda usa o Chameleon:

<key>Boot Flags</key>
<string>darkwake=0 dart=0</string>

E sua placa-mãe (se for da assinatura) não tem UEFI, vai ter que instalar em Legacy, instale o Chameleon.



#14
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

 

Acho que não deve ser a mesma mobo... de qualquer forma Chameleon é + fácil.

 

De forma alguma estou tentando te influenciar ou te obrigar a usar Chameleon, somente estou te orientando, pois Clover é mais complexo e se baseia totalmente no config.plist, se tiver alguma coisa errada no config.plist ou em falta a probabilidade do sistema não iniciar é bem grande.

 

De qualquer forma estaremos aqui para ajudar.



#15
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto

Decidi seguir o vosso conselho e instalei tudo de novo com o Chameleon e para já está tudo a funcionar. Até a Ethernet (obrigado Allan Oliveira).

Agora só falta colocar a DSDT em condições. Em anexo deixo o dsdt original extraído do dsdt editor.

 

PS: Reparei que os discos estão com a cor laranja como posso corrigir o problema e voltar ao estado original?

Attached Files



#16
All@n

All@n

    InsanelyMac Universum

  • Members
  • PipPipPipPipPipPipPip
  • 885 posts
  • Gender:Male
  • Location:Brazil

Tem que inserir este código com os devices ids da controladora dos seus disco, SATA:

 

Mas antes de aplicar, veja qual é seu device id:

 

Attached File  Screen Shot 2014-02-11 at 2.42.24 PM.png   12.9KB   5 downloads

Method (_DSM, 4, NotSerialized)
            {
               Store (Package (0x02)
                  {
                     "device-id", 
                     Buffer (0x04)
                     {
                        0x81, 0x26, 0x00, 0x00
                     }
                  }, Local0)
               DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
               Return (Local0)
            }

E você tem que ter o metodo DTGP aplicado na DSDT:

Method (DTGP, 5, NotSerialized)
    {
        If (LEqual (Arg0, Buffer (0x10)
                {
                    /* 0000 */    0xC6, 0xB7, 0xB5, 0xA0, 0x18, 0x13, 0x1C, 0x44, 
                    /* 0008 */    0xB0, 0xC9, 0xFE, 0x69, 0x5E, 0xAF, 0x94, 0x9B
                }))
        {
            If (LEqual (Arg1, One))
            {
                If (LEqual (Arg2, Zero))
                {
                    Store (Buffer (One)
                        {
                            0x03
                        }, Arg4)
                    Return (One)
                }

                If (LEqual (Arg2, One))
                {
                    Return (One)
                }
            }
        }

        Store (Buffer (One)
            {
                0x00
            }, Arg4)
        Return (Zero)
    }

Um pouco de conhecimento sobre isso:

 

Porque que aparecem laranja?

 

O ícone aparece laranja porque você ativou isso na BIOS.

 

Todos sabem que o OS X precisa do HD configurado como AHCI, e isso automaticamente habilita o Hot-Plug (ou Hot-Swap).

O Hot-Plug, por sua vez, é um recurso bastante interessante: ele permite que você troque, remova ou instale HDs sem desligar o sistema, como um pendrive. Você só precisa ejetar o HD desejado ou conectar um novo.
Só que, para trabalhar como um HD removível, ele precisa ser reconhecido como Dispositivo Externo, ou HD externo.
Por isso os ícones laranjas, padrão de todo HD Externo no OS X.

Portanto, ícone laranja não é um problema; apenas significa que você tem o recurso Hot-Plug ativado.
Isso NÃO interfere no desempenho do disco e nem precisa ser obrigatoriamente "corrigido".

 

Pode aplicar como te falei acima pela DSDT.

 

Mas a melhor opção é configurar no BIOS:

Nas opções de Disco, geralmente em SYSTEM, podemos desativar (DISABLED) apenas o Hot-Plug. Dessa forma os HDs voltam a ter o ícone padrão, mas sem a possibilidade de troca instantânea.



#17
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

 

Você também pode instalar essa kext: http://www.insanelym...attach_id=87701

Ela corrigi essa falha "cosmética" que mostra o HDD fixo, como sendo externo.

 

Para fazer sua DSDT tem esse guia: http://olarila.com/f...c.php?f=7&t=646

Sendo que DSDT não é tão necessária atualmente, mas ajuda.

 

Para habilitar o gerenciamento de energia para esse CPU, deve-se ativar P e C States com ajuda do app Chameleon Wizard e escolher MacPro3,1 como sendo seu SMbios e não instalar ou remover a kext NullCPUPM



#18
All@n

All@n

    InsanelyMac Universum

  • Members
  • PipPipPipPipPipPipPip
  • 885 posts
  • Gender:Male
  • Location:Brazil

Recomendo o modo BIOS pois não requer nenhuma alteração do Hack.

 

Esta Kext já deu alguns problemas, mas veja ai qual é o melhor para você, é como te disse ícone laranja não é um problema.



#19
PimentelX86

PimentelX86

    InsanelyMac Legend

  • Local Moderators
  • 1,363 posts
  • Gender:Male
  • Location:Brazil

Olá

 

Eu sempre uso essa kext e nunca deu problemas para mim, só testando para ver.

 

O resto é ler, compreender, praticar e ter perseverança :)



#20
Onvrb

Onvrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Porto
Como o icon laranja não é um problema decidi nem mexer. Se resto segui tudo o que me disseram só falta mesmo por o som a dar.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy