Jump to content

Samsung np300e5c-a0aus


  • Please log in to reply
8 replies to this topic

#1
nickabocker2k10

nickabocker2k10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hi everyone,

 

I have been searching and searching to see if anybody has done a hackintosh on a Samsung like mine, but to no avail have i been able to find one. I recently have been dabbling in Hackintosh and have successfully installed Mac OS X SL on a old CR-48 i had lying around. Now i'm ready to make the jump and do the same thing with my Samsung. My Biggest issue is listed below

 

1. Cant seem to get my USB to load any boot loader, I did get Clover to load ONCE but it never saw my install USB for my drive and when i restarted i could never get it to happen again.

 

I've gone ahead and attached a screen shot of my build ( PC Wizard 2013 gave me the info)  I'm hoping to build a tutorial on it for others to see when i get finished :)

 

Can Anyone Help?

 

Also side note, I cant seem to get a boot loader install to HDD on my cr-48 it only seems to work on my sd card only suggestions?

 

Thanks,

 

Nick

Attached Files



#2
Yragael

Yragael

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Fort de France, Martinique

Hi.

 

My lappy is a NP550P5C, running Mavericks.

I think your computer uses an APTIO UEFI Bios, am i right ?

 

If so, you have to disable secure boot and enable Legacy boot for Chameleon, or UEFI only for Clover.

 

You'll also need to force SATA controller to AHCI.

 

I use Clover, now the documentation is understandable.

 

Have fun.



#3
nickabocker2k10

nickabocker2k10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Well I got it to load finally had edb disabled. Got installer to work but now its stuck on first boot :(
Looks like im hanging on bluetoothcontroler register based off of -v

#4
nickabocker2k10

nickabocker2k10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Ok finally loaded all the way in I can only boot via safeboot and verbose mode. No wifi any suggestions

#5
Yragael

Yragael

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Fort de France, Martinique

What happens when you boot with verbose flag only ?

 

Please post original DSDT and IORegistryExplorer report.

 

 

For Wifi, HD4000, Battery..  DSDT edits.

 

Wifi, under Device (RP01)
 
 
                Device (ARPT) 
                {
                    Name (_ADR, Zero)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package (0x10)
                            {
                                "built-in", 
                                Buffer (One)
                                {
                                    0x00
                                }, 
 
                                "model", 
                                Buffer (0x19)
                                {
                                    "Atheros AR9285 WiFi card"
                                }, 
 
                                "name", 
                                Buffer (0x0B)
                                {
                                    "pci168c,2a"
                                }, 
 
                                "device-id", 
                                Unicode ("*"), 
                                "subsystem-id", 
                                Buffer (0x04)
                                {
                                    0x8F, 0x00, 0x00, 0x00
                                }, 
 
                                "subsystem-vendor-id", 
                                Buffer (0x04)
                                {
                                    0x6B, 0x10, 0x00, 0x00
                                }, 
 
                                "device_type", 
                                Buffer (0x08)
                                {
                                    "Airport"
                                }, 
 
                                "AAPL,slot-name", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
 
 
HD4000, renamed GFX0 to IGPU then
 
Method (_DSM, 4, Serialized)
            {
                Store (Package (0x04)
                    {
                        "AAPL,ig-platform-id", 
                        Buffer (0x04)
                        {
                            0x03, 0x00, 0x66, 0x01
                        }, 
 
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }


#6
nickabocker2k10

nickabocker2k10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Sorry for the late reaponce I just barely checked my email. I finally got into boot without -x command. Changed the graphics driver and viola better :)

#7
nickabocker2k10

nickabocker2k10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Ok so I went a head and installed ##### for drivers etc and that caused me to crash (applepowermanagement) so I wiped drive reinstalled and got it to work great , now that I know I have intel hd graphics. But wifi wasnt work Antel AR5B225 WLAN so I gave up after fighting for a bit. Now when I boot I cant get my keyboard to work, I didnt install any extra ktext any ideas? I read that possibly a custom dsdt will fix my issues? BTW im using ##### and Maveriks install now (it was free :) )

#8
Yragael

Yragael

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Fort de France, Martinique

To use PS2 keyboard you need ApplePS2Controller or VoodooPS2Controller kext.

Apple uses USB or bluetooth keyboards, so yours needs a driver.

 

About WiFi, it appears that AR5B225 is not supported (didn't try).

You may try DSDT fix.

Otherwise here is a list of supported cards: http://forum.osxlati...cards-inventory

or here https://spreadsheets...=ru&output=html

Let me know which extensions are installed on your system.

 

It is always better to install vanilla OSX, do not use any installer.

 

To start you just need FakeSMC and keyboard extensions.



#9
nickabocker2k10

nickabocker2k10

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Okay so ended up switching wireless card from my cr-48 to my samsung got my wifi to work found out I have to wait 5 to 7 minutes for keyboard and mouse to decide to work now my big issue is if I start the laptop unplugged my display is bright but as soon as I plug it in to display stays bright when I unplug it goes dim not sure how to fix that?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy