Jump to content

Radeon HD 5670 on Mavericks ?


Best Answer ilkiii, 16 January 2014 - 04:56 PM

---UPDATE---

 

I reinstalled Mavericks today and now it finds my graphics card and it works now.

Thanks for the support !!

 

vWwkPRt.jpg

Go to the full post


  • Please log in to reply
22 replies to this topic

#1
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Hey guys,

 

are there any kexts for the ATI Radeon HD 5670 for mavericks ? 



#2
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

I tried to inject the Graphics with Clover, but he still gave me 5MB Graphics and a wrong screen resolution,

 

at first he gave me 1024x768 , now he gives me 1280x1024

My needed screen resolution is 1440x900

Attached Files



#3
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,846 posts
  • Gender:Male
  • Location:Moscow

Did you follow instructions?

     [HOW TO] Make Radeon {Desktop or Mobility} be working by using Clover    



#4
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

Hi all. I have the same graphics card here and it works fine, even with the Clover or DSDT injection. You have found the ID of this device?



#5
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

yes , I have the vendor and device ID and I tried to install this Kext : http://www.osx86.net...dename-juniper/

 

it didn't work , but my vendor and device ID are in this kext

 

Xath9XJ.jpg


my problem is the AMDRadeonAccelerator.kext , because it shows many issues when I try to boot it with this kext 

 

R1XLNCt.jpg 

 

I deleted this kext from S/L/E , tried to boot with 'GraphicsEnabler=Yes -v and turned off InjectATI and VBios in Clover, but it still doesn't work



#6
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

You still have some kind of active injection in the system (DSDT, Graphics Kext or Graphics Enable=Yes)?

 

What are the connectors of the card?



#7
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

what do you mean with connectors? i'm sorry because i'm a real newbie hahaha :/



#8
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,846 posts
  • Gender:Male
  • Location:Moscow

yes , I have the vendor and device ID and I tried to install this Kext : http://www.osx86.net...dename-juniper/

 

it didn't work , but my vendor and device ID are in this kext

 

my problem is the AMDRadeonAccelerator.kext , because it shows many issues when I try to boot it with this kext 

 

 

I deleted this kext from S/L/E , tried to boot with 'GraphicsEnabler=Yes -v and turned off InjectATI and VBios in Clover, but it still doesn't work

 

I didn't understand what you installed and what you deleted? These kexts already present in system and you just kill system kexts.



#9
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
No they weren't present before I installed this kext

And I made a backup of AMDRadeonAccelerator.kext

#10
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

The case is that the graphics card should have been recognized natively. Mine has the same device id that your rose nearly perfect video and no modifications or GE = Yes, nothing at all. Only had to use DSDT and edit AMD5000.kext to get use FB Baboon with the correct connectors. Maybe you should reinstall the Mavericks again without any kind of injection and after all ok from modifications to the kext if necessary. But do not use distros, make the original image on a thumb drive and, in my case, use bootloader Clover with total ease, just a little reading ...



#11
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

can you send me your amd5000.kext ? 



#12
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

My modified kext can not work on your graphics card and depends on activation by injection Clover or DSDT. By Chameleon never got FB. I passasr everything for you so you can try but no guarantees, ok?



#13
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

okay, i'll give it a try  :)



#14
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

Install the kext with Kext Utility and insert the patch I'm sending in your DSDT or enable injection Clover by making the necessary changes to get the FB Baboon. But remember it may not solve for you. Incidentally, you need to say what are the connectors of the graphics card and the order in which they are from the PCI-E slot, ie, the part next to the motherboard.

 

http://www.sendspace.com/file/y56yn1



#15
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

okay , do i need the dsdt editor for looking for the connectors ? 



#16
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

Yes, but first tell about the connectors.


To say what are the connectors and their order just look at your graphics card connected.

 

I forgot to mention that it might be more difficult to make it work for you using a modified kernel for AMD. I think I read that somewhere ...



#17
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
so , i opened up my computer and my card is in a pci slot
and i use it with vga

G6URytc.jpg

i'll be back in a minute when i built up and booted mac again

i'm back now, i downloaded the DSDT editor and I'm searching my HD 5670


can you help me with the dsdt editor ? 



#18
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

here is my original dsdt.aml if it could help you :)

 

http://www.sendspace.com/file/9k3gh4



#19
Wppley2

Wppley2

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male

Read this carefully. The most important is to read and learn, so if you need later, you know what it takes  ;)

 

http://olarila.com/f...c.php?f=19&t=62



#20
ilkiii

ilkiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Best Answer

---UPDATE---

 

I reinstalled Mavericks today and now it finds my graphics card and it works now.

Thanks for the support !!

 

vWwkPRt.jpg







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy