Jump to content

Install problems with HP 6720s Compaq


  • Please log in to reply
1 reply to this topic

#1
HarderStyle

HarderStyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Belgium

Hello everyone,
Let me introduce myself,
My name is Arno and i come from Belgium,
I have some really good experience with Windows and i always can fix my own problems and those from other people regarding their Windows PC.
I've always been a fan of OS X but just haven't got the money to buy an Apple computer.
Now,to get to the point:
I'm trying to install Lion to one of my computers at home,my HP 6720S Compaq laptop.
I can't get it to boot into the installer itself... It panics when loading files before the installer itself starts.
To let you guys understand my situation i will go over the whole procedure i followed untill now.
On one of my other computers i have SL running in Virtualbox.
(In my SL VM) I've got the Mac OS X Lion install app and i showed its contents en navigated to the SharedSupport folder to copy the "InstallESD.dmg" image to the desktop.Once i got that i mounted it en enabled the showing of hidden files by excecuting this command in the terminal:

 

defaults write com.apple.finder AppleShowAllFiles True

next, i mounted the Base System dmg and in disk utility i formatted and partitioned my 8gb usb flash drive to 1 OS X Journaled(extended) partition with the MBR scheme and i restored the Base System to it.
Next,i went into the S/Installation folder on the usb drive and i deleted the Packages alias and i pasted the Packages folder from the InstallESD.
In the root of the usb drive i pasted the mach_kernel wich i got from the root of the InstallESD and in the root of the usb i also made a folder called "Extra" en i moved the "DSDT.aml" for my laptop into that folder.
I also installed these kexts:NullCPUPowerManagement,FakeSMC,ApplePS2Controller and AppleACPIPS2Nub to the S/L/E folder of the usb drive with the help of kextwizard and after that i repaired the permissions and rebuilded the kext cache with kextwizard on the usb drive.
Finally i got the Chameleon 2.2 svn r2269 pkg and i installed it to the usb drive.
Initialy when i plugged the drive in my laptop and tried to boot from it,there just was this blinking underscore and nothing more that happened.
So i burned an I B O O T disk(can't use this on this forum,i know,sorry) and used it to boot from the usb drive with the flags "-v -x" and that resulted in the system rebooting when it's loading files.The last file that i saw was loaded is "sm56kusbaudiofamily".

I tried different boot flags like: -v -x GraphicsEnabler=No PCIRootUID=1 arch=i386 and so on,and so on but none of them got me any further.
I also disabled all features i don't need in the bios leaving only the cd drive and usb working..things like wifi,bluetooth,network boot,card readers,prevention of data excecution,... i have all disabled it but this didn't help either.
Anyone got some ideas?
Let me know!
Thanks! 

 


#2
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 832 posts
  • Gender:Male

You are welcome.

 

But sorry, I can´t give you tips. I dont know the hardware, which is in your device used.

 

You make it easier to give you tips for doing a successful install, if you put your hardware in your signature, like many others here have done it.

 

Have fun.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy