Jump to content

Realtek 8168/8111 solution


  • Please log in to reply
870 replies to this topic

#841
lnx2mac

lnx2mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Thank you! But can you tell me how to install it or point me to a guide that tells me? I am very new so please pardon me.

http://bit.ly/RTL81xx
Basically, grab & unpack the zip file, choose Debug/Release and put it on your desktop.
Run #####. Reboot. You are done :hysterical:

#842
Bam Rock

Bam Rock

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

http://bit.ly/RTL81xx
Basically, grab & unpack the zip file, choose Debug/Release and put it on your desktop.
Run #####. Reboot. You are done :)


Just want to keep the page updated if nobody else has tried....verified working! Corrected my issues with 1password sync, Plex Media Server to my iphone (and to my jailbroken Apple TV 2g) and I think it's all because lnx2mac has amazing drivers that fixed bonjour! Whatever the reason I love it and thanks!!! This is working on the onboard LAN (8111C) on a Gigabyte GA-P31-ES3G running 32 bit Snow Leopard.

#843
lnx2mac

lnx2mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Just want to keep the page updated if nobody else has tried....verified working! Corrected my issues with 1password sync, Plex Media Server to my iphone (and to my jailbroken Apple TV 2g) and I think it's all because lnx2mac has amazing drivers that fixed bonjour! Whatever the reason I love it and thanks!!! This is working on the onboard LAN (8111C) on a Gigabyte GA-P31-ES3G running 32 bit Snow Leopard.

Bam Rock,
Thanks for your kind words :P

#844
Guilevv

Guilevv

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Updated to 10.6.5 and ethernet is not working.

Installed using RTGMac 2.0.5 - Realtek RTL8169

Is anyone else having this problem too?

#845
farski

farski

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Is there any way to install this in /E/E or somewhere other than the actually System folder? I'm building this PC for someone else and I'm trying to keep everything new sandboxed if possible, but I'm getting dependency errors when I move the kext to /E/E. Not a huge deal I guess, since it works perfectly, but if it's possible even with a bit of leg work I'd do it. Thanks.

#846
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male
  • Location:France

Updated to 10.6.5 and ethernet is not working.

Installed using RTGMac 2.0.5 - Realtek RTL8169

Is anyone else having this problem too?


Hello,

I think this kext is best !

http://www.kexts.com...sal_driver.html

Working for me in /Extra/ like a charm

Credits go to:
http://lnx2mac.blogs...osx-driver.html

:D

#847
lnx2mac

lnx2mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Hello,

I think this kext is best !

Thanks !

Working for me in /Extra/ like a charm

Actually, the recommended place for it is in /S/L/E, as it depends on IONetworkingFamily...
Note also that last week I released a new installer package for it, which takes care of conflicting kexts (if any), and rebuilding caches... So, it avoids the most common errors I found some users had.
Its version number is 0.0.67+ as it also solves a small incompatibility for users of RTL8169 cards.

Credits go to:
http://lnx2mac.blogs...osx-driver.html

Thanks again !

#848
neil43

neil43

    Grey Beard

  • Members
  • PipPipPipPip
  • 221 posts
  • Gender:Male
  • Location:Fremont, California, USA

http://bit.ly/RTL81xx
Basically, grab & unpack the zip file, choose Debug/Release and put it on your desktop.
Run #####. Reboot. You are done ;)


This driver and the installer are great. I am on a ECS H55H-I rev 1.0A with RTL8111DL and was only able to get about 1MB Sec transfers. After installing the RTL81xx from the link above, I was able to get GigaBit speeds with file transfers over my home network run 41+MBS. Running OS X 10.6.4

neil

#849
rushtrader

rushtrader

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
lnx2mac:

I grabbed your kext last night and installed on my Gigabyte X58-USB3 board, It starts, find the chip, recognizes the MAC address and thinks it is OK according to dmesg when running the DEBUG driver, but no network connection is made - no lights on the connector either. I built the system with #####/##### based on the DSDT from the database - proper BIOS level.

The network worked fine while I was booting off of the ##### disc but once I finally got the system to properly boot on its own, which required Chameleon RC5 with ATI support, ATY_INIT vervet kext (for Radeon 5770) and VoodooHDA 0.2.56, the network stopped working. I installed your 67+ package, but still no good.

I can set up a manual IP and it will ping itself, but that is it.

Any thoughts?

Thanks,
RT

#850
lnx2mac

lnx2mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

lnx2mac:

I grabbed your kext last night and installed on my Gigabyte X58-USB3 board, It starts, find the chip, recognizes the MAC address and thinks it is OK according to dmesg when running the DEBUG driver, but no network connection is made - no lights on the connector either. I built the system with #####/##### based on the DSDT from the database - proper BIOS level.

##### does nothing with the DSDT... Did you copy it manually to /Extra ?
If not, you should be using UserDSDT in #####.

The network worked fine while I was booting off of the ##### disc

Meaning NIC is OK, and recognized by the RTL81xx kext (which the latest ##### versions use).

but once I finally got the system to properly boot on its own, which required Chameleon RC5 with ATI support, ATY_INIT vervet kext (for Radeon 5770) and VoodooHDA 0.2.56, the network stopped working. I installed your 67+ package, but still no good.

Please post in http://www.tonymacx86.com/ for follow-up.

Thanks,
Lnx2Mac

#851
rushtrader

rushtrader

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

##### does nothing with the DSDT... Did you copy it manually to /Extra ?
If not, you should be using UserDSDT in #####.


Meaning NIC is OK, and recognized by the RTL81xx kext (which the latest ##### versions use).


Please post in http://www.tonymacx86.com/ for follow-up.

Thanks,
Lnx2Mac


Will do, thanks.

#852
sstyle

sstyle

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
Can somebody help me? Sometimes bonjour stops working. My macbook doest see printer that connect to hacintosh PC, soft like Things doesnt see iPhone etc. I go to network prefs and turn off iPv6 and then turn back - auto mode. It helps for a time. Internet and LAN works perfect.

#853
iwantmac2

iwantmac2

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
anyone use an RTL 8939D card?
it was working great in 10.5.6 but now it limps along on 10.6.3 and 10.6.5 - I feel like I'm on dial up
gx280 3.4Ghz P4 MyHack chocolate kernel with PATA drives on 10.6.5 and 10.5.6

#854
ravendawson

ravendawson

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I just found a good site that has a handy tool that can automate the task of updating realtek green ethernet drivers. Haven't personally tried it yet, but thought it may be worth sharing. :)


http://www.driversdo...tek-drivers.htm

#855
Dinoisme

Dinoisme

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Has anyone found anything for the Realtek 8112L?

#856
ZogD

ZogD

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
This worked fine for my system with Mac OSX 10.6.3 (worked both for kext patched system and DSTD patched system)

terminal window -> go to the dir where it is installed type

sh installrelease

(give admin pass)

got an error saying that it was not installed properly and |I have to reinstall it

however all worked fine after a reset

Thank you ! ;)

#857
Nameci

Nameci

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 166 posts
  • Gender:Male
hello lnx2mac,

is RTL8101E already included in your kext?

#858
lnx2mac

lnx2mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

hello lnx2mac,

is RTL8101E already included in your kext?

Almost... It's currently in Pre-Alpha (not in the 0.0.67 beta...)

Should be released soon...
Follow me on Twitter / Subscribe to my Blog to get the word when done.

#859
toyotascionxd

toyotascionxd

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
somebody referred me to this thread. i have an asus pce-n13 pci wireless adapter. i am able to go online on snow leopard 10.6.3 but not when i upgrade to 10.6.6 and run #####. would installing the realtek kext solve this problem?

#860
aao_pink

aao_pink

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Does RTL8111E support Auto MDIX?
I have GA P55A-UD3 mobo with this chip, and it's running fine with Lnx2mac's driver (cheers bro!), but,
I've gotten so used to using modern real Mac 'puters which can be plugged back to back or to other devices without worrying about a hub or crossover cable, and this 8111 won't do that.

Realtek have a "features" sheet http://www.realtek.c...i...&ProdID=239 which it claims can slice. dice, and serve 37 flavors of hot and cold beverages, but it doesn't say outright "Yes it does AutoMDIX", unless it's a hidden feature in one of those IEEE specs. Or a feature that isn't activated (yet) by this driver?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy