Jump to content

Nvidia GTX Recognized as 8600GT


  • Please log in to reply
6 replies to this topic

#1
gurden

gurden

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi all, would really appreciate your assistance:

 

I've installed Mavericks on a P5GC-MX MB using Myhack. Everything works great. 

I've used a DSDT file that i've extracted from windows prior to the installation of Mavericks.

The only problem i'm unable to solve is the GPU being recognized as 8600GT. I have a EVGA GTX460 V2 installed. 

The system information indicates the following: Nvidia GeForce 8600 GT OpenGL Engine [EFI]

I've tried to replace the kext, change the GraphicsEnabler to yes/no. nothing solves it. 

 

Attached, the "System information" Picture, A capture from an app i used called "System Info" that recognizes it correctly.

Also attached, the DSDT and IORegistryExplorer info.

 

Thanks a lot!

Gurden.

Attached Files



#2
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,045 posts
  • Gender:Male
  • Location:Brazil

It sounds like you may have a device properties string in your /Extra/org.chameleon.Boot.plist injecting your video card as a 8600 GT.

 

I didn't look at your attachment but I believe "System Info" uses LSPCI, which explains why it recognises your GTX 460.



#3
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 578 posts
  • Gender:Male
  • Location:Croatia

Hi all, would really appreciate your assistance:

 

I've installed Mavericks on a P5GC-MX MB using Myhack. Everything works great. 

I've used a DSDT file that i've extracted from windows prior to the installation of Mavericks.

The only problem i'm unable to solve is the GPU being recognized as 8600GT. I have a EVGA GTX460 V2 installed. 

The system information indicates the following: Nvidia GeForce 8600 GT OpenGL Engine [EFI]

I've tried to replace the kext, change the GraphicsEnabler to yes/no. nothing solves it. 

 

Attached, the "System information" Picture, A capture from an app i used called "System Info" that recognizes it correctly.

Also attached, the DSDT and IORegistryExplorer info.

 

Thanks a lot!

Gurden.

U need to have graphicsenabler=yes and use original untouched kext.

Graphics card its injected good soo your problem its in wrong kexts.



#4
gurden

gurden

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi Guys,

 

You were both SPOT ON! There was indeed a Device string that injected the information - Removed it and the card is recognized correctly!

Now i've encountered a different problem: from what i've read, GTX card are natively supported under Mavericks so i set the GraphicsEnabler=no - I get a black screen but it seems the OS has fully loaded.

Tried: npci=0x2000, PCIRootUID=0 - Didn't solve it. only GraphicsEnabler=yes starts correctly... any advice?

 

Thanks again,

Gurden.



#5
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,045 posts
  • Gender:Male
  • Location:Brazil

Partially correct. Your GTX 460 is a Fermi card. Only Kepler cards are natively supported, Fermi needs property injection in order for the nvidia drivers to load.



#6
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,953 posts
  • Gender:Male

GTX 460's have a long history of issues.



#7
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 578 posts
  • Gender:Male
  • Location:Croatia

Hi Guys,

 

You were both SPOT ON! There was indeed a Device string that injected the information - Removed it and the card is recognized correctly!

Now i've encountered a different problem: from what i've read, GTX card are natively supported under Mavericks so i set the GraphicsEnabler=no - I get a black screen but it seems the OS has fully loaded.

Tried: npci=0x2000, PCIRootUID=0 - Didn't solve it. only GraphicsEnabler=yes starts correctly... any advice?

 

Thanks again,

Gurden.

As i already say u need graphicsenabler=yes for this card.

Other than that u can inject it through DSDT.

I added it for u soo u can try with this dsdt and graphicsenabler=No

 

Attached File  DSDT.AML.zip   9.77KB   30 downloads







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy