Jump to content

[Aiuto] Asus P6X58D Premium - installazione mavericks


Best Answer frankyweb, 23 November 2013 - 07:43 AM

Prova questo

OK!!!! tutto funzionante!!!

Grazie!!!!!!

Go to the full post


  • Please log in to reply
21 replies to this topic

#1
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

un saluto a tutti, ho provato l'installazione di mavericks seguendo questa guida

http://www.insanelym...-109-mavericks/

al rivivo da pennetta con -f è partito ma non funzionano le USB ne 2 e nemmeno le 3, audio e pan. Riavviando senza pennetta si blocca e avviando in verbose ecco dove si ferma.

qualche aiuto?

Attached Files



#2
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Ciao, avvia con -v -x e prova ad installare questo sull'Hard disk



#3
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

fatto, ma system ultime in nanoseconds.... sistemata la sk pan ma ho provato ad intarlare i kext AppleHDA for ALC889 con kext utilità ma non va.

parte solo con -f



#4
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Hai un panic? posta la foto

Se hai seguito la guida devi installare NullCPU e FakeSMC nell'HD; inoltre se hai smbios MacPro 4,1 o 5,1 devi eliminare AppleTYMCEdriver



#5
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

Hai un panic? posta la foto

Se hai seguito la guida devi installare NullCPU e FakeSMC nell'HD; inoltre se hai smbios MacPro 4,1 o 5,1 devi eliminare AppleTYMCEdriver 

ho installato NullCPU e FakeSMC, al riavvio si ferma su "system ultime in nanoseconds " come vedo se ho smbios Mac Pro 4,1 o 5,1 ? AppleTYMCEdrive è in S/L/E. 



#6
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Se non fai la foto non capiamo il perchè del panic



#7
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

stamattina ho avviato in -v ed è partito, ho sistemato la LAN ma non riesco con la sk audio, ho provato "AppleHDA_for_ALC889" ma non funziona , che posso provare?



#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Se non hai il dsdt devi mettere l'enabler; se hai il dsdt devi cambiare layout id



#9
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

Se non hai il dsdt devi mettere l'enabler; se hai il dsdt devi cambiare layout id


Ho provato in tutte e due le maniere ma non va, una domanda : ogni volta che cambio il kext devo riavviare?

#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Certo, il riavvio è necessario



#11
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma
Comunque non funziona , hai qualche altra cosa che posso fare ? Ho provato ad editare il dsdt ma adesso non parte più che faccio ? Ricomincio da capo? Altre tutto mi ha rovinato ML che ho sullo stesso disco ma con partizione diversa, adesso questo parte solo con -v -x -f e l'audio non funziona più.
Ecco dove si blocca

Attached Files



#12
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Prova l'avvio con npci=0x2000 oppure 0x3000

Recupera il vecchio dsdt e reinseriscilo in extra

Se il dsdt attuale non ti permette l'avvio prova l'avvio con dsdt=/aaaaaaaa



#13
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

Prova l'avvio con npci=0x2000 oppure 0x3000

Recupera il vecchio dsdt e reinseriscilo in extra

Se il dsdt attuale non ti permette l'avvio prova l'avvio con dsdt=/aaaaaaaa

grazie, ma per l'audio posso fare qualcosa ? ho reinstallato mavericks, messo AppleHDA con kext utitlity e editato il dsdt con la stringa scritta ma niente.

io ho eliminato queste stringhe :

 Store (Package (0x0C)
                        {
                            "codec-id", 
                            Buffer (0x04)
                            {
                                0x89, 0x08, 0xEC, 0x10
                            }, 
 
                            "layout-id", 
                            /**** Is ResourceTemplate, but EndTag not at buffer end ****/ Buffer (0x04)
                            {
                                0x79, 0x03, 0x00, 0x00
                            }, 
 
                            "device-type", 
                            Buffer (0x0F)
                            {
                                "Realtek ALC889"
                            }, 
 
                            "model", 
                            Buffer (0x0F)
                            {
                                "Realtek ALC889"
                            }, 
 
                            "built-in", 
                            Buffer (One)
                            {
                                0x00
                            }, 
 
                            "PinConfigurations", 
                            Buffer (Zero) {}
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
 
con queste:

Store (Package (0x0c)

                    {                        

                        "built-in",

                        Buffer (One)

                        {

                            0x00

                        },

                        "layout-id",

                        Buffer (0x04)

                        {

                            0x04, 0x00, 0x00, 0x00

                        },

                       "PinConfigurations",

                       Buffer (0x00)

                       {

                           0x00

                       }

                    }, Local0)

                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

                    Return (Local0)

                }



#14
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Prova queste

 

                Store (Package (0x0E)
                    {
                        "AAPL,slot-name", 
                        Buffer (0x09)
                        {
                            "Built In"
                        }, 
                        "built-in", 
                        Buffer (One)
                        {
                             0x00
                        }, 
                        "device_type", 
                        Buffer (0x06)
                        {
                            "AUDIO"
                        }, 
                        "name", 
                        Buffer (0x0F)
                        {
                            "Realtek ALC889"
                        }, 
                        "model", 
                        Buffer (0x27)
                        {
                            "Realtek ALC889HD High Definition Audio"
                        }, 
                        "layout-id", 
                        Buffer (0x04)
                        {
                             0x0C, 0x00, 0x00, 0x00
                        }, 
                        "PinConfigurations", 
                        Buffer (Zero) {}
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
 
Associato a questo AppleHDA

Attached Files



#15
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

 

Prova queste

 

                Store (Package (0x0E)
                    {
                        "AAPL,slot-name", 
                        Buffer (0x09)
                        {
                            "Built In"
                        }, 
                        "built-in", 
                        Buffer (One)
                        {
                             0x00
                        }, 
                        "device_type", 
                        Buffer (0x06)
                        {
                            "AUDIO"
                        }, 
                        "name", 
                        Buffer (0x0F)
                        {
                            "Realtek ALC889"
                        }, 
                        "model", 
                        Buffer (0x27)
                        {
                            "Realtek ALC889HD High Definition Audio"
                        }, 
                        "layout-id", 
                        Buffer (0x04)
                        {
                             0x0C, 0x00, 0x00, 0x00
                        }, 
                        "PinConfigurations", 
                        Buffer (Zero) {}
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
 
Associato a questo AppleHDA

 

Che faccio monto prima il kext e poi modifico il dsdt ? un'altra cosa le icone degli HD sul desktop li vede solo come se fossero USM, solo alcune volte li vede  come normali HD (parlo sempre di icone)h

ho provato e non va, mi da errore quando salvo il dsdt



#16
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Allega il tuo DSDT



#17
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

eccolo

Attached Files



#18
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,605 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Ecco

Attached Files



#19
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 6,929 posts
  • Gender:Male
  • Location:Italy
Per l'audio usa questo : http://www.insanelym...hda-for-alc889/

Fabio

#20
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Gender:Male
  • Location:Roma

Ecco


Ok ! Con questi dsdt funziona perfettamente l'audio, unica cosa sono le icone degli HD che me li fa vedere come se fossero usb





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy