Jump to content

AppleHDA Patch Requests.


  • Please log in to reply
1565 replies to this topic

#41
karlcloudy

karlcloudy

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male

 

Re-use the AppleHDA
working the Mics + IOAUDIOFanily.kext.
 
repair permissions rebuild caches.
for your IOREg use this: IORegistryExplorer

 

 

The audio situation is still the same. The moment I use the patched IOAudioFamily, it prevents the audio from working. Using the stock IOAudioFamily produces the results I mentioned above (mic input working on the first micfix, but not the second, etc.). This IOreg is missing the audio device because AppleHDA isn't loading to begin with, because it doesn't like the patched IOAudioFamily kext.

Attached Files



#42
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil

Another alternative is this kext.

look here: https://github.com/D...Codec-Commander



#43
karlcloudy

karlcloudy

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male

Another alternative is this kext.

look here: https://github.com/D...Codec-Commander

 

Thank you, that kext does fix my speaker sleep issue :). Microphone is still a bit funny, but it works well enough (and with the speaker glitch solved, putting it to sleep is no longer an issue to fix the mic which I don't use too often anyway -- I usually use a headset).

 

Thanks for all the help  :thumbsup_anim:

 

PS: Have since found a fix for the internal mic dropout. Going into Audio MIDI setup and resetting the sample rate makes it start working again ;)


Edited by karlcloudy, 21 November 2013 - 11:49 AM.


#44
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil

Enjoy the good sound!!!



#45
JustinR1

JustinR1

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:New York, New York

Attached are my DSDT.aml, ioregistry, & codec dump card #1 & #2.

I have a Realtek ALC283, I am currently using voodoohda but it only suffices for a temporary fix, for I need to record and plug in headphones (which sounds really really bad on voodoohda). Hopefully you can get this working, I'd be very grateful. 

Attached Files



#46
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil

@JustinR1

try this, install AppleHDA+HDAEnabler.

Attached Files



#47
JustinR1

JustinR1

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:New York, New York

Here is my IOReg attached below after the kexts are installed.

Attached Files



#48
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil
I will send later
another test.


#49
JustinR1

JustinR1

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:New York, New York

Ok thank you Mirone, really appreciate you taking the time to help me get my audio working.



#50
PoisonApple666

PoisonApple666

    InsanelyMac Geek

  • Donators
  • 107 posts
  • Gender:Male
  • Location:USA

Hi,

 

I recently lost my audio in an update and for the life of me, this time I can't get it back.  I've uploaded the dsdt and the ioreg but not the 889 codec {Not certain how to do this ... if you can point me to some instructions, I cna try to install linux on a disk and do this.}

 

I really use the digital audio with a headroom dac and amp, but now i'm sorta dead in the water.  Any help or info would be greatly appreciated.

 

TIA

Rick

Illinois

Attached Files



#51
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil

@PoisonApple666

try this:

 

Attached Files



#52
JustinR1

JustinR1

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:New York, New York

Attached is my dsdt.dsl

Attached Files

  • Attached File  dsdt.zip   40.87KB   11 downloads


#53
PoisonApple666

PoisonApple666

    InsanelyMac Geek

  • Donators
  • 107 posts
  • Gender:Male
  • Location:USA

thanks mirone...I'll give it a shot....appreciate the fast response.



#54
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil

Attached is my dsdt.dsl

try this, delete HDAEnabler, install AppleHDA+DSDT.

Attached Files



#55
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Taiwan

Hi Mirone,

Could you take a look of my friend's X202E?

Sorry for not being able to dump the ioreg, as the machine is not with me.

Attached File  X202E.zip   32.6KB   4 downloads

 

I've made my version for him too, but according to my experience, I've never got laptop's sound card worked with AppleHDA. (System always failed to detect device in System Preferences) So I come here in case mine failed again...

I'll get his laptop on Saturday night (GMT) :lol: , so you don't need to do this in a hurry.

 

Thanks!



#56
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil
First try this,
and let me know if it worked for you.

Attached Files



#57
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Taiwan

@Mirone

Thanks.

I've taken a look on the Info.plist inside AppleHDAHardwareConfigDriver.kext, but I don't think it would work except IntSpeaker.

The X202E's codec are much different from the one you gave me.

Node 12   30 09 a6 90  [Fixed]  Mic      at Int N/A    Unknown
Node 14   10 01 17 90  [Fixed]  Speaker  at Int N/A    Unknown  EAPD 0x02
Node 17   f0 11 11 41  [N/A]    Speaker  at Ext Rear   Black
Node 18   f0 11 11 41  [N/A]    Speaker  at Ext Rear   Black    VREF_HIZ
Node 19   f0 11 11 41  [N/A]    Speaker  at Ext Rear   Black    VREF_HIZ
Node 1a   20 14 21 04  [Jack]   HP Out   at Ext Right  Black
Node 1b   f0 11 11 41  [N/A]    Speaker  at Ext Rear   Black
Node 1d   2d 81 05 40  [N/A]    Line Out at Ext N/A    Purple
Node 1e   f0 11 11 41  [N/A]    Speaker  at Ext Rear   Black
Node 21   f0 11 11 41  [N/A]    Speaker  at Ext Rear   Black

I'm confused by node 0x1d. According to the codec, it doesn't look like an output device.



#58
JustinR1

JustinR1

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:New York, New York

Hey bro, still no sound. I replaced the dsdt.aml with the one you sent me and the applehda.kext, removed the HDAEnabler but still nothing :/ it's not detecting anything in sysprefs->sound, either. What do you think we should do?

I guess this is harder than I thought. Do you need anything from me?



#59
Mirone

Mirone

    InsanelyMac Deity

  • Local Moderators
  • 1,611 posts
  • Gender:Male
  • Location:Brazil
This codec has many variations,
so said to try.

Hey bro, still no sound. I replaced the dsdt.aml with the one you sent me and the applehda.kext but still nothing :/ it's not detecting anything in sysprefs->sound, either.

I guess this is harder than I thought. Do you need anything from me?

send me the ioreg with the kext installed.



#60
JustinR1

JustinR1

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:New York, New York

 

This codec has many variations,
so said to try.

send me the ioreg with the kext installed.

 

Alright attached is my updated ioreg with the applehda.kext installed.

 

Attached Files







1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy