Jump to content

Thinkpad T430 - Mavericks 10.9.x

Thinkpad Thinkpad T430 T430 UEFI Mavericks 10.9

  • Please log in to reply
43 replies to this topic

#1
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

Hi guys,

 

I have almost working Mavericks 10.9 on my Thinkpad T430 and I would like to share my work to people have same hardware as mine. I also need some advise to complete my hackintosh :)

 

First thing first, my Thinkpad details specs:

- Model: Thinkpad T430 2344BMU
- lshw -numeric on Ubuntu 13.10

 

Hardware specs

Spoiler

 

 

* Working parts:

  • Intel HD 4000 (Capri): Full resolution: 1600x900, QE/CI
  • NVIDIA GF108M (NVS 5400M):  Full resolution: 1600x900, QE/CI
  • VGA, Display Port
  • Wired network / Ethernet
  • Think Light, Keyboard backlit (BIOS controlled)
  • Webcam
  • Mic, Speaker, Audio Jack
  • Bluetooth
  • Trackpoint, Touchpad
  • USB 3.0
  • Battery
  • UEFI with CLOVER r2366
  • Keyboard. Multimedia keys: Sleep, Prev / Play / Pause / Next (Brightness control with Fn-F8/F9 not work)
  • Shutdown / Restart / Sleep

* NOT working parts:

  • Intel Centrino Advanced-N 6205 Wireless adapter
  • Card reader

 

 

HOW TO:

 

1. Create Mac OS X Maverick 10.9 USB installer: Google it!

 

2. Install CLOVER EFI bootloader or Chameleon

Use my config.plist if you install CLOVER

NOTE: need to change the SMBIOS hardware section and CustomUUID to your own hardware.

 

3. Backup and copy kexts from attached file

 

4. Option: install LCD display profile

 

5. Option: install HWMonitor.app 

 

6. DSDT: Use diff tool to apply diff changes

a) I'm using 3 different DSDT file for 3 graphic config mode:

  • DSDT.d.dsl / DSDT.d.aml: for Discrete graphic only BIOS config
    • VGA, Mini-DP work well but hottest
    • Temperatures on my machine:
      • CPU: avg: 65oC, range: 60-85
      • GPU: avg: 60oC, range: 56-74
  • DSDT.o.dsl / DSDT.o.aml: for Optimus graphic BIOS config - NOTE: you will need to backup & remove  /S/L/E/NVDA* because of OS X not support Optimus mode and it caused conflict loading video driver.
  • DSDT.i.dsl / DSDT.i.aml: for Integrated graphic only BIOS config

B) Optimus & Integrated gave me much more cooler temperatures but NO VGA, Min-DP - I usually use Integrated mode for travelling and Discrete mode for work because I need extend to my external Dell monitor.

 

c) Temperatures when using Integrated only mode:

  • CPU: avg: 45oC, range: 40-70-80

d) I added FAN control to DSDT based on T420 / W520 guides, Thinkvantage button will be used to toggle turbo fan mode.

 

7. SSDT: I used auto generated P-States and C-States CLOVER's option

 

 

 

UPDATE:

 

 

10.9.1:

  • Sound stop working as AppleHDA.kext updated for VoiceOver bug fix, re-patch with patch AppleHDA script 3.1 from this thread
  • Everything work well as 10.9.0 as last. Still have problem with Shutdown / Restart / Sleep

 

10.9.3:

  • ​HWMonitor version 6.8.1307 support FAN sensor (Check for update inside app and install FakeSMC and all it's plugins)
  • NVIDIA: new version not work, replace with old working kexts (NV*.kext)
  • Intel HD 4000 Capri: patch with Platform-ID `0300 6601` - Hex: `01 00 00 00 02 00 00 00 30 02 00 00`
  • AppleHDA: patch-hda-3.1 NOT work - Work with VoodooHDA 2.8.4 (download from zip file here or pkg installer here
  • AppleIntelCPUPowerManagement.kext patch with AICPMPatch

  • Bluetooth: using modified kext from #26 (thanks @eilatuno)

  • Others old kexts: AppleACPIPlatform.kext, IOUSBFamily.kext
  • Shutdown / Restart / Sleep work well using latest CLOVER r2671

 

 

That's all, feel free to ask and discussion here about Mac OS X on T430 series, I will try to help if I can in my spared time.

 

May 22, 2014: Finished upgrade to 10.9.3, I will update package soon when I have free time.

Attached Files

  • Attached File  T430.zip   7.58MB   522 downloads

Edited by Uoc Nguyen, 22 May 2014 - 06:42 PM.


#2
TonyBurn

TonyBurn

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi,  when do you plan on posting kexts?  I've recently install 10.9 on my T430 however am yet to get USB3 or the webcam working.  I've used myhack/chameleon, should I instead be using clover to ensure success?

 

Aside from the Nvidia chipset, my hardware seems to be identical to yours.



#3
aerodt

aerodt

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi,

 

I bought a Thinkpad T430 last year and would like to install OS X Mavericks.  The H/W configuration is similar to you guys.  Could you guys please share the steps and procedures?

 

Many Thanks.



#4
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

Just to notify that I updated #1

 

Sorry for lately update, I was very busy and I can not find any spare time to collect changes, package them together and update guide.



#5
aerodt

aerodt

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Thanks Uoc Nguyen.  I'm new to hackintosh and I probably will have other questions be posted later.

 

Thanks again for your help.



#6
techitch

techitch

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Uoc Nguyen

 

I have T430 Model 2347-A82

 

Could you please post or MSG me the screen shots of your bios settings? I also would like to know if you used any switches to allow Mavericks to install I am currently getting the spinning loader to a black screen. If it helps to see my specs I can get these for you your help would be appreciated.

 

Also I was able to get Mountain Lion to work with some of the files you posted so I believe I am just missing something simple with Mavericks install.

 

Thank You



#7
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

@techitch: My BIOS config is normal, I enabled almost everything. You can see boot switches in CLOVER/config.plist file inside my attachment in post #1.

 

Let's post your screenshot of your boot progress with switch '-v' without quote.



#8
techitch

techitch

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

@Uoc Nguyen thank you for your response I think thats where I went wrong I used another method to boot because it was more straight forward for my new skills. May I ask how to find my SMBIOS and CUSTOMUUID? I found these values in your config.plist but I don't know how to get these values. I will work on using CLOVER in the morning to see if I get further installing OS X M. If it still hangs I will upload screen shot using -v switch


@ Uoc Nguyen: Found UUID in bios dough GOOGLE helps a lot!! working on SMBIOS now



#9
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

You can download Clover Configurator from here: http://mackie100.web...altervista.org/ -> generate new SMBIOS for you and copy it back to your config.plist

You can use SMBIOS MacBookPro 9.2 like me, it is for IvyBridge Core i5/i7.

 

About CUSTOMUUID, you can remove it if you can not found, find it in your BIOS main screen (BIOS / Main UUID)



#10
techitch

techitch

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

@Uoc Nguyen I'm stuck @ Clover step I was able to update config but can figure out how to boot to Clover. 

 

1. How should I format clover usb drive?

 

Thanks for any help you can provide.

 

Scott



#11
techitch

techitch

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
@uoc-nguyen

So I have created mavericks USB bootable disk using this command

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

I have modified config.plist
I have clover installed

I am stuck on configuring clover to boot so I can install mavericks

#12
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

  You must create a GPT UEFI compatible disk (Follow this instruction to create it: https://wiki.archlin...stem_Partition)

 

  In short, you must have an ESP (EFI partition), it is a small FAT 32 partition (about >= 128M depend your need) with EFISYS flag. It used to store CLOVER or any EFI firmware / bootloader, Linux kernel, config file, theme...

 

  After created a GPT partition you can verify it by command `sudo diskutil list /dev/diskX` with diskX is your USB disk, usually is disk1 as disk0 is your internal HDD, and you will see something like this:

Attached File  Screenshot 2013-12-27 00.37.46.png   46.12KB   13 downloads

 

I use some live Linux distro for some reasons, that's why my partition number 1 (EFI) is large.

 

  Since EFI partition is a system partition so Operating System usually hide it. You can mount it by command `sudo disk mount /dev/diskXsY` (if your EFI is first partition of your USB disk then diskXsY should be disk1s1). Now you can install CLOVER and copy config files... to this partition and create your Mac Installer Bootable USB.

 

  Hint: Press F12 to select boot from USB after reboot

 

Happy hacking!



#13
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

Finally, got wireless work with 7$ USB Wifi dongle with 150MB/s - http://www.comfast.c...duct168_en.html

 

Look like Realtek fault, the device show as ethernet instead of wireless and need to use Wireless Network Utilities to connect to AP.

 

Download Mac OS X 10.8 install package from this page. It work well for 10.9.1.



#14
winteum

winteum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

I own a T430 Type 2347A39.

 

After install your kexts I got everything working except the audio and the restart, sleep etc. I was working before the kexts installs...

But how did you got the fn-F9 to work for increase brightness?? My screen is too dark and I have no option to increase...



#15
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

I own a T430 Type 2347A39.
 
After install your kexts I got everything working except the audio and the restart, sleep etc. I was working before the kexts installs...
But how did you got the fn-F9 to work for increase brightness?? My screen is too dark and I have no option to increase...

  • Audio: you will need to patch AppleHDA and edit DSDT to use it, I'm patched and using the layout 28, you can use my patched AppleHDA version 2.5.3 from 10.9.1 Attached File  AppleHDA.kext-10.9.1.zip   1.13MB   32 downloads
  • For brightness, currently I'm using the _Q14, _Q15 (Fn-K, Fn-P) in DSDT to control the brightness. If you want to use Fn+F8/F9, you need to find out which Keycode used and will need to edit the DSDT or `/System/Library/Extensions/VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist`
  • IFAIK, Shutdown / Restart / Sleep may caused by UEFI CLOVER, I take some work around but it still not stable to use, it is needed to edit the DSDT _PTS, _WAK method, try to use some code from this thread http://www.insanelym...25#entry1952283 as reference. I tried a lots but still no luck.

Edited by Uoc Nguyen, 09 January 2014 - 04:09 AM.


#16
winteum

winteum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

My hardware is almost the same as yours. I using no UEFI for now, I'm booting with legacy.

I've installed all the kexts and display and was working as I wrote in the first post. After that, I added your DSDT without diff and got appleintelcpupowermanagement panic at the boot beginning.

I'll try again adding the DSDT first.

I'll try to use the fn-P K for brightness and your patched audio.

Thanks



#17
winteum

winteum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

No luck to install. Getting kernel panic. Could you please write a step by step what you did and in which order? 



#18
Uoc Nguyen

Uoc Nguyen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Can you boot with single user safe mode?
  • Did you repair the permission for kexts you copied from my attachment? if not, you can boot up with the install USB/DVD and repair it use this command: 
    chown -R root:wheel /Volumes/OSXROOT/System/Library/Extensions
    chmod -R 755 /Volumes/OSXROOT/System/Library/Extensions
    kextcache -u /Volumes/OSXROOT/
    

    replace OSXROOT with your mounted installed OSX volume



#19
winteum

winteum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

Using DSDT.i I could boot but Audio not working even with the patched kext and Video only VGA. Keyboad, TrackPad, Bluetooth, Ethernet Working.

Using DSDT.d Nvidia looks loads correct but blank screen after the boot.



#20
winteum

winteum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

Now I got almost everything working, thank you. Just the brightness of the screen is still annoying me. Altough I move to maximum, it still draker than I got in Windows... How to try to increase? DSDT edit? where exactly?







Also tagged with one or more of these keywords: Thinkpad, Thinkpad T430, T430, UEFI, Mavericks, 10.9


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy