Jump to content

Wallpaper Resets after Reboot and Mission Control has Another virtual Desktop Created

mavericks issue z87 asus ssd clover

  • Please log in to reply
2 replies to this topic

#1
aplats

aplats

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Not Telling

Hey guys, I really need help on this as I've tried many things and cannot get it working.

 

I have recently upgraded my hardware to what's in my signature. The order was, I updated my old computer to Mavericks, then switched out the motherboard, processor and video card. I got the boot working with Clover or with Chameleon from USB. The last thing I did was clone my hard drive to a new SSD (sped up boot from 1:30 to around 10 seconds).

 

I have this weird issue where 70% of the time when I reboot, my wallpaper on my primary (which is hooked to displayport so it shows as the second monitor) monitor is reset. If I launch mission control (used to be expose), I see on the top that I have extra desktops. So instead of just my Primary being Desktop 1 and my Secondary being Desktop 2, my primary desktop will also have Desktop 3 Desktop 4 and so on. I get a new desktop when I reboot. Sometimes I don't and the wallpaper I picked 5 reboots ago worked!

 

I have clover installed onto my EFI and is set for uEFI motherboards. I've changed tons of different settings in clover and nothing fixes it. I've even recreated the user account and it still isn't working.

 

It did seem to work for about 3-4 reboots when I created a temp user. I never even logged in as this user, I just created it. It may have kept working, but when I saw that happening, after a few reboots I decided to recreate the user account.

 

I have a self-made UUID in my config.plist for clover and I think everything else looks fine. I have a GTX 780, which seems to work fine with OS X drivers without doing anything special.

 

Is there a chance that OS X is loading faster than it is detecting my monitor, so it loads a default desktop? I don't know, that sound crazy, but I'm desperate...

 

I greatly appreciate any help as this and getting bluetooth to actually pair with my keyboard are my last 2 issues. 



#2
aplats

aplats

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Not Telling
I must be running into some unique issue, I can't find much about it anywhere.

#3
aphex6b

aphex6b

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male

i've come across sorta the same issues you are describing, in the sense of after a reboot sometimes, i see a wallpaper i did assign previously to that desktop... but it never really bothered me, i think it's some sort of cache issue with the windowserver or related once you start using multiple monitors... one thing you can try is when in mission control... to delete all screens... then perhaps clean the cache or something, however im not sure this helps. Also in 10.9 they did make alot of changes to the way apps(are assigned) and multiple spaces / screen behave in osx. But im not sure if this is related to the issue you'r describing because i might even have come across this in pre-mavericks times...







Also tagged with one or more of these keywords: mavericks, issue, z87, asus, ssd, clover


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy