Jump to content

Beginners guide to UEFI Triple/Dual boot OS X, Windows and Linux (Kali) on an single true-gpt ssd

dual boot osx windows efi gpt uefi clover acer s3 triple boot linux

  • Please log in to reply
152 replies to this topic

#141
ThunderBolt_Mac

ThunderBolt_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male

I installed every thing but Kali linux doesn't show in clover boot menu.



#142
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

I installed every thing but Kali linux doesn't show in clover boot menu.

 

How did you install it which partition? also uplload youre info.plist so i can take a look, n some cases we need to add the path manually



#143
ThunderBolt_Mac

ThunderBolt_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male

How did you install it which partition? also uplload youre info.plist so i can take a look, n some cases we need to add the path manually

 

I installed it in separate partition also ubuntu is installed ubuntu is listed in clover boot options but kali linux is not listed i can access it only from bios.

 

Attached File  Info.plist.zip   1.03KB   2 downloads



#144
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

I installed it in separate partition also ubuntu is installed ubuntu is listed in clover boot options but kali linux is not listed i can access it only from bios.

 

attachicon.gifInfo.plist.zip

 

Did you create the installer like my guide? Maybe you installed it in non-uefi mode, mbr.. instead. i will take a look at youre info.plist now

 

please upload CLOVER/config.plist instead of info.plist (my bad)



#145
ThunderBolt_Mac

ThunderBolt_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male

Did you create the installer like my guide? Maybe you installed it in non-uefi mode, mbr.. instead. i will take a look at youre info.plist now

 

please upload CLOVER/config.plist instead of info.plist (my bad)

 

It is installed in uefi mode. I have used the kexts suitable for my laptop.

Attached File  config.plist.zip   2.78KB   2 downloads

 



#146
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

It is installed in uefi mode. I have used the kexts suitable for my laptop.

attachicon.gifconfig.plist.zip

 

 

double check youre entries: take myne as example:

 

http://www.insanelym...-1#entry1968832

 

post #8



#147
ThunderBolt_Mac

ThunderBolt_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male

double check youre entries: take myne as example:

 

http://www.insanelym...-1#entry1968832

 

post #8

 

I didn't install windows, I uninstalled ubuntu but that didn't work too.

 

Edit: I installed VBoxExt4-64.efi driver and it worked


Edited by ThunderBolt_Mac, 29 April 2016 - 08:18 AM.


#148
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

I didn't install windows, I uninstalled ubuntu but that didn't work too.

 

Edit: I installed VBoxExt4-64.efi driver and it worked

 

Great to hear you got it working!



#149
davidosullivan

davidosullivan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

I set my Hackintosh up following these instructions sometime ago and I was just wondering if anyone has done an Upgrade to Windows10 from an earlier version?

 

If I let Windows update itself from 7 to 10 I dont suppose there is any chance the installer is clever enough for that to 'just work' with all this funky UEFI stuff is there?



#150
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

I set my Hackintosh up following these instructions sometime ago and I was just wondering if anyone has done an Upgrade to Windows10 from an earlier version?

 

If I let Windows update itself from 7 to 10 I dont suppose there is any chance the installer is clever enough for that to 'just work' with all this funky UEFI stuff is there?

 

Nope i didnt, but i do think windows will create its own partition correctly. But maybe you have to boot from clover usb again to add it as boot option. Make a image first with macrium reflect. So if anything goes wrong, you are able to revert it back easy. Good luck and let us know youre findings so we can write an post how to update and add it to Original Post



#151
DigiGoon

DigiGoon

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Trying to Dual Boot Mac OS X El Capitan and Ubuntu 16.04

 

Config:

HP-Pavillion-G6-2231tx

Intel Core i3-3110M

Intel HD4000

Realtek Ethernet

Clover Bootloader r3625

 

Partition-1: EFI

Partition-2: Mac OS

Partition-3: Ubuntu 16.04

 

Problem:

So my problem arose after I updated Ubuntu, in those update, there was a new kernel image too, so of course, Grub2 got reinstalled with new configs. After doing the update, Clover doesn't show up, and I get to it by Boot Device Options. Upon booting to Mac OS I reinstalled clover after deleting it from the EFI partition, Clover installed successfully, I then reboot the laptop, but guess what, it boots directly to Ubuntu. No matter how I do it, but now if there is Ubuntu folder with grub in EFI then the laptop boots directly into it whether the Clover is present or not.

 

Thank you, but please help. :)



#152
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

Trying to Dual Boot Mac OS X El Capitan and Ubuntu 16.04

 

Config:

HP-Pavillion-G6-2231tx

Intel Core i3-3110M

Intel HD4000

Realtek Ethernet

Clover Bootloader r3625

 

Partition-1: EFI

Partition-2: Mac OS

Partition-3: Ubuntu 16.04

 

Problem:

So my problem arose after I updated Ubuntu, in those update, there was a new kernel image too, so of course, Grub2 got reinstalled with new configs. After doing the update, Clover doesn't show up, and I get to it by Boot Device Options. Upon booting to Mac OS I reinstalled clover after deleting it from the EFI partition, Clover installed successfully, I then reboot the laptop, but guess what, it boots directly to Ubuntu. No matter how I do it, but now if there is Ubuntu folder with grub in EFI then the laptop boots directly into it whether the Clover is present or not.

 

Thank you, but please help. :)

 

Oki, please boot from the Clover USB, then go to some option in that menu to add it to the bios, then in bios you can change it to clover, i had this before with windows. please check and confirm, thank you



#153
IIIdefconIII

IIIdefconIII

    InsanelyMac Geek

  • Donators
  • 137 posts
  • Gender:Male
  • Location:Rotterdam
  • Interests:pc, hackintosh, servers, soccer, xbox360, work

my support stops here, i transferred to vmware cause i didnt want to do all the manuel patches each big update. ;) good luck!







Also tagged with one or more of these keywords: dual boot, osx, windows, efi, gpt, uefi, clover, acer s3, triple boot, linux


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy