Jump to content

Triple Boot: modificare il bootloader


  • Please log in to reply
4 replies to this topic

#1
strongmade2000

strongmade2000

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Female

Salve ragazzi.

Ho un Netbook in cui sono installati tre sistemi operativi: Ubuntu, Win 7 e Win 8. Vorrei provare a installare OS X nella partizione in cui è presente Win 8 perchè inutilizzato. Il problema sta nel boot. Sono presenti due boot: il primo, GNU GRUB (quindi creato da Ubuntu), che mi chiede di scegliere tra Ubuntu e Win 8; il secondo che mi appare nel momento in cui scelgo di avviare Win 8, che mi chiede di scegliere tra Win 8 e Win 7 (creato da Win 8). Senza fare alcun tipo di danni, come mi consigliate di fare? Eliminando il boot di Win 8, mi torna Win 7 "al posto" di Win 8 nel boot di Ubuntu? E quando installerò iPortable Snow Leopard (perchè ho letto che funziona meglio sui Netbook con processore Intel Atom), come dovrò comportarmi?

Scusate la confusione.  :rolleyes:  

Grazie.



#2
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,899 posts
  • Gender:Male
  • Location:Roma

secondo che boot vuoi utilizzare

 

se hai gia istallati w8 e ubuntu istalli osx e tramite chameleon gestisci il boot.

attenzione pero' quando istalli ubuntu, grub va istallato nella stessa partizione , no nell'MBR , seno chameleon non lo vede.

 

al boot di chameleon quando selezioni ubuntu partira grub, per non farlo vedere devi impostare Timeout di gru a 0, cosi non lo vedrai e parte subito ubuntu ( per fare questo trovi procedura su google)

qui http://askubuntu.com...ault-boot-entry

 

carlo_67



#3
marco.pisellonio80

marco.pisellonio80

    InsanelyMac Sage

  • Donators
  • 380 posts
  • Gender:Male
  • Interests:Libri, musica e natura

Scusate se mi inserisco,

carlo_67, voi parlate di triple boot, io non riesco neanche a fare un dual boot. Avevo installato windows 7 e linux mint, ho cancellato la partizione di linux e ho installato Mavericks. Partiva solo w7, per far partire Mavericks mi serviva una pen drive con chameleon, così Ludox mi consigliò di installare EasyBCD su windows così da poter scegliere quale far partire tra w7 e OSX. Easy BCD non funzionava e mi cancellava l'mbr di windows, al che sempre Ludox mi consigliò di formattare tutto l'HD in GUID (perchè OSX ci gira meglio) e di installare prima OSX e poi w7 e da lì Easybcd. In GUID Easybcd non mi cancella l'mbr di windows, ma non parte lo stesso. Selezionando Mavericks parte un chameleon incorporato in Easybcd, perchè ha le icone diverse dal chameleon installato su Mavericks e parte già col conto alla rovescia. Con quel chameleon Mavericks non riesce a partire, perchè dovrei modificare i flags, ma non so come fare perchè nelle impostazioni di Easybcd quel chameleon o configurazioni simili non ne trovo. Risultato: devo partire con la pen drive. E' una scocciatura e me lo eviterei volentieri.

Qualche suggerimento?



#4
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,899 posts
  • Gender:Male
  • Location:Roma

@Marco lascia perdere easy

formatta in guid, istalla win 7 poi osx e istalla chameleon

se win non parte piu'' lo ripristini col disco di istallazione


fai attenzione win 7 a volte non parte perché ha la flag di boot è sulla partizione file di sistema

quindi scarica partition magic, masterizzi il cd e avvii 

selezioni il disco, e metti la flag boot a riservato per il sistema



#5
marco.pisellonio80

marco.pisellonio80

    InsanelyMac Sage

  • Donators
  • 380 posts
  • Gender:Male
  • Interests:Libri, musica e natura

carlo_67

 

Lo avevo già fatto, ma una volta ripristinato il w7 col dvd di boot al riavvio avevo solo il w7, il chameleon era sparito. Però avevo installato prima OSX poi W7. Proverò a rifare la procedura installando prima W7

 

Quest'ultima parte non l'ho capita

 

"fai attenzione win 7 a volte non parte perché ha la flag di boot è sulla partizione file di sistema

quindi scarica partition magic, masterizzi il cd e avvii 

selezioni il disco, e metti la flag boot a riservato per il sistema"

 

ma proverò a rifare la procedura che mi hai consigliato e se non parte di nuovo, mi studierò la cosa.

Grazie e ciao.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy