Jump to content

Get iLife, iWork & Aperture for free


  • Please log in to reply
79 replies to this topic

#61
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary

I boot with clover like you, so I installed it only on the USB and with that I start my mavericks partition.

You need to specify "BoardSerialNumber" in "config.plist" file > "SMBIOS" section. (add a key named "BoardSerialNumber", and add <your serial number>+6digits to it as a string)

 

I think when you boot with clover, you already booting with the hfsplus.efi driver.

 

I didn't installed it into ESP and everything worked, so I think it should work without that.



#62
pepto

pepto

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

I boot with clover like you, so I installed it only on the USB and with that I start my mavericks partition.
You need to specify "BoardSerialNumber" in "config.plist" file > "SMBIOS" section. (add a key named "BoardSerialNumber", and add <your serial number>+6digits to it as a string)
 
I think when you boot with clover, you already booting with the hfsplus.efi driver.
 
I didn't installed it into ESP and everything worked, so I think it should work without that.


Oke i have searched my config.plist and i see not Boardserialnumber as string in smbios but what do you mean with "add <your serial number>+6digits" to it as a string) Where can i find the 6 digits or can i make it by myself.

Do you mean something like this Example:
<key>BoardSerialNumber</key>
<string>CXXX2BKXXXF+digits?</string>

#63
CarmeB

CarmeB

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
  • Gender:Male
  • Location:Catanzaro, Italy

I see many things that wrong in that config.plist, many dsdt and acpi fixes and patches applied to an already patched (your) dsdt, there is high chance that this causes problems. I'm on an ipod now, when I'll be at my PC, I'll post a modified config.plist which you could try.

I've created a new config.plist, using genconfig.

It's "plain" than the other :P I've written the custom uuid as suggested in the clover v2 guide, but iCloud, iMessage and AppStore don't work yet... -.-

 

EDIT: Hey guys! I'm happy to tell you that I did it! :D the problem was that I had not installed Clover in the ESP partition.

I've flagged in the Clover installer:

- Install Clover in the ESP

- Bootloader -> Install boot0af in MBR

 

Then I've followed the ErmaC guide about the iCloud fix, and I've found on internet also something about MLB and ROM: in MLB I've written the same code as "Board Serial Number" and in ROM my MAC code with also ":".

I don't know if it was a f***ing good luck or not, but it works like a charm :) And at the end: I have to copy the EFI folder also in the root of my 2 partitions? (I have Mountain Lion and Mavericks).

Thanks to all! :)



#64
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 930 posts
  • Gender:Male
  • Location:France

ok..

 

I don't have the boardserialnumber -> MAS error with Chameleon

 

I switch to clover (currently on USB stick) 

 

still no boardserialnumber as my capture shown -> MAS error vanished ... Aperture update fine.

 

So goodbye Chameleon after 4 years of use ; hello to Clover

 

 

EDIT : just discovered i can keep both Clover and Chameleon, so i'm gonna stick with the two :)

Attached Files

  • Attached File  done.png   173.11KB   9 downloads


#65
pepto

pepto

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

ok..

 

I don't have the boardserialnumber -> MAS error with Chameleon

 

I switch to clover (currently on USB stick) 

 

still no boardserialnumber as my capture shown -> MAS error vanished ... Aperture update fine.

 

So goodbye Chameleon after 4 years of use ; hello to Clover

Same for me did a clean install but now with clover boot loader and also no boardserialnumber but my life, aperture and iWork's is now updating :) 



#66
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 930 posts
  • Gender:Male
  • Location:France

Same for me did a clean install but now with clover boot loader and also no boardserialnumber but my life, aperture and iWork's is now updating :)

 

Even your life is updating ?  :thumbsup_anim:



#67
pepto

pepto

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Yes even my life 😎👍

#68
Johnny V

Johnny V

    InsanelyMac Sage

  • Donators
  • 372 posts

I need to get an iLife!

 

So can I just install clover with a running Mavericks system?



#69
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary

Yes, you can just run the installer.



#70
gladpants

gladpants

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Base install of clover as described above but not addition mods for anything like dsdt or smbios. Boots stock and was able to update everything. Perfect tut guys. 



#71
JorgeMax

JorgeMax

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 309 posts
  • Gender:Male
  • Location:Brasil-Piauí-Teresina
Guys, an update is available iMovie 10.0.1 November 20. And when I try to update it shows me that the AppStore ID: "l.a.b.u.s.h.e.w@gmail.com", and asked for the password. But I do not know that this is ID and do not even know the password.
I can not change for my ID at all! How to upgrade this application?


#72
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,248 posts
  • Gender:Not Telling

 

Guys, an update is available iMovie 10.0.1 November 20. And when I try to update it shows me that the AppStore ID: "l.a.b.u.s.h.e.w@gmail.com", and asked for the password. But I do not know that this is ID and do not even know the password.
I can not change for my ID at all! How to upgrade this application?

 

 

You may have downloaded a pirated version of iMovie that already contains the store receipt. Try downloading an untouched iLife installer and try it all again.



#73
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 401 posts
  • Gender:Male

I have a working hackintosh with Chameleon bootloader. All I did to get the iLife updates working for free was to create a Clover USB stick, then boot OS X using Clover, and then going to the App Store and click on update. The updates started working so I paused them, then rebooted using Chameleon and then opened the App Store and continued to download them and they installed just fine. Now they appear in the purchased tab. :)



#74
pippox0

pippox0

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 221 posts
  • Gender:Male
Very easy and usefull


#75
runner(PY)

runner(PY)

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Paraguay

Sup guys! Is this bug still working? I have just finished installing my new Hackintosh, but this method is not work for me.

These are the error messages i get while trying to update the apps. 

 

VK0UKAR.png
 
JG35Wfj.png
 
I installed Clover on a usb drive as you guys suggested with the default settings, am I missing something?
Thanks for the help!


#76
Onixs

Onixs

    Since 2007

  • Members
  • PipPipPipPipPipPipPip
  • 807 posts
  • Gender:Male

lol.. isn't that too obvious 



#77
runner(PY)

runner(PY)

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Paraguay

BTW, I am using the trial version of the apps, and it says that they belong to someone else.



#78
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,248 posts
  • Gender:Not Telling

You probably downloaded a pirated version which is linked to a specific AppleID. Try to download the trial from known websites instead of "sharing" websites. And make sure you have a custom "SerialNumber" and "BoardSerialNumber" in Clover's preferences. Clover Wiki - Clover Configurator.



#79
slemblod

slemblod

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
  • Gender:Not Telling

I was able to download the apps using this method, without a recovery partition.

2qS6PG3.png



#80
mendietinha

mendietinha

    mendi

  • Members
  • PipPipPipPipPipPipPip
  • 898 posts
  • Gender:Male
  • Interests:full hackintosh.

nice´n easy with a real mac.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy