Jump to content

[Guide] [Mavericks] AMD Radeon HD5450

ATI AMD Radeon HD5450 5450 Mavericks 10.9

  • Please log in to reply
107 replies to this topic

#21
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,805 posts
  • Gender:Male

Dr. Hurt, for some reason my AMD500Controller.kext does't have either an info.plist or a version.plist, otherwise that would be a piece of cake, since i've been adding my device ID (68F91002) to these since 10.7.5. So, could you either upload your edited kexts or at least the package contents for the AMD5000? 

 

All the best!



#22
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,805 posts
  • Gender:Male

I confess i'm having lots of difficulties to enable my HD 5450 Silent (device 0x68F91002) under Mavericks. The procedures i took for granted until now - editing the ATI5000 and the AMDx3000 kexts, adding Toleda's patch to my DSDT so i have HDMI audio and booting with GraphicsEnabler=No - aren't working for me this time: the stock AMD5000Controler.kext (formerly ATI5000) doesn't appear to have either an Info.plist or a Version.plist (it's not simply invisible, since ShowAllFiles doesn't make them to show up) and adding them by pasting Lion's both files didn't help at all. The result is i don't have either QE/Ci or proper resolution for my 40'' screen (connected via HDMI) or audio when I boot with GraphicsEnabler=No, and with GE=Yes i'd be stuck indefinitely with the spinning boot wheel. I'm yet to perform these troubleshooting steps:

 

 - Boot without my current DSDT (thus using GE=Yes): i don't know if something changed from ML to Mavericks in this regard;

 

 - Boot with PCIRootUID=1, both with and without my current DSDT;

 

 - Copy the plists from ML's kext instead of Lion's and apply all above steps.

 

If this doesn't take me anywhere, i'll really need help and will report here.

 

All the best!



#23
polyzargone

polyzargone

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:France

Yeah, same problem for me except that my IDs are different. I've got an MSI Radeon HD 5450 1 GB with id : 0x68f91002 and another one from Sapphire with id : 0x68e01002.

Like the others, my AMD5000Controller.kext has no info.plist on my both configs. I have restored them from the installer and replace the corrupted ones on my both systems. I've uncheck GraphicsEnabler and ATI Config with Chamelon Wizard but I still have no QE/CI support and even system freezes. With the editing method it's OK but I really want to use the DSDT way because it should solve my sleep issues.

Did I miss something ?



#24
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Yeah, same problem for me except that my IDs are different. I've got an MSI Radeon HD 5450 1 GB with id : 0x68f91002 and another one from Sapphire with id : 0x68e01002.

Like the others, my AMD5000Controller.kext has no info.plist on my both configs. I have restored them from the installer and replace the corrupted ones on my both systems. I've uncheck GraphicsEnabler and ATI Config with Chamelon Wizard but I still have no QE/CI support and even system freezes. With the editing method it's OK but I really want to use the DSDT way because it should solve my sleep issues.

Did I miss something ?

 

Here is the DSDT you uploaded a few post back (patched with the fake id).

 

Is this the one you wanted to patch?

 

Attached File  dsdt.aml.zip   9.38KB   27 downloads



#25
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Dr. Hurt, for some reason my AMD500Controller.kext does't have either an info.plist or a version.plist, otherwise that would be a piece of cake, since i've been adding my device ID (68F91002) to these since 10.7.5. So, could you either upload your edited kexts or at least the package contents for the AMD5000? 

 

All the best!

Thats strange. I have the plists in their place, as usual.

 

Here are the patched kexts.

(The forum uploader is not working for me).

http://www.speedysha...tched-kexts.zip



#26
polyzargone

polyzargone

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:France

Hi Dr. Hurt and thanx for your time.

The DSDT you provided to me is for the 0x68e01002 id's, right ?

 

I'll give a try but it seems that I used it a with my 0x68f91002 config which is not good of course.

Tell me if I'm wrong but I just have to modifiy the values with DSDT Editor to makes it work with my 0x68f91002 config ?

Attached Files



#27
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Hi Dr. Hurt and thanx for your time.

The DSDT you provided to me is for the 0x68e01002 id's, right ?

 

I'll give a try but it seems that I used it a with my 0x68f91002 config which is not good of course.

Tell me if I'm wrong but I just have to modifiy the values with DSDT Editor to makes it work with my 0x68f91002 config ?

 

No, you misunderstood that.

68E0 is the fake id we must use to trick the kext. The OS already sees your card as F9, so we use DSDT to make it see the card as E0 instead  :D

 

Just boot with the DSDT and the stock kexts.



#28
sjtuross

sjtuross

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Dr. Hurt, it's a special case here. I run OS X Mavericks in ESXi 5.1 as a virtual machine and passthrough the ATI HD5450 graphic card. I can enable the card by following your 2nd method i.e. change the kext drivers. It works perfectly.

 

I would like to enable the card by DSDT because I want to enable the HDMI audio and the onboard audio (also passthrough) later. I installed Chimera and changed my DSDT by following your 1st method, but it doesn't work. After the change, the PCIe graphic card is listed in the system report but the device-id is not changed to the fake one. According to IOReg, the display bridge seems to be PE40 instead of PEGP or PEG0. I attached both DSDT and IOreg files. Could you throw some light? Thanks a lot.

Attached Files



#29
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Dr. Hurt, it's a special case here. I run OS X Mavericks in ESXi 5.1 as a virtual machine and passthrough the ATI HD5450 graphic card. I can enable the card by following your 2nd method i.e. change the kext drivers. It works perfectly.

 

I would like to enable the card by DSDT because I want to enable the HDMI audio and the onboard audio (also passthrough) later. I installed Chimera and changed my DSDT by following your 1st method, but it doesn't work. After the change, the PCIe graphic card is listed in the system report but the device-id is not changed to the fake one. According to IOReg, the display bridge seems to be PE40 instead of PEGP or PEG0. I attached both DSDT and IOreg files. Could you throw some light? Thanks a lot.

 

In that case, you need to add the Device (GFX0) under the Device (PE40).

 

Here's your patched DSDT. Remember that to use it, you need to revert to stock kexts (ie. change back ids in kexts to original values).

Attached Files



#30
kofmasters

kofmasters

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:mexico

Sure, just upload it.

heres my dsdt,please edit for me     Attached File  dsdt.dsl.zip   12.48KB   14 downloads



#31
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

heres my dsdt,please edit for me     attachicon.gifdsdt.dsl.zip

 

Try this, and if it doesn't work, upload your ioreg.

Attached Files



#32
JuniorGump

JuniorGump

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Paraíba, Brasil
Dr. Hurt, as you would edit my DSDT? He is on the previous page.
 
 
Thank you very much.


#33
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

 

Dr. Hurt, as you would edit my DSDT? He is on the previous page.
 
 
Thank you very much.

 

 

Ooops, sorry about that  :blush:

Attached Files



#34
polyzargone

polyzargone

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:France

Hi Doc !

 

Sorry to bother you with that but I made so much tryes that my config has become a real mess. I even can't use the old editing method, ilt doen't works and I can't explain why. So let's start over :

Here's the DSDT with id : 68e41002

and the patched Kexts I actually use with this id (they don't work, I got an error at boot with AMDRadeonAccelerator : malformed kext, Device is in Slot 1)

 

So could you please patched my DSDT and take a look at my modified Kexts to tell me what going wrong ? I did the editing method a thousand times with others Radeon HD 5450 1gb and I never had so much problem to make them works. I'm wondering if the AMDRadeonAccelerator is still necessary with Mavericks so I tried without it but I got no QE/CI. With it it crashes and with GraphicsEnabler=No it doesn't but still no QE/CI.

 

Thanx for your time

Attached Files



#35
kofmasters

kofmasters

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:mexico

Try this, and if it doesn't work, upload your ioreg.


thanks i will try when i get home,idont know how to get ioreg but i will search for that info , thanku very much for edit my dsdt

#36
flava

flava

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Dr Hurt, please can you edit my dsdt for me ? my card is  a ATI Radeon HD 5400 series

 

Many thanks in advance  :) 

Attached Files



#37
JuniorGump

JuniorGump

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Paraíba, Brasil

Ooops, sorry about that  :blush:

Unfortunately it did not work. Still no QE / CI, even enabling GE.
 
The only kext related to amd is loading, is this one:

 

 

 

 65    0 0xffffff7f81a56000 0x7a000    0x7a000    com.apple.kext.AMDSupport (1.1.4) <64 63 11 10 7 5 4 3 1>

 
Still, thanks a lot for your help!  ^_^


#38
gonebytim

gonebytim

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi,

 

I was wondering if you could please please please edit my DSDT for me?

 

The Device ID for my card is 0x68f9

 

 

Attached Files



#39
XanthraX

XanthraX

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:Romania

Hi Dr. Hurt. I had problems installing Asus HD 5450 on my Asus P5K-VM Mobo. Currently I use Nvidia GeForce 9400 GT, but I keep getting fermi freezes. Well, with the original kexts, all I get is the fray screen with the spinning gear and I never get on the desktop. I edited the kexts, but all I got was a black screen. I am totally illiterate in editing dsdt. Can you do it for me please? And eventually tell me what you did and where. I may learn.

 

Many thanks in advance.

Attached Files



#40
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Hi,

 

I was wondering if you could please please please edit my DSDT for me?

 

The Device ID for my card is 0x68f9

 

Attached File  DSDT-GA-X58A-UD3R-2.0-FH.aml.zip   7.02KB   10 downloads

 

Hi Dr. Hurt. I had problems installing Asus HD 5450 on my Asus P5K-VM Mobo. Currently I use Nvidia GeForce 9400 GT, but I keep getting fermi freezes. Well, with the original kexts, all I get is the fray screen with the spinning gear and I never get on the desktop. I edited the kexts, but all I got was a black screen. I am totally illiterate in editing dsdt. Can you do it for me please? And eventually tell me what you did and where. I may learn.

 

Many thanks in advance.

 

Attached File  dsdt.aml.zip   14.32KB   7 downloads







Also tagged with one or more of these keywords: ATI, AMD, Radeon, HD5450, 5450, Mavericks, 10.9


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy