Jump to content

Mavericks AppleHDA HDMI Audio

AppleHDA HDMI Sound Realtek

  • This topic is locked This topic is locked
339 replies to this topic

#321
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

I didn't ignore the post.

IOReg/IOJones is not the problem. The other requested files are missing. Attach all Problem Reporting files.



#322
jgoens

jgoens

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:San Mateo

Attached File  DPCIboot log.rtf   9.12KB   3 downloads

 

I'm kind of struggling trying to figure out how to save the boot log from DPCImanager. I did a copy and paste of it. I never installed ssdt or dsdt. 

IOReg/IOJones is not the problem. The other requested files are missing. Attach all Problem Reporting files.

 



#323
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

I'm kind of struggling trying to figure out how to save the boot log from DPCImanager. I did a copy and paste of it. I never installed ssdt or dsdt. 

Not helpful. All the requested files in one post. Try again.



#324
jgoens

jgoens

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:San Mateo

Attached File  Jgoens requested files.zip   3.18MB   2 downloads

Not helpful. All the requested files in one post. Try again.

Hi Toleda, I recently installed Mavericks and do not have any sound via HDMI. HDMI is through my AMD 6800 card to a  stereo receiver which works fine with Windows system. I am trying to follow the guide HD3000 as well as OSX ssd  installation V3.  I have award BIOS f12. I am pretty Noob.

I downloaded MaciASL but am unsure of how to use it...I'm assuming that is how you patch?

. In the extra folder there is not any ssdt or dsdt installed. I tried just copying the ssdt.ami to the extra folder and nothing happened. I've spent a lot of time trying to remedy the no sound via HDMI and all leads point to the method described here.

 

 

 

 

 

 



#325
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

I recently installed Mavericks and do not have any sound via HDMI

HDMI audio is not native in OS X. See Post #1, edit the dsdt or install a ssdt. Download the guide for the selected method and install.



#326
jgoens

jgoens

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:San Mateo

HDMI audio is not native in OS X. See Post #1, edit the dsdt or install a ssdt. Download the guide for the selected method and install.


You are kidding me right? I have read that guide more than ten times and have uploaded requested files over and over yet you do not seem to want to assist me. This is easy for you yet you seem to want to belittle me as a grade school teacher does to a child who does not understand their homework. I don't have much experience in the hack but have invested a lot of time in learning about it and have had much help from another member as well who luckily has had patience with me. In the end it does not make a difference if the mac system does not
work perfect for me--but I can't believe someone with your ability finds it easier to play a noob off instead of simply "trying" to give some assistance.

#327
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

have uploaded requested files over and over 

All files show the same thing, no HDMI audio edits present.  Why?

No edits, your problem.



#328
jgoens

jgoens

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:San Mateo

All files show the same thing, no HDMI audio edits present.  Why?

No edits, your problem.

Right...the problem is, is I don't understand this:

[Guide]-audio_ssdt-hdmi-installation_v1.1

Location.aml - ssdt.aml installation folder

1. Chameleon: Extra/

2. Clover: EFI/Clover/ACPI/Patched/

Installation - HDMI audio ssdt (audio_ssdt-hdmi…)

1. Copy Downloads/audio_ssdt-hdmi.. . ./SSDT-1.aml to Location.aml

1. If Location.aml/SSDT.aml is present, install SSDT-1.aml as is:

Location.aml/SSDT-1.aml

2. If no Location.aml/SSDT.aml, rename SSDT-1.aml to SSDT.aml and

install as: Location.aml/SSDT.aml

3. The 1st SSDT is SSDT, 2nd is SSDT-1, 3rd is SSDT-2, etc.; no gaps

2. Enable SSDT

1. Chameleon - Extra/org.chameleon.Boot.plist

<key>DropSSDT</key>

<string>Yes</string

2. Clover_v2000+ - EFI/Clover/config.plist/ACPI/SSDT

<key>DropOem</key>

<YES/>

3. Rebuild kernel cache, see Tools 1.

4. Restart

5. Verify HDMI audio

 

 

 

I know I have award Bios..I tried simply placing the SSDT-1 file into my extra folder..that didn't work. Guess I need to use MacIasl? Problem is, is that I don't know how to do this and am not as savvy on what to do as you. That's why I came here looking for some direction.



#329
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

I tried simply placing the SSDT-1 file into my extra folder..

dsdt edits use MaciASL, ssdt does not need edits or MaciASL.

Chameleon use a particular order to load ssdts, explained in installation guide.

It says: if you do not have Extra/SSDT.aml rename SSDT-1.aml to SSDT.aml and install as Extra/SSDT.aml. Restart.

Reply with Chameleon Boot log, IOReg, and the installed ssdt.



#330
FarmerBill

FarmerBill

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I have attempted to use your audio_cloverALC-HDMI-110.command_v0.8.1 script to enable HDMI audio on my Hackintosh. It says: No AMD/Nvidia discrete graphics card found. I set gDebug=2 to get more info, output attached.

 

The machine has an Asus P8H61 motherboard running Mavericks OSX 10.9.5 with an Asus HD5450 Silent graphics adapter. It uses the AMD5000Controller and AMDRadeonX3000 kexts. I have to edit the AMDRadeonX3000 Info.plist to add the IOPCIMatch id 0x68E11002 for the graphics acceleration to work. This id is already in the AMD5000Controller Info.plist. I have previously used your audio_realtekALC-110_v1.0o1.command script to enable the ALC887 audio, which worked fine. I have also attached the output from the command 'ioreg -rxn PEG0@1' which picks up the graphics and HD audio, and a screenshot of IORegistryExplorer.

 



.

Attached Files



#331
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

It says: No AMD/Nvidia discrete graphics card found. I set gDebug=2 to get more info, output attached.

ioreg.txt and ioreg screenshots, not helpful. IOReg.../File/Save a Copy As...

script updated with display@0. Download from repo and run.



#332
FarmerBill

FarmerBill

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I have tried your updated script - it found the graphics card and installed a SSDT. After reboot HDMI audio does not appear in the sound preferences, so I ran the script again - it said AMD HDMI audio is not enabled, just like the first time. I have attached the output from running ioreg and the output from your script the first and second time.

Attached Files



#333
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

ioreg.txt again; Ignored Post #331.

See Problem Reporting, Post #1, attach all requested files.



#334
FarmerBill

FarmerBill

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Sorry, didn't realise you meant IORegistryExplorer. I can't get clover to generate a boot log file, I've checked the clover wiki but no joy.

Attached Files



#335
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

can't get clover to generate a boot log file

Clover log: DPCI Manager/Misc/Boot log

ssdt is not loading.

Config.plist is a disaster. Remove any property starting with #

 

ACPI/DSDT/Fixes/ Set the following properties to NO:

AddHDMI_8000000

FixDisplay_0100
FixHDA_8000
 
Set ACPI/DSDT/Debug/YES
 
Restart
Attach new files
Attach EFI/CLOVER/ACPI/origin/  (1st and last dsdt)


#336
FarmerBill

FarmerBill

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Ok, nothing in EFI/CLOVER/ACPI/origin/, nothing in EFI/CLOVER/misc, can't find a folder 'DPCI Manager' on the machine.

Attached Files



#337
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

Ok, nothing in EFI/CLOVER/ACPI/origin/, nothing in EFI/CLOVER/misc, can't find a folder 'DPCI Manager' on the machine.

Frankly, no difference between IORegs, was the edited config.plist installed?

See El Capitan AppleHDA HDMI Audio for

Post #1/IX - Tools/2. DPCIManager/Misc/Boot log

Post #1/IX - Tools/3. MaciASL/File/Extract Tableset....

 

Attach new files



#338
FarmerBill

FarmerBill

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I replaced some valid keys I cut out of config.plist. There are two OSX partitions on this disk - El Capitan and Mavericks. I thought that Clover was reading the config.plist on this partition - Mavericks as it is set as the DefaultVolume, but it appears to have been reading both. So I have made the same changes to the El Capitan config.plist. Now the HDMI audio works on Mavericks, I haven't got to El Capitan yet. It's working on El Capitan as well - Thanks.

Attached Files



#339
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

it appears to have been reading both. 

Not possibile, one or the other; BIOS setting.



#340
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,842 posts
  • Gender:Male

Mavericks AppleHDA HDMI Audio - Deprecated

Mavericks/solutions/support, see El Capitan AppleHDA HDMI Audio







Also tagged with one or more of these keywords: AppleHDA, HDMI, Sound, Realtek


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy