Jump to content

GTX660 OpenCL and Mavericks?


  • Please log in to reply
11 replies to this topic

#1
petaire

petaire

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hey guys ! 

 

I've got a brand new installation of the Mavericks GM on my Z87X-UD3H. Everything works like a charm, except my GTX660. On luxmark, I get 448, which is very low regarding to the other guys (they got something like 1158). Now, I know the problem is related to OpenCL, because FCPX doesn't work. I've got this error from FCPX everytime I open a video on the timeline or in the event manager, like ten per second : 

 

22/10/2013 11:12:32,812 Final Cut Pro[336]: dynamic_cast error 1: Both of the following type_info's should have public visibility.  At least one of them is hidden. 23PCSerializerWriteStream, 17PCHashWriteStream.
 
And after several minutes, FCP just crash. 
 
Do you guys have any idea? I'm pretty sure I have to enable OpenCL for my keprel card (which is 2GB of memory), but I honestly didn't found anything to do that on Mavericks…
 
Thanks a lot !
 
edit : And yes, I did tried with the other topic with the kext from the DP8, but still the same issue…


#2
petaire

petaire

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Really ? No one ?



#3
chris_27

chris_27

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Same problem here.



#4
jbaugh

jbaugh

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

I have the same problem.  It appears that this is a relatively uncommon problem, however.  So it may take a while to come to Apple's attention.

What hardware are those of you with this problem running?

I have a MacPro 4,1 with 32GB RAM.  Can't recall the GPU right at the moment.  I'll have to check that out.

John



#5
KasperNL

KasperNL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male

I have exactly the same issue with a 'GTX 650ti boost 2GB' card.

Console is full with 'OpenGL' related errors, OpenCL seems not supported according to several benchmark tools and the graphics performance is horrible, any ideas?

Kasper



#6
johansjg

johansjg

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

I have the same problem i have a gigabyte gtx 660 2gb, when i run Luxmark i only score 448. Still not any known way to fix it? 



#7
ineorfey

ineorfey

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Moscow
  • Interests:OS X

Somewhere I read that series 6xx 7хх Kepler videocards in OS X have no OpenCL support



#8
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 920 posts
  • Gender:Male
  • Location:The Streets

Kepler cards have OpenCL support. What they don't have is power management with OpenCL. So if you use it your card stays stuck in a high power state until reboot.

 

I used to have to patch my cards to enable OpenCL. Now I patch to disable it.

 

Just avoid nVidia if OpenCL is important to you. I doubt they're interested in properly supporting it considering it's competition for CUDA.



#9
mvd120

mvd120

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male

nVidia are developing current web drivers for 10.9.x. Hopefully in the future they will fix the openCL bugs.

 

If you are running 10.9.2 try the web drivers and the cuda drivers.

 

They wont help with the power management issues, but they might help with other errors you are having.

 

I know personally on my system they GREATLY improved my graphics performance with a kepler card using macpro 4,1 smbios.


Edited by mvd120, 09 May 2014 - 09:06 PM.


#10
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil

Heads up, your link points to an older set of web drivers.

 

Current ones are here: http://www.nvidia.co...spx/75319/en-us



#11
sselshamy

sselshamy

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
  • Gender:Male
  • Location:Egypt

 new web drivers for 10.9.3 ver 334.01.01f01 solved the problem

http://us.download.n....4.01.01f01.pkg 

 

I have tested previewing images using preview app and GPU clock slows down normally, no need to restart :D

 

Cheers



#12
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil

Confirmed!

 

Great news. Lower clocks = less heat, less fan noise and longer component life.

 

Here's some photo evidence - screenshots taken after running Oceanwave, Luxmark:

Attached File  Screen Shot 2014-05-16 at 21.18.04.png   579.72KB   11 downloads

Attached File  Screen Shot 2014-05-16 at 21.34.13.png   577.99KB   4 downloads

 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy