Jump to content

Can't get my hackintosh to sleep

sleep mountain lion 10.8.5 ga-x58a-ud3r

  • This topic is locked This topic is locked
22 replies to this topic

#21
vraiment

vraiment

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

his has been my adventure so far:

  1. I booted without tony's DSDT and installing NullCPUPowerManagement so I don't get a kernel panic for the lack of HPET, I got a "virgin" DSDT with MaciASL.
  2. Then I removed NullCPUPowerManagement, rebuild the kext cache and the permissions and boot with tony's DSDT, surprise surprise! sound doesn't work any more (to got it working originally I only used the patched AppleHDA from tony's tools).
  3. Using the default MaciASL "source" (the one called sourceforge) I applied the patch: "Remove WMI" to my "virgin" DSDT.
  4. From oralila I downloaded the following patches and applied them to my "virgin" DSDT:
    • Desktop -> DTGP, LPC NEHALEM
    • Misc -> AHCI SATA orange icon, Mac devices, New HPET, WAK
  5. I restarted with the new DSDT, I don't get the kernel panic for the HPET and that's cool. Then with IORegistryExplorer I got the "IOName" of my LPC device (which is called PX40 in the DSDT): "pci8086,3a16" and edited my AppleLPC.kext adding a new entry in "IONameMatch". After a restart my system now loads AppleLPC.

The decompiled DSDT obtained from this is attached to this post (is called working.txt).

 

Right now with this new DSDT the computer DOESN'T goes to sleep, doesn't shutdown and I don't have sound.

 

I have tried two of these audio injection methods (the one with the kext and the DSDT patches) with this AppleHDA patch and both give me sound but with lag and cracking noises.

 

As a side note, tony has a repo for MaciASL and in it a patch named "Award Gigabyte 1366 Fixes MacMan", so I gave it a shot with my virgin DSDT. Haven't tried sound but shutdown and sleep works but when I wake up my machine it restarts instead.

Attached Files



#22
PimentelX86

PimentelX86

    InsanelyMac Deity

  • Local Moderators
  • 2,445 posts
  • Gender:Male
  • Location:Area 51

Hello.

 

About Sleep... no more ideas...

 

But about audio, you can try use VoodooHDA. It is more compatible and works well. Version 2.8.4 is really great
Download: http://www.projectos...p?showtopic=355

 

But to me, your problems is related with tony tools

 

Try install the system again and use Chameleon and install all kext manually…you would earn much more with Chameleon… This is my opinion, because we are helping you on one thing that we don’t give support...

 

If you want to continue using the tony tools, you can post these problems in him forum ... I'm not being ignorant, I'm just giving advice.

 



#23
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

vraiment, please don´t post more issue TMC here, please read rules!!!!!

 

 

 

For all those who don't yet know our position about tonymac, and your ##### software, your Forun, Tolls, links, thank you for reading  http://www.insanelym...ort-tonymacx86/   

 p.s : pls read the forum rules  !!! 

InsanelyMac doesn't support tonymac's tools.







Also tagged with one or more of these keywords: sleep, mountain lion, 10.8.5, ga-x58a-ud3r


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy