Jump to content

How do I get my VGA port working?

vga port hd3000

  • Please log in to reply
4 replies to this topic

#1
vanquybn

vanquybn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
Hi All,
I have just install Mac OS 10.9GM, every thing work fine except the VGA port connector.
I also tried patch DSDT and AppleIntelGraphic kext. however i got fail.
Here are my laptop:
Dell inspiron core i7 2670QM
Graphich: HD 3000 (0116x8086) and Nvidia
Please help me!


#2
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 653 posts
  • Gender:Male

 

Hi All,
I have just install Mac OS 10.9GM, every thing work fine except the VGA port connector.
I also tried patch DSDT and AppleIntelGraphic kext. however i got fail.
Here are my laptop:
Dell inspiron core i7 2670QM
Graphich: HD 3000 (0116x8086) and Nvidia
Please help me!

 

You should get modgliani script at olaria.com (registering for free) to patch the pinouts of original AppleIntelSNBGraphicsFB.kext. The third table is edited for the vga port and the forth one is set to zero. Tables are fully working on a Lenovo EDGE E320.

 

HD3000 Table:
0000000: 0102 0300 1007 0000 1007 0000  ............
000000c: 0100 0000 0200 0000 3000 0000  ........0...
0000018: 0205 0000 0008 0000 0600 0000  ............
0000024: 0602 0000 1000 0000 0900 0000  ............
0000030: 0000 0000 0004 0000 0900 0000  ............

 

Have fun.



#3
vanquybn

vanquybn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male

You should get modgliani script at olaria.com (registering for free) to patch the pinouts of original AppleIntelSNBGraphicsFB.kext. The third table is edited for the vga port and the forth one is set to zero. Tables are fully working on a Lenovo EDGE E320.

 

HD3000 Table:
0000000: 0102 0300 1007 0000 1007 0000  ............
000000c: 0100 0000 0200 0000 3000 0000  ........0...
0000018: 0205 0000 0008 0000 0600 0000  ............
0000024: 0602 0000 1000 0000 0900 0000  ............
0000030: 0000 0000 0004 0000 0900 0000  ............

 

Have fun.

it's already done for me, and it didn't work :(



#4
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,035 posts
  • Gender:Male
  • Location:Brazil

Maybe this is useful somehow

http://www.insanelym...ble-hd4000-vga/



#5
LinK14

LinK14

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

I got the same problem here.

Dell Vostro with Sandy Bridge i5 and HD3000 (no discrete card).
DSDT patch (_DSM method) + kext patch doesn't work. I know it worked when I tried Moutain Lion (more than one year ago). But no luck with Mavericks.

 

EDIT : I made it work !!!

 

in the AppleIntelSNBGraphicsFB file, I edited each 0304 0000 0004 0000 0900 0000 found on the file.
In 10.9.1, there are 3 of them. I've replaced each three. And that works. Or more precisely "works". The screen is only detected when pluged in before booting the compture, or when it's sleeping. I don't know if it's possible to solve this.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy