Jump to content

[Guide] Mavericks 10.9.X - Dell Optiplex 780 (760)

- - - - - dell mavericks 780 optiplex tutorial osx hd5450 trackpad pdf Simon

  • Please log in to reply
314 replies to this topic

#301
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:France

Sorry for the late answer :P

 

Try this one :

 

 

Attached Files

  • Attached File  dsdt.zip   9.04KB   22 downloads


#302
Aromis

Aromis

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

can someone reupload the 

  • Install109.zip – This ZIP file contains everything that you need to get your flash drive properly prepared.


#303
serosis

serosis

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

 

can someone reupload the 

  • Install109.zip – This ZIP file contains everything that you need to get your flash drive properly prepared.

 

 

No need, you can access it via the Wayback Machine.



#304
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts

Hi,

I try to install 10.9 with a Asus GT610 (NVidia chipset), I know this video card is working in 10.10/10.11 with a 'generic' DSDT file under Clover.

But what to do when using Chameleon like in this guide?

I'm getting the same error "BootCacheControl: Unable to open /var/db/BootCache.playlist" as user 'justusiv' in message #175.

 

I boot with -f -x -v, GraphicsEnabler=No but it stops. First attempt was GraphicsEnabler=Yes (like in this guide) but that did not start the installer either.
 
Thanks for any help.


#305
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:France

@DutchAcerOne

 

Why use Chameleon :D ?

 

Spoiler


#306
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts

Why use Chameleon :D ?

This was a great idea, nearly everything is working, except the sound?
 
Remember I run 10.9 so maybe things are a bit different when using the instructions for 10.1x
 
I tried the Clover Injection method.
- In /S/L/E I installed with Kext Utility AppleHDA.kext (v272.18)
- File RealtekALC.kext is copied to EFI/EFI/Clover/kexts/9.1 (9.1 and not 10.10!)
- The config.plist from "Optiplex 780-760 Clover/Kexts/AppleHDA Sound Kexts/AppleHDA Patched For Injection" is copied in "EFI/EFI/Clover/"
- Rebooted.
 
But when I plug in my ear phone all is grey in the sound effects and in the output tab I only see my AppleTV.
 
Any ideas to solve this?


#307
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:France

Remember I run 10.9 so maybe things are a bit different when using the instructions for 10.1x


Indeed. You need to patch vanilla 10.9 AppleHDA first. Shouldn't be that hard though.

Show package content of El Capitan's AppleHDA then go to Contents/Ressources folder and copy/paste all LayoutXX.xml.zlib and platform.xml.zlib from there to the same place in your vanilla 10.9 AppleHDA. Rebuild cache then reboot.

I'm not sure but the Clover audio injection for El Capitan should work as well in Mavericks using the same settings. If not, try using Yosemite's settings.

I installed with Kext Utility AppleHDA.kext (v272.18)


Won't work. Ever. AppleHDAs are system specific and also update specific. In other words, AppleHDA from El Capitan won't work on previous OS X versions. However, you can use previous versions on new ones. It may work but it's not for sure.

File RealtekALC.kext is copied to EFI/EFI/Clover/kexts/9.1 (9.1 and not 10.10!)


:wacko: !

Why rename 10.9 folder to 9.1 ??? Non sense :P.

#308
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts
Thanks for the tips, and indeed the "9.1" was a typo, in reality I used "10.9".

#309
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts
Sound is working, thank you all the people of InsanelyMac!
I have made a donation! ??

#310
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,523 posts
  • Gender:Male
  • Location:France

@DutchAcerOne

 

Great news !

 

Did you use this ?

 

Indeed. You need to patch vanilla 10.9 AppleHDA first. Shouldn't be that hard though.

Show package content of El Capitan's AppleHDA then go to Contents/Ressources folder and copy/paste all LayoutXX.xml.zlib and platform.xml.zlib from there to the same place in your vanilla 10.9 AppleHDA. Rebuild cache then reboot.



#311
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts

Did you use this ?

Show package content of El Capitan's AppleHDA then go to Contents/Ressources folder and copy/paste all LayoutXX.xml.zlib and platform.xml.zlib from there to the same place in your vanilla 10.9 AppleHDA. Rebuild cache then reboot.

Not exactly, that did not work.

I used the files layout1.zml.zlib and Platforms.zml.zlib that I found in:

Optiplex 780 (760) El Capitan Clover-v3/Kexts/Sound/Clover_AppleHDA/

Copied these two files in a vanilla AppleHDA.kext, repaired, rebuild cache and rebooted.



#312
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts

I have a question about how the Intel Core 2 Duo is recognized in VirtualBox on 10.9.

Under OSX the processor of the Optiplex 780 is correctly recognized as dual core, for example in Activity Monitor.
But in the windows Task Manager (windows 7 VirtualBox 5.0.10) I see only a single core.
On my real Intel Core 2 Duo MacBook I see in VirtualBox two graphs but on the Optiplex 780 only one.
I can't find a setting in VirtualBox to adjust this, only the option for the numbers of processors but then I get a warning "not compatible settings" and that is correct.
 
Does someone know how to solve this?

Attached Files



#313
geveke

geveke

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Has anyone applied security update 2015-007 to an Optiplex 780 running Mavericks 10.9.5? Any problems?



#314
DutchAcerOne

DutchAcerOne

    InsanelyMac Protégé

  • Donators
  • 24 posts

Has anyone applied security update 2015-007 to an Optiplex 780 running Mavericks 10.9.5? Any problems?


I did, no problems.

#315
geveke

geveke

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I did, no problems.

Thanks for your reply. I installed it today, and apart from having to re-patch AMD5000Controller.kext and AMDRadeonX3000.kext everything went smoothly.

 

 

[edit]: Six days later I installed Security Update 2015-008. Again I had to re-patch AMD5000Controller.kext and AMDRadeonX3000.kext, but apart from that, no problems.







Also tagged with one or more of these keywords: dell, mavericks, 780, optiplex, tutorial, osx, hd5450, trackpad, pdf, Simon


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy